Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Kann man einen Server zur Performacesteigerung mit 2 Netzwerkkarten parallel an einem Switch betreiben? Wenn ja mit welcher Konfiguration ?

Frage Microsoft Windows Server

Mitglied: herber-herber

herber-herber (Level 1) - Jetzt verbinden

13.04.2009, aktualisiert 18.10.2012, 17080 Aufrufe, 2 Kommentare

Wir haben seit kurzem ein NAS was über zwei 1GB NIC´s im Modus Loadoptimierung an den Switch angeschlossen ist.
Dies wirft bei mir (als Nichthardwarespezi) die Frage auf, ob ich evtl. auch den 2ten bisher ungenutzten NIC des Server für so etwas mit nutzen kann?

Wenn dies geht, mit welche Konfiguration muss ich den 2ten NIC zur Performancesteigerung an den Switch anschließen?

Server:
SBS 2003 mit allen SP´s
Konfig NIC1
IP.192.168.1.11
Gatewaye.192.168.1.254
DNS1:192.168.1.11
DNS2:192.168.1.254

Clients:
XP pro. inkl. aller SP´s


Vielen Dank im voraus!
Mitglied: aqui
13.04.2009, aktualisiert 18.10.2012
Ja, generell klappt das vollkommen problemlos !!! Bei Microsoft Servern (oder PCs generell) nennt man diese IEEE 802.3ad Link Aggregation Teaming !!

Bei Intel Chip basierenden Treibern ist das z.B. die bekannte Intel Pro Suite und bei den ebenfalls sehr populären Marvel Chipsätzen auf Mainbords sind das diese Treiber die ein Teaming supporten:
http://www.marvell.com/drivers/driverDisplay.do?driverId=199
Broadcomm Chipsätze in HP Servern z.B.
http://www.broadcom.com/support/ethernet_nic/downloaddrivers.php
Haben eine Management Suite (BACS) die man mit den Treibern downloaden kann und die ein Adapter Teaming supportet.

3Com und andere NIC Hersteller haben entsprechende Treiber in ihren Download Bereichen im Web !

Diese beiden Threads hier:

http://www.administrator.de/forum/motherboard-mit-2-onboard-lan-anschl% ...
und
http://www.administrator.de/forum/traffic-am-server-auf-2-nics-verteile ...

sollten zudem alle deine Fragen zu diesem Thema beantworten !!

Was das Thema Konfiguration anbetrifft ist das mehr oder weniger Hersteller spezifisch. Bei Winblows Servern heist so ein Link Aggregation Teaming und der NIC Kartentreiber muss das supporten, was aber die meisten High End Karten heutzutage problemlos machen.

Auf der Switch Seite ist das auch sehr unterschiedlich und hängt von der Command Line Syntax ab. Hier mal 3 Beispiele (2 GiG Trunk) als Vergleichsübersicht mit einer Cisco Switch Konfig, einer Foundry Switch Konfig sowie einer HP Switch Umgebung:

Cisco Konfiguration:

interface Port-channel35
description 2 GiG Trunk zum Server
no ip address
switchport
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/1
description Erster 1 GiG Link
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-protocol lacp
channel-group 35 mode active
!
interface GigabitEthernet1/14
description Zweiter GiG Link
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-protocol lacp
channel-group 35 mode active


Foundry Konfiguration:

interface ethernet 1/1
port-name Erster GiG Link
link-aggregate configure key 10000
link-aggregate active
!
interface ethernet 1/2
port-name Zweiter GiG Link
link-aggregate configure key 10000
link-aggregate active

HP Konfiguration:

Bei HP Switches ist generell LACP im passive Modus auf allen Ports im Default aktiviert. Ob das nun sinnvoll ist oder nicht ist sicher diskussionswürdig aber nicht Thema dieses Threads.
Der HP Switch kann also sofort Links bündeln sofern die andere Seite (Server oder Switch) im LACP active Modus ist.
Den HP Switch kann man pro Port auch in den Active Modus setzen mit:
.
(config) # int eth 1 to 2
(eth-1-2) # lacp active
(eth-1-2) # write mem
Danach kann man sich wie bei den o.a. Switches auch mit
(eth-1-2) # show lacp
Den Trunking /Teaming Status ansehen !

Bei anderen Herstellern hast du halt andere Kommandos. Welche das sind steht im Handbuch unter Link Aggregation !!
Bitte warten ..
Mitglied: aqui
19.04.2009 um 20:01 Uhr
Wenns das jetzt war bitte dann
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Router & Routing
gelöst VPN-Server (Fritzbox) hinter Zyxel 5501 betreiben (7)

Frage von basti76nie zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...