Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Serverumzug Linux zu Windows - MySQL Problem?

Frage Entwicklung Datenbanken

Mitglied: Janosch2008

Janosch2008 (Level 1) - Jetzt verbinden

09.11.2010 um 10:40 Uhr, 4819 Aufrufe, 5 Kommentare

Hallo,
habe folgendes Problem und komme nicht weiter. In unserem Firmenintranet läuft ein Linux Server (Apache/2.2.11, MySQL-Client-Version: 5.1.33, PHP 5.2.9). Auf diesem Server wird eine Datenbankanwendung (PHP) ausgeführt und die Datensätze in eine MySQL Datenbank gspeichert. Läuft alles einwandfrei.
Da in unserer Firma nur Windows Server (Windows Server 2003 R2 Standard Edition) eingesetzt werden, soll der Linux Server auf Windows umziehen. Dort läuft PHP 5.3.3, Apache 2.2.17 und MySQL 5.1.51. Der Umzug war unkompliziert doch ich habe jetzt folgendes Problem: Ich kann keine Datensätze über die PHP Anwendung in der Datenbank abspeichern. Einen vorhandenen Datensatz editieren und ändern geht. Nur es lässt sich kein neuer Datensatz über die Anwendung anlegen. Wo könnte das Problem liegen? PHP? MySQL? in den PHP Scripten?

Gruß, Janosch
Mitglied: 60730
09.11.2010 um 10:57 Uhr
moin,

ich schreib dir ja nur ungern diese Zeilen...

  • wtf kommt auf die Idee eine Tuxbüxse gegen eine Winblows Büchse zu tauschen, wenn die vorherige Aussage ist

a) Läuft/lief alles einwandfrei.
b) dann auf W2k3, dessen Tage eh bald gezählt sind

Ich vermute mal, Ihr habt nicht alle Rechte übernommen und dürft deswegen keine Datensätze erstellen, oder eine Abfrage läuft auf der Tuxbüxse und eine auf dem Fenster.
Man weiß es nicht, jeder kocht da seine eigenen Suppen.

Gruß
Bitte warten ..
Mitglied: Janosch2008
09.11.2010 um 11:27 Uhr
Hallo,
die Linux Rechner werden von unserer IT nicht gewartet oder betreut. Deswegen soll alles vom laufendem Linux System auf Windows umziehen.
Gruß Janosch
Bitte warten ..
Mitglied: SlainteMhath
09.11.2010 um 11:54 Uhr
Moin,

Wo könnte das Problem liegen? PHP? MySQL? in den PHP Scripten?
Ohne das Du eine (brauchbare) Fehlermeldung aus dem System kitzelst lautet die Anwort 3x Ja plus das was Timo geschrieben hat

lg,
Slainte
Bitte warten ..
Mitglied: Janosch2008
09.11.2010 um 13:24 Uhr
Hallo,
möchte noch anmerken, das ich das ganze Lokal (Xampp, Vista) installiert habe. Dort funktionierts komischerweise.
Gruß, Janosch
Bitte warten ..
Mitglied: Janosch2008
10.11.2010 um 15:37 Uhr
Hallo,
das Problem liegt wohl bei MySQL unter Windows. Wir mussten im PHP-Script alle vorhandenen \" ersetzen in " oder Hochkommas.

Gruß, Janosch
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Netzwerke
Clientmanagement für Linux + Windows (3)

Frage von janne-s zum Thema Netzwerke ...

Windows 10
gelöst Windows 10: Problem mit Bitlocker (10)

Frage von honeybee zum Thema Windows 10 ...

Batch & Shell
gelöst Windows 7: Problem mit CP in Batch (3)

Frage von Maik87 zum Thema Batch & Shell ...

Verschlüsselung & Zertifikate
gelöst Sophos SafeGuard mit Windows CA Problem beim Ausstellen (1)

Frage von westberliner zum Thema Verschlüsselung & Zertifikate ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (19)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...