Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Set Befehl per GPO zieht nicht

Frage Microsoft Windows Server

Mitglied: Hasch5988

Hasch5988 (Level 1) - Jetzt verbinden

13.06.2012 um 08:43 Uhr, 3730 Aufrufe, 5 Kommentare

Hallo Kollegen,

ich habe folgendes Problem. Und zwar will ich die Umgebungsvariablen HOMESHARE, HOMEPATH und HOMEDRIVE per Policy setzen. Habe hierzu 2 Dinge probiert.

1. Die Umgebungsvariable per Policy setzen
2. Die Umgebungsvariable per Logon Script setzen

Es funktioniert leider beides nicht.

Verwendet wird eine XenApp 6 TS Farm basierend auf 2008 R2.

Komischerweise kann ich per Shell händisch die Variablen setzen.

Sobald ich bei der aktiven Session wo ich per Hand die Variablen setzen kann das .bat File mit den selben Befehlen ausführe funktioniert dies nicht. Hier handelt es sich um das selbe File das ich per Policy ausgebe.

set HOMEDRIVE=H:
set HOMEPATH=\
set HOMESHARE=\\srv.domain\Freigabe\%username%


Vielleicht mach ich auch einen konkreten Fehler den ich übersehe.


Schon mal vielen Dank für eure Bemühungen.

Mitglied: Penny.Cilin
13.06.2012 um 08:52 Uhr
Moin erstmal,

statt
 Set 
würde ich
 SetX 
nehmen. Sieh' Dir dazu die Syntax mit SetX /? an.
Bitte warten ..
Mitglied: Hasch5988
13.06.2012 um 09:20 Uhr
Besten Dank für den Tipp aber es liegt ja nicht daran das der "set" Befehl nicht funktioniert. Er funktioniert anscheinend nur nicht als .bat File.

Was für ein Syntax wäre denn sinnvoll deiner Meinung nach?
Bitte warten ..
Mitglied: 48507
13.06.2012 um 09:36 Uhr
Die Befehle gelten nur in der bat-Datei. Sprich, wenn sie ausgeführt und zu ist, ist die Session auch zu. Ich würde lieber mit der Registry (GPOs) arbeiten.
Bitte warten ..
Mitglied: Hasch5988
13.06.2012 um 10:01 Uhr
Das war wohl ein entscheidender Hinweis. Habs gerade noch einmal nachgestellt und du hast vollkommen Recht.
Bitte warten ..
Mitglied: Hasch5988
13.06.2012 um 10:59 Uhr
Funktioniert jetzt einwandfrei per Registry.

Herrzlichen Dank für die Hilfe.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst BATCH: Minuszeichen in set-Befehl (3)

Frage von Schottenrock zum Thema Batch & Shell ...

Windows 7
GPO Internet Explorer Wartung entfernen (3)

Frage von xbast1x zum Thema Windows 7 ...

Windows Server
gelöst Windows Firewall via GPO (2)

Frage von Ghost108 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows 7
gelöst BOOTMGR is missing (auch nach bootrec -RebuildBcd) (21)

Frage von Mipronimo zum Thema Windows 7 ...

Router & Routing
Tipps für Router (ca. 100 clients, VPN) (20)

Frage von oel-auge zum Thema Router & Routing ...

Windows Userverwaltung
Windows Freigabe: Zugriff auf alle Ordner trotz Sicherheitseinstellungen (18)

Frage von Pandreas zum Thema Windows Userverwaltung ...

Exchange Server
gelöst MS Exchange 2016 - Basicconfig Fragen (16)

Frage von maddig zum Thema Exchange Server ...