Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Sharepoint-Services WSS3 und Recovery bzw. wiederherstellung

Frage Microsoft Windows Server

Mitglied: MReimer

MReimer (Level 1) - Jetzt verbinden

03.03.2009, aktualisiert 11:25 Uhr, 7156 Aufrufe, 2 Kommentare

Hallo zusammen,

folgende Problematik:

Meine Sharepoint-Services WSS3 mit SP1 liefen bis jetzt ohne Probleme auf einem Windows Server 2003. Wir haben ausschießlich Dokumentenbibliotheken benutzt.
Ausserdem läuft noch ein WSUS mit auf dem Server, der sollte aber nichts zur Debatte tun.

Von heute auf morgen war die Zentraladministration nicht mehr erreichbar.
Es erscheint folgender Fehler:

Serverfehler in der Anwendung /.
Die DataSourceID von QuickLaunchMenu muss die ID eines Steuerelements vom Typ IHierarchicalDataSource sein. Ein Steuerelement mit der ID QuickLaunchSiteMap konnte nicht gefunden werden.
Beschreibung: Unbehandelte Ausnahme beim Ausführen der aktuellen Webanforderung. Überprüfen Sie die Stapelüberwachung, um weitere Informationen über diesen Fehler anzuzeigen und festzustellen, wo der Fehler im Code verursacht wurde.

Ausnahmedetails: System.Web.HttpException: Die DataSourceID von QuickLaunchMenu muss die ID eines Steuerelements vom Typ IHierarchicalDataSource sein. Ein Steuerelement mit der ID QuickLaunchSiteMap konnte nicht gefunden werden.

Quellfehler:

Beim Ausführen der aktuellen Webanforderung wurde einen unbehandelte Ausnahme generiert. Informationen über den Ursprung und die Position der Ausnahme können mit der Ausnahmestapelüberwachung angezeigt werden.

Stapelüberwachung:


[HttpException (0x80004005): Die DataSourceID von QuickLaunchMenu muss die ID eines Steuerelements vom Typ IHierarchicalDataSource sein. Ein Steuerelement mit der ID QuickLaunchSiteMap konnte nicht gefunden werden.]
System.Web.UI.WebControls.HierarchicalDataBoundControl.GetDataSource() +1483857
System.Web.UI.WebControls.HierarchicalDataBoundControl.ConnectToHierarchicalDataSource() +158
System.Web.UI.WebControls.HierarchicalDataBoundControl.OnLoad(EventArgs e) +16
System.Web.UI.Control.LoadRecursive() +47
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1436

--------------------------------------------------------------------------------
Versionsinformationen: Microsoft .NET Framework-Version:2.0.50727.1433; ASP.NET-Version:2.0.50727.1433


Googeln hat mich auch nicht sehr viel weiter gebracht. Meine Vermutung ist, es liegt wohl an der web.config. Aber was da genau nicht passen soll, ist mir noch ein Rätsel. Wir haben ja an den Files nichts geändert.

Dann habe ich den Konfigurations-Assistent für Sharepoint-Produkte und Technolgien gestartet, was wohl dann den ganzen Sharepoint ohne Rückfrage zurückgesetzt hat. (Tolles Tool..Danke)
Jetzt ist nichts mehr da. Die Websites sind weg aber dafür geht die Zentraladministration wieder

Ok. Damit die User wenigstens auf die Dokumente zugreifen können, habe ich den Server vorher in eine VM umgewandelt für Notfälle. Jetzt ist wenigstens das Portal wieder erreichbar.
So, auf den bisherigen Server gibt es ja jetzt keine Konfiguration mehr, ich habe aber ein Backup der Inhaltsdatenbank. Das Backup habe ich mit folgendem Befehl ausgeführt:

stsadm.exe" -o backup -directory c:\backup\ -backupmethod full

Versuche ich auf einem Test-System die Datenbank zurückzuspielen erscheinen aber auch diverse Fehlerchen.

z.B.
Fehler beim SharePoint - 80-Objekt im OnRestore-Ereignis. Weitere Informationen finden Sie im Fehlerprotokoll im Sicherungsverzeichnis. SPDuplicateObjectException: Ein Objekt vom Typ "Microsoft.SharePoint.Administration.SPWebApplication" mit dem Namen "SharePoint - 80" ist bereits unter "Microsoft.SharePoint.Administration.SPWebService" mit dem Namen "" vorhanden. Benennen Sie das Objekt um, oder löschen Sie das vorhandene Objekt.

Letztendlich weiss ich nicht wirklich wie ich jetzt weitermachen soll. Ich habe ein Backup kriege es aber nicht eingespielt. Die Konfiguration in der Zentraladministration muss ich sicherlich von Hand neu machen, da ich denke dass die Konfiguration nicht mitgesichert wird. Irgendwie muss ich doch die Inhaltsdatenbank wieder verknüpfen oder zurückspielen können.

Hoffentlich weiss jemand wie man da jetzt am besten vorgeht.

Jede Info ist Willkommen.

Danke.

Manuel
Mitglied: ANGER77
03.03.2009 um 11:50 Uhr
Hallo Manuel,

Erstens: Für die Zukunft würde ich von der Sicherung des Sharepoints mit
stsadm.exe abraten. Denn die Wiederherstellung ist sehr langwierig
kompliziert.
Ich benutze für solche Sachen DocAve von Avepoint -
www.avepoint.de

Zweitens: Googlen hilft doch^^

http://office.microsoft.com/de-de/sharepointdesigner/HA100699391031.asp ...

http://technet.microsoft.com/de-de/library/cc288965.aspx

http://www.sharepointcommunity.de/tabid/108/ctl/ArticleView/mid/457/art ...

und so weiter...

Gruß Enrico
Bitte warten ..
Mitglied: MReimer
06.03.2009 um 15:35 Uhr
hi,

thread kann geschlossen werden, habs wieder hinbekommen.

die reihenfolge bei der rücksicherung des backup`s und beim anlegen der neuen bzw. hinzufügen der alten inhaltsdatenbank
ist scheinbar von grosser bedeutung in der sharepoint welt

gruss
manuel
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Sticky Notes - Autostart unterbinden

Tipp von Pedant zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
SharePoint: Rechte in Listen

Frage von holladie zum Thema Windows Server ...

Windows Server
Sharepoint - Win10 fragt nach erneuter Authentifizierung, Win8.1 nicht (4)

Frage von DerWoWusste zum Thema Windows Server ...

Microsoft
SharePoint 2016 - SQL Server 2016 Planung (1)

Frage von Resolv zum Thema Microsoft ...

Heiß diskutierte Inhalte
Flatrates
DeutschlandLAN der Telekom - welche internen IPs? (19)

Frage von qualidat zum Thema Flatrates ...

LAN, WAN, Wireless
Wie Gäste ins Internet bringen? (15)

Frage von xSiggix zum Thema LAN, WAN, Wireless ...

Linux
gelöst Schmaler Scrollbalken in Python-Anwendung (14)

Frage von indi955 zum Thema Linux ...

Batch & Shell
gelöst Base64 Decode (Batch,VBS) (12)

Frage von clragon zum Thema Batch & Shell ...