Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Shell Scripten unter Debian

Frage Linux Debian

Mitglied: Friesco

Friesco (Level 1) - Jetzt verbinden

11.09.2009, aktualisiert 08:31 Uhr, 3715 Aufrufe, 2 Kommentare

Hallo liebe Gemeinde,

Ich hab da ein Problem mit einem Script da ich mich nicht so gut mit Scripten auskenne.
Also folgendes:
Ich frage via snmp bei einer USV die Batteriespannung ab mit folgendem Befehl
/usr/lib/nagios/plugins/check_snmp -H 192.168.0.101 -o .1.3.6.1.2.1.33.1.2.5 | awk '{print$4}'
Leider gibt er mir den Befehl nicht mit einer Kommastelle aus. Also die Batteriespannung beträgt 55,0 Volt aber ich bekomme den Wert 550 ausgegeben. Nun hatte ich die Idee das ganze in einem Script laufen zu lassen und der mir den Wert abfängt und ich einfach durch 10 teilt.
z.B. mit expr $WERT / 10. aber ich bekomme immer einen Syntaxfehler angezeigt da die Variable wohl leer ist nehme ich an.
Wie bekomme ich den Wert in eine Variable rein???

schonmal vielen dank für eure Hilfe !!!

Gruß
Friesco
Mitglied: CadelPigott
11.09.2009 um 12:30 Uhr
Hallo Friesco,

hast du mit dem befehl 'snmpwalk' mal geguckt ob es einen MIB gibt der dir den Wert mit Kommastelle zurück gibt?

Ich checke AMP USV´s auf die selbe Weise mit Nagios.
Allerdings würde es sowohl mit als auch ohne Kommastelle funktionieren. Ich überprüfe lediglich ob die Batteriespannung größer oder kleiner als der Schwellenwert ist.

Gruß
Cadel
Bitte warten ..
Mitglied: Friesco
11.09.2009 um 12:40 Uhr
ja aber die Riello teile geben dies leider nicht aus.

Ich hab aber das Problem gelöst.... Hier mein mini Script^^

WERT=`/usr/lib/nagios/plugins/check_snmp -H 192.168.0.101 -o .1.3.6.1.2.1.33.1.2.5 | awk '{print$4}'`
SPANNUNG=`expr $WERT / 10`

echo Die Spannung betraegt $SPANNUNG Volt.

Aber dann teilt er zwar durch 10, schneidet aber den rest ab....
MIt

WERT=`/usr/lib/nagios/plugins/check_snmp -H 192.168.0.101 -o .1.3.6.1.2.1.33.1.2.5 | awk '{print$4}'`
SPANNUNG=`echo "scale=2; $WERT / 10" | bc`

echo Die Spannung betraegt $SPANNUNG Volt.
Zeigt er mir dann die Zahl mit 2 Kommastellen an.

Trozdem danke für deine Hilfe...

Gruß
Friesco



Edit:
Das einzige was ich falsch gemacht hatte die ganze Zeit sind die Backticks die ich vergessen habe.
Und das ich hinter der Variablen (z.B. WERT) ein leerzeichen hatte ( WERT=_)
Bitte warten ..
Ähnliche Inhalte
Apache Server
gelöst Debian CPU Auslastung durch Apache2 sehr hoch (12)

Frage von zeroblue2005 zum Thema Apache Server ...

Hyper-V
Hyper-V 2016 Debian 8 VM frisst Speicherplatz (2)

Frage von m.reeger zum Thema Hyper-V ...

Batch & Shell
gelöst Variable in Makefile durch Shell Command (2)

Frage von nico1999 zum Thema Batch & Shell ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Exchange Server
Microsoft Exchange Weiterleitung mit anderer primären E-Mail Adresse (14)

Frage von Rene12345 zum Thema Exchange Server ...

Windows Userverwaltung
gelöst Wie verfahrt Ihr mit den Windows-Benutzerkonten und -dateien von ausgeschiedenen Mitarbeitern? (14)

Frage von Bl0ckS1z3 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Devolo DLAN 500 pro Wireless+ (13)

Frage von IceAge zum Thema LAN, WAN, Wireless ...

Microsoft
gelöst Subnetting: In welchem Subnetz befindet sich die IP? (12)

Frage von winler zum Thema Microsoft ...