Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Single Sign On VMWare Server 5.5

Frage Virtualisierung Vmware

Mitglied: KevinSesterhenn

KevinSesterhenn (Level 1) - Jetzt verbinden

16.01.2014 um 08:59 Uhr, 8757 Aufrufe, 12 Kommentare

Hallo zusammen,

wir haben 3 ESXi 5.5 Hosts und den VCenter Server als virtuelle Appliance laufen.

Für das SSO bin ich nach dieser Anleitung vorgegangen : http://www.virten.net/2013/09/howto-ad-authentication-in-vcenter-sso-5- ...
Leider funktioniert die Anmeldung über die Windows Sitzungsanmeldedaten im VMWare vSphere Client nicht. Windows übergibt den Benutzer im Format Domain/user.
Wenn ich meinen Benutzer im Format user@domain angebe funktioniert die Anmeldung ohne Probleme.

Danke für eure Hilfe!

Mitglied: tkr104
16.01.2014 um 11:14 Uhr
Moin,

mein Ansatz löst dein Problem zwar nicht, aber du kannst den vSphere Client mit Parametern für Server, User und Passwort aufrufen.

"C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\VpxClient.exe" -s <VCENTER SERVER> -u <USERNAME> -p <PASSWORT>

VG,

Thomas
Bitte warten ..
Mitglied: Rudbert
16.01.2014 um 11:52 Uhr
Hi,

hast du auch den AD-Gruppen entsprechende Berechtigungen im vSphere zugewiesen? Sonst könnte deine Anmeldung auch scheitern, wenn ein AD-Benutzer sich per SSO anmelden will, aber keiner vSphere-Berechtigungsgruppe zugewiesen ist.

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: KevinSesterhenn
16.01.2014 um 11:55 Uhr
Zitat von tkr104:

Moin,

mein Ansatz löst dein Problem zwar nicht, aber du kannst den vSphere Client mit Parametern für Server, User und Passwort
aufrufen.

"C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\VpxClient.exe" -s <VCENTER
SERVER> -u <USERNAME> -p <PASSWORT>

VG,

Thomas

Danke für den Ansatz. Leider ist das keine ausreichende Lösung für uns, aber gut zu wissen face-smile
Bitte warten ..
Mitglied: KevinSesterhenn
16.01.2014 um 11:59 Uhr
Zitat von Rudbert:

Hi,

hast du auch den AD-Gruppen entsprechende Berechtigungen im vSphere zugewiesen? Sonst könnte deine Anmeldung auch scheitern,
wenn ein AD-Benutzer sich per SSO anmelden will, aber keiner vSphere-Berechtigungsgruppe zugewiesen ist.

Mit freundlichen Grüßen

Ich habe meinem User im Vsphere die Rolle Administrator zugewiesen. Diese Berechtigung wurde auch bis nach unten an die Hosts durch vererbt. Anmelden kann ich mich manuell über meine Benutzer, wenn ich meinen Benutzernamen im Format user@domain eingebe. Nur die Automatische Weitergabe von Windows funktioniert nicht, da dann mein Benutzer im Format domain\user übergeben wird.
Bitte warten ..
Mitglied: Rudbert
16.01.2014, aktualisiert um 12:03 Uhr
Zitat von KevinSesterhenn:
Nur die Automatische Weitergabe von Windows funktioniert nicht, da dann mein Benutzer im Format domain\user
übergeben wird.

Daran liegts nicht, ist bei mir auch so, wenn ich den SSO-Haken setze, dann wird DOMAIN\user automatisch befüllt und funktioniert trotzdem (als auch die Anmeldung manuell egal in welchem Format).

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: KevinSesterhenn
16.01.2014 um 12:06 Uhr
Kann es sein, dass eventuell noch irgendwo eine Einstellung fehlt? Sind die Schritte in dem von mir verlinkten Artikel ausreichend?
Bitte warten ..
Mitglied: Rudbert
16.01.2014 um 12:11 Uhr
Zitat von KevinSesterhenn:

Kann es sein, dass eventuell noch irgendwo eine Einstellung fehlt? Sind die Schritte in dem von mir verlinkten Artikel
ausreichend?

Ich hatte auch den Artikel benutzt und irgenwas hatte da noch gefehlt - aber leider kann ich mich nicht mehr erinnern, was genau

Hast du unter SSO>Konfiguration>Identitätsquellen die AD-Domain als Standardquelle festgelegt?

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: KevinSesterhenn
16.01.2014 um 12:14 Uhr
Ja unsere AD-Domain ist als Standard festgelegt.

Ich habe leider auch in keiner anderen Anleitung weiter Optionen gefunden.
Vielleicht fällt es dir ja wieder ein.

Hat sonst einer eine Idee oder einen Lösungsansatz?

Danke
Gruß Kevin
Bitte warten ..
Mitglied: Rudbert
16.01.2014 um 12:16 Uhr
Dann bleiben dir wohl nur noch die Logs.

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: tkr104
17.01.2014 um 00:39 Uhr
Zitat von KevinSesterhenn:

Hat sonst einer eine Idee oder einen Lösungsansatz?


Moin,

Mach doch ein Ticket bei VMware auf, die helfen schnell und zuverlässig. Wir hatten in der 5.1 ein ähnliches Problem und haben dann auf Anraten des Supports und weil wir sie nicht brauchten die lokale Authentifizierungsquelle gelöscht. Danach funktionierte unsere AD Authentifizierung...

VG,

Thomas
Bitte warten ..
Mitglied: KevinSesterhenn
27.01.2014 um 15:43 Uhr
Ich werde das im Laufe der Woche mit unserem VMWare Partner klären.
Dann berichte ich wieder, falls ich eine Lösung habe ;)

Gruß Kevin
Bitte warten ..
Mitglied: ITApolda
18.09.2014 um 09:37 Uhr
Und hast du es lösen können?

Vielen Dank für deine Hilfe!
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Vmware
Storage für VMWare Server gesucht (10)

Frage von MichiBLNN zum Thema Vmware ...

Vmware
gelöst Server 2008 R2 in VMware (ESX-Farm) extrem langsam (10)

Frage von YotYot zum Thema Vmware ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...