Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Skript soll warten bis bestimmte Prozess nicht mehr läuft

Frage Entwicklung Batch & Shell

Mitglied: Dani

Dani (Level 5) - Jetzt verbinden

18.09.2014, aktualisiert 20:13 Uhr, 1287 Aufrufe, 3 Kommentare

Guten Abend Kollegen,
ich schreibe ein Powershellskript in dem ein Tool aufgerufen wird:
01.
... 
02.
notepad.exe /xxx /yyy 
03.
...
Das Skript wartet leider nicht bis das Tool fertig ist, sondern arbeitet die nachstehnenden Befehle sofort ab.

Mit dem cmdlet "Get-Process cleanmgr" erhalte ich die Rückmeldung ob der Prozess noch vorhanden ist. Leider habe ich keinen Ahnung, wie ich diese Ausgabe weiter verarbeiten könnte um an mein Ziel zukommen: Das Skript läuft erst weiter, wenn der Prozess nicht mehr vorhanden ist.

Das Skript läuft unter Microsoft Windows 7 (32 und 64Bit).


Gruß,
Dani
Mitglied: BirdyB
LÖSUNG 18.09.2014, aktualisiert um 20:13 Uhr
Hallo Dani,

Hier gibt es einen Lösungsansatz: http://stackoverflow.com/questions/1741490/how-to-tell-powershell-to-wa ...
Vielleicht hilft das ja weiter...

Beste Grüße

Berthold
Bitte warten ..
Mitglied: colinardo
LÖSUNG 18.09.2014, aktualisiert um 20:40 Uhr
N'Abend Dani,
01.
Start-Process <pfad zur exe> -NoNewWindow -Wait
oder auf das Ende eines Prozesses warten
01.
while(get-process 'cleanmgr' -ErrorAction SilentlyContinue){ 
02.
 sleep(1) 
03.
}
usw. und sofort
hier gibts noch mehr Varianten die ich hier schon mal gepostet hatte, inkl. einer Multithread Variante:

Grüße Uwe
Bitte warten ..
Mitglied: Dani
18.09.2014 um 20:13 Uhr
Guten Abend ihr Zwei,
vielen Dank für den schnellen Input.

Hab mich für die Variante Start-Process entschieden. Auf fünf Maschinen verliefen die Tests bisher positiv.


Gruß,
Dani
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Batch & Shell
Batch - Warten bis bestimmter Task läuft (5)

Frage von Winfried-HH zum Thema Batch & Shell ...

Windows Server
gelöst IIS Benutzerdefinierte Sitedelegierung mittels Skript (16)

Frage von EditorialBagPipe zum Thema Windows Server ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...