Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

sleep() Funktion Probleme

Frage Entwicklung PHP

Mitglied: adis22

adis22 (Level 1) - Jetzt verbinden

07.06.2008, aktualisiert 08.06.2008, 4670 Aufrufe, 5 Kommentare

Hallo , Habe die sleep funktion in einer wihle Schleife verbastelt;
01.
while(true) 
02.
03.
sleep(5); 
04.
echo 'hallo'; 
05.
}
Nu dachte ich alle füng Sekunden würde hallo ausgegeben, nur es tut sich nichts:
Habe ea auch mit for und do while, oder so versucht.
01.
$i=0; 
02.
while($i<10) 
03.
04.
sleep(5); 
05.
echo 'hallo'; 
06.
}
Das geht nicht, Warum, hat da einer ne Idee wie ich ein ständigen Zyklus durchlaufen kann. Dann mal danke im voraus für eure Hilfe.
Mitglied: kaiand1
07.06.2008 um 23:48 Uhr
Nun da fehlt noch bissel was....
und probier mal php error aus das zeigt dir fehler an
und auf der Seite
http://phpbox.de/php_befehle/while.php
hast du Beispiele wie die Funktionieren
Bitte warten ..
Mitglied: adis22
07.06.2008 um 23:58 Uhr
Danke für die schnelle Antwort
MFG Adis
Bitte warten ..
Mitglied: EvilMoe
08.06.2008 um 00:54 Uhr
Das Problem liegt daran das du eine Endlosschleif produziert hast!
Du hast vergessen den Zähler also "$i" zu erhöhen ($i++).



Aufbau von Schleifen findest du z.B. hier: http://www.infos24.de/phpe/handbuch/13_php_schleifen.htm
Bitte warten ..
Mitglied: filippg
08.06.2008 um 01:00 Uhr
Hallo,

ganz großartig, dass du nicht geschrieben hast, was nicht geht.
Problem dürfte aber sein, dass du das Prinzip von HTML nicht verstanden hast. Die Schleife wird auf dem Server ausgeführt. Standardmässig wird dann das Ergebnis am Ende des Skripts an den Browser gesendet, und der zeigt es an. Da nie zuende ist, wird das Ergebnis nie gesendet oder erst, wenn der Puffer voll ist.
Aber selbst wenn die Schleife nur z.B. 10mal ausgeführt wird, dann wird im Browser 50 sek (ist die Angabe nicht in ms?) nicht passieren, danach gleichezeitg 10mal hallo erscheinen.

Abhilfe: man kann PHP dazu bringen, alle bisher erzeugten Ausgaben an den Browser zu senden. Der Befehl könnte flush() heißen, such mal danach.
Alternative: JavaScript verwenden, das wird im Browser ausgeführt.

Gruß

Filipp
Bitte warten ..
Mitglied: adis22
08.06.2008 um 01:04 Uhr
Nein, so balt sleep() in der schleife ist tut sich nicht, ich habe Beispiele im Netz gefunden, warum geht es blos nicht bei mir, oooo man.

vielleicht noch ne Idee.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Yoursecurecloud.de Probleme mit Pfaden (6)

Frage von WPFORGE zum Thema Windows Server ...

Mac OS X
Probleme mit Freigegebener MAC Festplatte

Frage von mark16 zum Thema Mac OS X ...

Server-Hardware
HP Proliant ML30 + HPE H240 Probleme (7)

Frage von Sauropode zum Thema Server-Hardware ...

Outlook & Mail
Outlook 2016 Mails verschwinden - Probleme mit mehreren Postfächern? (6)

Frage von hannsgmaulwurf zum Thema Outlook & Mail ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(5)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Router & Routing

PfSense auf Supermicro Intel Xeon D-15x8 SoC Bare Bone

Tipp von Dobby zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (26)

Frage von FA-jka zum Thema Windows 10 ...

LAN, WAN, Wireless
Brauche Hilfe: Mit (schnellem) WLAN Strecke überbrücken (23)

Frage von pierrehansen zum Thema LAN, WAN, Wireless ...

Basic
Programmierung von Windows Programmen (10)

Frage von Ghost108 zum Thema Basic ...