Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SLES 10 - Anmeldung als root nicht mehr möglich

Frage Linux Suse

Mitglied: heparus

heparus (Level 1) - Jetzt verbinden

23.07.2009, aktualisiert 15:38 Uhr, 5994 Aufrufe, 1 Kommentar, 1 Danke

Hallo ich hab ein SLES 10 mit Samba auf einer IBM I6 am laufen, dessen Authentifizierung bis eben über Xerberos an unserem Windows Server 2003 lief. Auf wunsch der GL sollte kein Xerberos mehr verwendet werden und Samba mit LDAP laufen.

Mein Problem ist nun, dass ich mich an der Maschine weder über SSH noch über VNC anmelden kann. Ich erhalte immer die Fehlermeldung, es steht kein gültiges Anmeldeverfahren zur Verfügung.

Was war geschen: Da ich in Eile war habe über Yast den LDAP-Client konfiguriert und bestätigt. yast hat dann nachgefragt, welche Informationen er in zukunft nutzen soll, da ja der Xerberos-Client auch noch am laufen war. Ich hab dann LDAP gewählt und die Konfiguration wurde geschrieben, aber beim Starten der Dienste ist Yast bei 50% hängen geblieben. Ich wollte mir nun per SSH eine zweite Session öffnen und musste feststellen, dass ich mich als root nicht mehr Anmelden konte. Geschweige den einer der anderen User. Da die Maschine in einem externen Rechenzentrum steht, habe ich leider auch keinen physikalischen Zugriff auf das Gerät bzw. die HMC steht auch dort.

Ich hab eine Sicherung der Maschine mit Bacula von letzter Nacht, müsste mir aber dafür erstmal ne Boot-CD bauen, um die Sicherung zurückzuspielen. Außerdem müsste ich das Tape erst anfordern und hätte es erst frühstens morgennachmittag vorort.

Ich hoffe mir kann jemand weiterhelfen.
Mitglied: heparus
28.07.2009 um 17:19 Uhr
OK, ich hab es jetzt wie folgt gelöst.

Neugestartet und im Bootmanager mit init=/bin/bash gestartet. Und die Root-Partition zum lesen/schreiben gemountet.
Hab dann PAM (/etc/pam.d/common-auth, -account, -password und -session) kontrolliert und mehrere falsche Einträge entfernt. In common-password war ein Eintrag, welcher auf pam_unix2.so mit dem Parameter MD5 verwiess.
Anschliessend /etc/shaddow und /etc/passwd kontrolliert und aus shadow das root pw gelöscht.

Neugestartet, aber root liess sich immer noch nicht anmelden.

Wieder mit init=/bin/bash gestartet.
Dannach in /etc/nsswitch die Schalter wieder alles auf files gesetzt.
Und zum Schluss dem Root ein neues Password verpasst und neugestartet.

Siehe da seit dem kann man sich wieder lokal anmelden. Anschliessend LDAP wieder eingerichtet.

Warum die lokale Anmeldung nicht mehr funktioniert hat, ist mir bis jetzt schleierhaft.
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
Windows 10 Domänen beitrit nicht möglich (23)

Frage von simonlohr zum Thema Windows Netzwerk ...

Hyper-V
Win 10 HyperV Verbindung nicht möglich (3)

Frage von WPFORGE zum Thema Hyper-V ...

Windows 7
gelöst Windows 7 Home - Anmeldung nicht mehr möglich (6)

Frage von Munkel zum Thema Windows 7 ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(2)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (36)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Windows 10
Windows Store Apps ohne Windows Store installieren (10)

Frage von keefien zum Thema Windows 10 ...

Internet Domänen
Nameserver ein Geist? (9)

Frage von zelamedia zum Thema Internet Domänen ...