Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SMARTmon Tools und Blat zusammen nutzen!

Frage Microsoft Windows Tools

Mitglied: apnoe0381

apnoe0381 (Level 1) - Jetzt verbinden

04.08.2009, aktualisiert 21:16 Uhr, 5952 Aufrufe, 2 Kommentare

Hallo alle Miteinander melde mich hiermit in den Kreis und hoffe auf eure Hilfe bzw. Anregungen!

Das Vorhaben ist folgendes: Ich möchte mit den SMARTmon Tools die SMART Daten der Festplatte überwachen und wenn dort etwas nicht den Vorgaben entspricht soll eine E-Mail geschickt werden, damit man möglichst rechtzeitig reagieren kann! Den E-Mail Versand bei Fehlern ermöglicht SMARTmon soweit auch, dieses muss aber gemäß der man pages vom smartd (smart daemon) über Blat realisiert werden,...

Da ich in der smartd.conf nicht wirklich viele Daten an blat übergeben kann, versuche ich Blat soweit wie möglich schon einzurichten damit er Daten wie Postausgangsserver, Username und Passwort schon kennt. Dieses schreibt er mit folgendem Befehl in die Registry :

blat -install -f benutzername@mailserver.de -server mail.mailserver.de -port 25 -try 1 -profile profilname -u benutzername -pwd passwort

In der Registry sind dann die Werte unter "HKEY_LOCAL_MACHINE\SOFTWARE\Public Domain\Blat\..." zu finden. Was auffällt ist das Username und Pwd irgendwie cryptisch verschlüsselt in der Registry zu finden sind!

Login YmVudXR6ZXJuYW1l
Pwd LXB3ZA==
Sender benutzername@mailserver.de
SMTP 25
Server mail.mailserver.de
Try 1

blat -to admin@mailserver.de -body "testtext" -s "TESTbetreff" -p profilname -debug

Diese finden sich dann auch so cryptisch während des versuches eine E-Mail zu versenden wieder, was dann mit einem Error endet (authentication failure The SMTP server did not accept Auth LOGIN PASSWD value). Wenn ich die daten Blat direkt im Befehl übergebe funktioniert der E-Mail Versand problemlos!

Daher Hilfe

Vielen Dank
sebastian
Mitglied: KarlKommnichklar
05.08.2009 um 09:35 Uhr
Hallo Sebastian,
ich benutze Blat mit einer Konfigurationsdatei in der alle wichtigen Parameter drin stehen, der Aufruf erfolgt dann
über blat.exe -of konfigdatei, so sieht diese aus:

-server smtp.1und1.de
-f benutzer@online.de
-s "Betreff"
-i benutzer@online.de
-u benutzer@online.de -pw password
-tf recipient.txt
-cf cc.txt
-html
-bodyF htmlmailbody.txt
-embed bild.jpg
-alttextf mailbody.txt
-sig htmlmailsig.txt
-tag fortunes.txt
-attacht attachment.txt
-ps htmlfooter.txt
-log blatlog.txt -debug -timestamp
Blat ist deshalb genial weil es als einer der wenigen Kommandozeilen-Mailer
Emails mit voheriger Authenfizierung versenden kann. und dabei die eigentliche Email
aus mehreren Dateien zusammen setzt, siehe Konfigdatei, was die einzelnen
Parameter bedeuten ist ja in der Hilfe von Blat ersichtlich.

Gruss,

Karl
Bitte warten ..
Mitglied: apnoe0381
05.08.2009 um 11:19 Uhr
Hallo Karl,
danke für deinen Tip, das funkzt soweit problemlos im mom macht auch eher der smartd probleme da er bei einem test keine E-Mail versendet, wie er das eigentlich tun sollte. Hat jemand da schon eine funktionierende smartd.conf als beispiel zum versand von mails unter windows???

Grüße
Sebastian
Bitte warten ..
Ähnliche Inhalte
E-Mail
gelöst BLAT zum Mail versenden. Fehler für mich nicht lösbar (25)

Frage von 130217 zum Thema E-Mail ...

Utilities
Telefonkonferenzen - Tools - Sicherheit (2)

Frage von rjenuwein zum Thema Utilities ...

Grafikkarten & Monitore
AMD GPU zusammen mit Intel CPU (3)

Frage von KungLao zum Thema Grafikkarten & Monitore ...

Hyper-V
gelöst Disk2VHD Tool (3)

Frage von HansWurstAugust zum Thema Hyper-V ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 im Unternehmen? (26)

Frage von zorlayan zum Thema Windows 10 ...

LAN, WAN, Wireless
Ping u. DNS geht am Rechner nicht mehr (21)

Frage von Kuemmel zum Thema LAN, WAN, Wireless ...

Festplatten, SSD, Raid
Raid 1 2 SSD mit Windows Server 2016 (17)

Frage von jaywee zum Thema Festplatten, SSD, Raid ...