Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SMB Netzwerkperformance schlecht

Frage Linux Samba

Mitglied: FN2PGF

FN2PGF (Level 1) - Jetzt verbinden

14.08.2010, aktualisiert 19:17 Uhr, 9484 Aufrufe, 11 Kommentare

Hallo,

ich habe hier einen HP DL385 G2 mit Windows Server 2008 64-Bit und einen DL385 G6 mit Windows Server 2008 R2.
Beide hängen an einem Procurve Gigabit-Switch.

Vom G2 möchte ich eine Hyper-V Maschine auf den G6 kopieren, aber das geht elend langsam, laut Total Commander mit 2,5 MB/s!

- Jeweils das neueste Proliant Support Pack ist installiert
- Das Autotuning für das Netzwerk ist deaktiviert
- Ansonsten sind alle Netzwerkparameter, abgesehen von fester IP-Adresse, die Standardeinstellungen nach einer Neuinstallation
- Die Werte von netio sind aber in Ordnung:

01.
NETIO - Network Throughput Benchmark, Version 1.26 
02.
(C) 1997-2005 Kai Uwe Rommel 
03.
 
04.
TCP connection established. 
05.
Packet size  1k bytes:  103645 KByte/s Tx,  114009 KByte/s Rx. 
06.
Packet size  2k bytes:  115582 KByte/s Tx,  114644 KByte/s Rx. 
07.
Packet size  4k bytes:  115244 KByte/s Tx,  114006 KByte/s Rx. 
08.
Packet size  8k bytes:  114821 KByte/s Tx,  114562 KByte/s Rx. 
09.
Packet size 16k bytes:  115144 KByte/s Tx,  114149 KByte/s Rx. 
10.
Packet size 32k bytes:  115130 KByte/s Tx,  114188 KByte/s Rx. 
11.
Done.
Die Performanceprobleme beschränken sich jeweils immer nur auf das Kopieren von Daten von SMB-Shares innerhalb von Windows.
Auch mit einem Windows 7 Client verhält es sich so, dass die netio-Werte über 100MB/s liegen, aber Dateitransfers mit dem Windows-Explorer oder Total Commander erschreckend langsam sind.
Interessanterweise flutscht der Transfer vom G2 auf das Qnap NAS mit 70 MB/s. Das ist aber auch ein Linux und kein Windows.

Für Ideen und Vorschläge jenseits von "Probier mal ein Treiberupdate" bin ich dankbar.
Mitglied: aqui
15.08.2010 um 11:04 Uhr
Den TCP Stack hast du an die LAN Performance angepasst ?? Stichwort "Windowsize" ??
http://www.psc.edu/networking/projects/tcptune/
und
http://www.heise.de/netze/TCP-IP-Tuning--/artikel/97619
Bitte warten ..
Mitglied: FN2PGF
15.08.2010 um 14:00 Uhr
Nein, habe ich nicht.
Diese Optimierungen sind für ältere Betriebssysteme wie XP.
Server 2008, R2 und 7 haben den "Next Generation TCP/IP Stack", der sollte eigentlich von Haus aus bessere Performance liefern.

Außerdem mutet es etwas seltsam an, dass teuere Serverbetriebssysteme vom gleichen Hersteller an einem Gigabit-Switch untereinander Performanceprobleme bei Standardoperation wie Dateien kopieren haben.

Aber ich probiere es trotzdem gerne aus.
Bitte warten ..
Mitglied: aqui
16.08.2010 um 17:45 Uhr
Das kann auch am Switch selber liegen ! SMB/CIFS ist bekanntermassen ein sehr mieses Protokoll zum Datei Transfer, da es viele kleine Pakete benutzt und somit sehr ineffektiv ist. Abstriche muss man also immer machen !!

Wenn der Switch aber ein Billigteil ist ist deren Performance meistens sehr sehr mies was das Forwarding kleiner Pakete anbetrifft. Der Switch selber hat also auch einen nicht unerheblichen Einfluss !
Bitte warten ..
Mitglied: domisann
16.08.2010 um 19:31 Uhr
Das scheint am Server 2008 R2 zu liegen. Wir haben auch das Problem bei dem DL385 G6 unsere TSM Sicherungen durchzukriegen.
Habens jetzt mal mit 2003 R2 auf dem DL385 G6 probiert und schon flutschts. 4 fache Geschwindigkeit gegenüber dem 2008 R2.

Hab sowas gehört das es sich um ein bekanntes Problem bei dem DL385 G6 in Verbindung mit 2008 R2 gibt.

Wir setzen jetzt mal ein 2008 er Server auf und werden dann nochmal testen. Ich hoffe wir kriegen das diese Woche noch hin.

Werde das Ergebnis dann posten.
Bitte warten ..
Mitglied: FN2PGF
16.08.2010 um 20:25 Uhr
Zitat von domisann:
Das scheint am Server 2008 R2 zu liegen. Wir haben auch das Problem bei dem DL385 G6 unsere TSM Sicherungen durchzukriegen.
Habens jetzt mal mit 2003 R2 auf dem DL385 G6 probiert und schon flutschts. 4 fache Geschwindigkeit gegenüber dem 2008 R2.

Hab sowas gehört das es sich um ein bekanntes Problem bei dem DL385 G6 in Verbindung mit 2008 R2 gibt.

Oje, das wäre fatal. Vor allem, wenn man das HP glaubhaft nachweisen will.
Bitte warten ..
Mitglied: FN2PGF
16.08.2010 um 20:28 Uhr
Zitat von aqui:
Das kann auch am Switch selber liegen ! SMB/CIFS ist bekanntermassen ein sehr mieses Protokoll zum Datei Transfer, da es viele
kleine Pakete benutzt und somit sehr ineffektiv ist. Abstriche muss man also immer machen !!
Wenn der Switch aber ein Billigteil ist ist deren Performance meistens sehr sehr mies was das Forwarding kleiner Pakete
anbetrifft. Der Switch selber hat also auch einen nicht unerheblichen Einfluss !

Nun, zwischen "Abstriche machen" und 2,5 MB/s ist bei Gigabit-Ethernet durchaus etwas Spielraum.
Und einen HP Procurve Switch würde ich jetzt auch nicht als "Billigteil" bezeichnen.

Nimm's mir nicht übel, aber hast du meinen überhaupt Eingangsbeitrag gelesen?
Bitte warten ..
Mitglied: RottenSon667
22.11.2010 um 18:46 Uhr
Hast du das Problem mittlerweile gelöst? Auch wir haben hier mit der miesen Übertragungsgeschwindigkeit kleiner SMB-Pakete zu kämpfen. Windows2000Server hat das 2-4x so schnell bewerkstelligt.

Mit freundlichen Grüßen Maik
Bitte warten ..
Mitglied: FN2PGF
23.11.2010 um 12:11 Uhr
Leider nein.
Die meisten Vorschläge gehen auch in Richtung "probiere dies, probiere jenes", ohne vorher eine profunde Analyse zu durchzuführen.
Ich habe sogar bei der c't angerufen und darum gebeten, sich mal mit der Netzwerkoptimierung im LAN zu befassen.
DSL-Optimierungen findet man ja schon zuhauf.
Bitte warten ..
Mitglied: domisann
23.11.2010 um 16:22 Uhr
Wir haben als "Lösung" wieder den Server 2008 mit SP2 installiert. Also nicht den R2. Danach hats wieder gefluppt. Wenigstens die 3fache wenn nicht 4fache Geschwindigkeit. Eventuell werden wirs demnächst mal mit dem 2008 R2 mit SP1 versuchen.
Bitte warten ..
Mitglied: FN2PGF
24.11.2010 um 12:15 Uhr
Tja, den Server 2008 habe ich auch hier, der ist auch nicht besser.
Kopiere ich Daten vom 2008R2 zum 2008, komme ich auf 2 MB/s, mit Total Commander sogar 3 MB/s.
Mit XP 64-Bit als Gegenstelle ist es noch schlechter, da schaffe ich nicht mal 1 MB/s.
Und das ausgerechnet an den CAD-Arbeitsplätzen.
Bitte warten ..
Mitglied: RottenSon667
30.11.2010 um 10:16 Uhr
Hey, es KANN doch nicht sein dass das ein generisches Problem ist... Wir haben hier in einer Testumgebung alles mögliche getestet, von Netzwerkeinstellungen über Optimierung der Fileserverdienste. Nichts brachte etwas. Komischerweise ist bei Verwendung von Win7-Clients (die nur wir in der IT zum testen haben!!!) alles normal schnell....

Mit freundlichen Grüßen Maik
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
SAN, NAS, DAS
gelöst QNAP TS-453U - drei IP-Adressen für iSCSI , SMB , Management (2)

Frage von caspi-pirna zum Thema SAN, NAS, DAS ...

Samba
SMB Mount als unpriviligerter User (3)

Frage von Phill93 zum Thema Samba ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (10)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...