Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Software via GPO zuweisen funktioniert nicht...

Frage Microsoft Windows Server

Mitglied: ahstax

ahstax (Level 2) - Jetzt verbinden

08.02.2012 um 14:14 Uhr, 7393 Aufrufe, 4 Kommentare

Ich möchte Software via GPO installieren (lassen), was aber nicht funktioniert, obwohl die Richtlinie am Client (mittels gpresult) als angewendet angezeigt wird.

Hallo,

ein Clientrechner (WinXP SP3) soll mit einer Software versehen werden, die auf diesem (noch) nicht installiert ist.

Der Rechner ist im AD (Win Server 2003 R2) in einer Organisationseinheit (laut ldp.exe (verfremdet...):
OU=OU4,OU=OU3,OU=OU2,OU=OU1,DC=domain,DC=local
darin
CN=Client,OU=OU4,OU=OU3,OU=OU2,OU=OU1,DC=domain,DC=local
in der gpmc.msc habe ich ein Gruppenrichtlinienobjekt (ich hoffe, ich verwende die richtige Vokabel...) erstellt und dann mit der OU4 verknüpft.

Sicherheitsfilter: Authentifizierte Benutzer
(ich hatte da mal ne Gruppe mit dem Client drin, das funktionierte aber nicht, weswegen ich dann wieder die Originaleinstellung verwendet habe...)

In dem GPO ist in
Computerkonfiguration, Softwareeinstellungen, Softwareinstallation
ein (funktionierendes) MSI-Paket zugewiesen (!)...

Da ich entsprechendes als Fehlerquelle schon mal gelesen habe, habe ich "Sprache beim Bereitstellen... ignorieren" aktiviert.


Das mal für den Anfang...

Das Problem ist nun, dass die Software nicht installiert wird, obwohl am Client bei der Abfrage mit "gpresult" die GPO als angewendet angezeigt wird...

Kann mir jemand helfen? Kennt jemand das Problem?

Danke für Antworten schon jetzt!!!

Grüße aus Stuttgart,
Andreas


PS.: Ich "verwalte" zwar das Netzwerk, das heißt aber nicht, dass ich weiß, wovon ich rede...
Mitglied: SlainteMhath
08.02.2012 um 14:22 Uhr
Moin,

sieht soweit alles richtoig aus.

Fragen dazu:
- Was steht denn im Eventlogs des Clients? Falls bei der Installation Fehler auftreten sollten die da vermerkt sein.
- Wird per UNC auf das MSI verwiesen?
- Stimmen die Rechte auf das Share und den NTFS Ordern (Jeder=lesen)?

lg,
Slainte
Bitte warten ..
Mitglied: ahstax
08.02.2012 um 15:42 Uhr
Hallo Slaint,

  1. Da sind einige Fehler drin... s.u.
  2. Ja, via UNC. Allerdings sieht der recht lang aus... ( \\Server\Freigabe\01\02\03\04\05\Software.msi ) kann das daran liegen?Leerzeichen sind keine drin, allerdings Unterstriche.
  3. Auf die Freigabe hat die Gruppe "Jeder" Leseberechtigung. Ebenfalls auf die untergeordneten Ordner und das MSI-File. Allerdings... NTFS-Ordner? Mein Gesicht verzieht sich zu einem großen Fragezeichen... Hab ich das in jedem Fall, wenn diese Freigaben vorhanden sind (sein können)? Wie bekomme ich das heraus?


Hier ist "unten"...:
Alle EInträge des Eventlogs "Anwendungen" seit dem letzten Systemstart, zu dem die Installation hätte erfolgen sollen.
Mir scheint, da ist irgendwas krumm...?!?

-------------<SNIP>-----------------
Ereignistyp: Fehler
Ereignisquelle: AutoEnrollment
Ereigniskategorie: Keine
Ereigniskennung: 15
Datum: 08.02.2012
Zeit: 14:39:33
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die automatische Zertifikatregistrierung für "lokaler Computer" konnte keine Verbindung zum Active Directory (0x8007054b) herstellen. Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden.
Die Registrierung wird nicht durchgeführt.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Fehler
Ereignisquelle: Userenv
Ereigniskategorie: Keine
Ereigniskennung: 1054
Datum: 08.02.2012
Zeit: 14:39:32
Benutzer: NT-AUTORITÄT\SYSTEM
Computer: PC062-210211
Beschreibung:
Der Domänencontrollername für das Computernetzwerk konnte nicht ermittelt werden. (Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden. ). Die Verarbeitung der Gruppenrichtlinie wurde abgebrochen.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: SecurityCenter
Ereigniskategorie: Keine
Ereigniskennung: 1807
Datum: 08.02.2012
Zeit: 14:39:20
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Der Dienst "Sicherheitscenter" wurde beendet. Die Ausführung wurde durch eine Gruppenrichtlinie verhindert.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Fehler
Ereignisquelle: AutoEnrollment
Ereigniskategorie: Keine
Ereigniskennung: 15
Datum: 08.02.2012
Zeit: 12:49:30
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die automatische Zertifikatregistrierung für "lokaler Computer" konnte keine Verbindung zum Active Directory (0x8007054b) herstellen. Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden.
Die Registrierung wird nicht durchgeführt.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Fehler
Ereignisquelle: Userenv
Ereigniskategorie: Keine
Ereigniskennung: 1054
Datum: 08.02.2012
Zeit: 12:49:30
Benutzer: NT-AUTORITÄT\SYSTEM
Computer: PC062-210211
Beschreibung:
Der Domänencontrollername für das Computernetzwerk konnte nicht ermittelt werden. (Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden. ). Die Verarbeitung der Gruppenrichtlinie wurde abgebrochen.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: SecurityCenter
Ereigniskategorie: Keine
Ereigniskennung: 1807
Datum: 08.02.2012
Zeit: 12:49:17
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Der Dienst "Sicherheitscenter" wurde beendet. Die Ausführung wurde durch eine Gruppenrichtlinie verhindert.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: SceCli
Ereigniskategorie: Keine
Ereigniskennung: 1704
Datum: 07.02.2012
Zeit: 17:18:10
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die Sicherheitsrichtlinie in den Gruppenrichtlinienobjekten wurde erfolgreich angewendet.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: LoadPerf
Ereigniskategorie: Keine
Ereigniskennung: 1000
Datum: 07.02.2012
Zeit: 15:42:15
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die Leistungsindikatoren für den Dienst WmiApRpl (WmiApRpl) wurden geladen. Die Daten enthalten die dem Dienst zugeordneten neuen Indexwerte.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: 0c 14 00 00 ....


Ereignistyp: Informationen
Ereignisquelle: LoadPerf
Ereigniskategorie: Keine
Ereigniskennung: 1001
Datum: 07.02.2012
Zeit: 15:42:15
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die Leistungsindikatoren für den Dienst WmiApRpl (WmiApRpl) wurden entfernt. Die Daten enthalten die neuen Werte der Registrierungseinträge Last Counter und Last Help.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: f2 3c 00 00 f3 3c 00 00 ò<..ó<..
0008: 17 07 00 00 ....


Ereignistyp: Fehler
Ereignisquelle: AutoEnrollment
Ereigniskategorie: Keine
Ereigniskennung: 15
Datum: 07.02.2012
Zeit: 15:38:07
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Die automatische Zertifikatregistrierung für "lokaler Computer" konnte keine Verbindung zum Active Directory (0x8007054b) herstellen. Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden.
Die Registrierung wird nicht durchgeführt.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Fehler
Ereignisquelle: Userenv
Ereigniskategorie: Keine
Ereigniskennung: 1054
Datum: 07.02.2012
Zeit: 15:38:06
Benutzer: NT-AUTORITÄT\SYSTEM
Computer: PC062-210211
Beschreibung:
Der Domänencontrollername für das Computernetzwerk konnte nicht ermittelt werden. (Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden. ). Die Verarbeitung der Gruppenrichtlinie wurde abgebrochen.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Ereignistyp: Informationen
Ereignisquelle: SecurityCenter
Ereigniskategorie: Keine
Ereigniskennung: 1807
Datum: 07.02.2012
Zeit: 15:37:54
Benutzer: Nicht zutreffend
Computer: PC062-210211
Beschreibung:
Der Dienst "Sicherheitscenter" wurde beendet. Die Ausführung wurde durch eine Gruppenrichtlinie verhindert.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
-------------<SNIP>-----------------



Was könnte da denn falsch sein und wie könnte ich das beheben?

Grüße aus Stuttgart,
Andreas
Bitte warten ..
Mitglied: SirAnimus
08.02.2012 um 16:30 Uhr
Hallo

Würde mal folgende Richtlinie setzen. Computerkonfiguration -> Administrative Vorlagen -> System -> Anmelden-> Beim Neustart des Computers und bei der Anmeldung immer auf das Netzwerk warten, aktiviert.

Damit zuerst das Netzwerk richtig funktioniert bevor die Software installiert wird.


Als zweites könntes du mal versuchen die MSI lokal auf dem PC zu starten. am besten mit dem Parameter /qr. Damit die Installtion wie auch mit GPO ohne Benutzer Eingabe installiert wird.


Berechtigungen muss auch der Computer haben:

Zum testen mal auf dem Software-Ordner den Computer direkt zu den NTFS Berechtigungen legen.

Beispiel: Client002 - Lesen

Das gleiche auch auf dem Share



Mit freundlichen Grüßen
Bitte warten ..
Mitglied: ahstax
08.02.2012 um 16:51 Uhr
Interessante Neuigkeit...

Ob es da einen Zusammenhang gibt oder nicht, kann ich icht so genau sagen, dennoch:
Als ich gerade an dem Client ein wenig "rumgespielt habe, ist mir aufgefallen, dass unter
"Status von LAN-Verbindung" - "Eigenschaften von LAN-Verbindung" - "Eigenschaften von Internetprotokoll (TCP/IP)" - "Erweitert"
im Reiter "WINS" kein EIntrag vorhanden war. Darin habe ich die IPs der beiden Domänencontroler ergänzt, und die Software wurde installiert.
Wenn ich das nun reproduzieren kann, wäre ich der Lösung vermutlich sehr nah...!

Den Hinweis mit der Richtline "Warten bis Netzwerk" werde ich gleich umsetzen!!!
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...