Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Software und ISOs per PXE booten

Frage Linux

Mitglied: oi-polloi

oi-polloi (Level 1) - Jetzt verbinden

14.11.2009 um 10:39 Uhr, 7144 Aufrufe, 11 Kommentare

Hallo,

ich habe mir unter SUSE 10.3 einen DHCP-,TFTP- und NFS-Server aufgesetzt.
Alles funktioniert soweit.
Die Clients erhalten eine IP, wenn sie in der Liste sind. Sie starten mit ploplinux, memtest, und auch SUSE zur Installation sowie zwei weitere Diagnose-Tools.

Was ich gerne wissen möchte.
Ist es möglich ein ISO, IMG, IMA zubooten.

Mich interessiert vorallem M*DVD, Acronis, Knoppix und ein selbst erstellte BartPE. Falls es möglich ist weitere Images damit zu boote, wäre auch net schlecht.
Ich will keine Windows oder Linux Installation durchführen. Es sollen lediglich Diagnose-Tools damit gebootet werden.
Soviel ich weiß, wird ein Floppydisk emu benötigt, memdisk habe ich.
Hat wer damit schon Erfahrungen?
Google gibt nur Mist aus, nicht wirkich informatives.

Ich bin schon am basteln der default, aber ich hab keine Lust all diese veschiedene Möglichkeiten durch zu gehen.
Eventuell hat hier jemand einen Tipp oder die Antwort.

Cheers
Mitglied: oi-polloi
14.11.2009 um 12:11 Uhr
Ok...Arconis habe ich zum booten gebracht, nur bleibt er zur Zeit mit der Meldung
"Kernel panic: No init found. Try passing init= option to kernel" hängen.
Bis jetzt hat google nur da zu Lösungen für installieren Linux-vesionen ausgespuckt.
Hab auch schon versucht die init Angaben in der default mit zuübergeben mit =/etc/init und =/5 sowie /Pfad/kernel.dat, aber ohne Erfolg.
Bitte warten ..
Mitglied: 68162
14.11.2009 um 13:04 Uhr
Acronis TI10 geht z.B. mit

LABEL ti10
KERNEL /acr/KERNEL.DAT
APPEND initrd=/acr/RAMDISK.DAT vga=788 ramdisk_size=32768 acpi=off quiet

wobei man 'acpi=off' u.U. auch weg lassen kann.

KNOPPIX und Bart-PE usw. klappen meiner Erfahrung nach besser, wenn man die ISO auspackt.

Die obigen Pfade sind natürlich relativ zum definierten TFTP-ROOT zu sehen.

MfG, -FM-81-
Bitte warten ..
Mitglied: oi-polloi
14.11.2009 um 14:27 Uhr
@ -F-M-81-
du bist göttlich, danke danke...

ich weiß zwar net so recht wieso aber es geht.

Ich hatte zuvor diese Einstellungen gehabt.

label acronis
kernel /PFATH/kernel.dat
append initrd=/PRATH/ramdisk.dat ramdisk_size=32767 vga=791 root=/dev/ram0 init=/etc/init

an dem "zu kleinem" RAM kann es ja nicht gelegen haben...
so dann versuch ich gleich mal den Rest weiter :D

Knoppix und BartPE sind ausgepackt.

Danke dir noch mals
Bitte warten ..
Mitglied: 68162
14.11.2009 um 15:12 Uhr
root=/dev/ram0 init=/etc/init

Rootdevice brauchst Du nicht angeben, weil wird ja quasi "mit dem System innerhalb der INITRD bleiben". Und dort ein extra INIT angeben: Wozu ?

MfG, -FM-81-
Bitte warten ..
Mitglied: oi-polloi
15.11.2009 um 18:40 Uhr
das extra initrd habe ich aus der Konfig fürs Knoppix per PXE...
bin da noch recht unerfahren.
kennst du eine HP mit allen wichtigen Parameter die darin auch gut beschrieben sind?

cheers
Bitte warten ..
Mitglied: 68162
15.11.2009 um 19:33 Uhr
Zitat von oi-polloi:
kennst du eine HP mit allen wichtigen Parameter die darin auch gut
beschrieben sind?

Leider nicht! Was nicht bedeutet, daß es so etwas nicht gibt!

Im Zweifelsfalle nehme ich die INITRD des betreffenden Live-Linux auseinander, und probiere, was ich mir so denke ...

GRML z.B. funktioniert problemlos, irgendwo auf den dortigen Seiten wirst Du eine angepasste INITRD finden.

Zu Bart-PE kann ich das http://oss.netfarm.it/guides/pxe.php empfehlen.

MfG, -FM-81-
Bitte warten ..
Mitglied: oi-polloi
16.11.2009 um 22:22 Uhr
ok danke dir

schade das es keine man dazu gibt.

in wieweit kann man die initrd aus einander nehmen?
mount -o loop ?
Bitte warten ..
Mitglied: 68162
17.11.2009 um 06:38 Uhr
Seit Kernel 2.6.irgendwas ist die INITRD ein CPIO-Archiv ...

Für KNOPPIX 6 habe ich hier schon vor einiger Zeit mal was gebastelt:
http://www.file-upload.net/download-1697960/minirt-nfs.gz.html

Für GRML gibt es das auf deren Website (ist leider etwas versteckt, weiß den Link nicht mehr).

Zugehörige Konfigs kann ich leider erst am WE posten.

MfG, -FM-81-
Bitte warten ..
Mitglied: oi-polloi
17.11.2009 um 12:22 Uhr
ok danke.

ich hab schon mal versucht mit so einer miniroot.gz zuarbeiten.
habe sie gemountet, aber die hinzugefügten Treiber *.ko wurden nicht erkannt. Kann es sein, weil ich sie nicht mit insmod=e1000e.ko in der append mit angegeben haben, das sie nicht automatisch vom Kernel mitladen wurden?

cheers
Bitte warten ..
Mitglied: 68162
18.11.2009 um 06:28 Uhr
Zitat von oi-polloi:

ich hab schon mal versucht mit so einer miniroot.gz zuarbeiten.
habe sie gemountet, aber die hinzugefügten Treiber *.ko wurden
nicht erkannt. Kann es sein, weil ich sie nicht mit insmod=e1000e.ko
in der append mit angegeben haben, das sie nicht automatisch vom
Kernel mitladen wurden?

Im richtigen Verzeichnis waren sie ja bestimmt? Und die Kernel-Version passte auch? Dann könnte man noch versuchen zu verstehen, was die internen Scripte machen, aber das ist Friemelarbeit...

Den 'insmod'-Parameter habe ich noch nie gebraucht, aber das muss garnichts bedeuten.

MfG, -FM-81-
Bitte warten ..
Mitglied: oi-polloi
18.11.2009 um 18:48 Uhr
Im richtigen Verzeichnis war der Treiber schon,aber warscheinlich der falsche Kernel...

Aber zur Zeit läuft erst mal das was ich will
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Cisco W-Lan Controller als Applicance oder Software (11)

Frage von Herbrich19 zum Thema LAN, WAN, Wireless ...

Sicherheits-Tools
Dr. Keiser PC Wächter gegen Erpressungs Software (10)

Frage von Herbrich19 zum Thema Sicherheits-Tools ...

Erkennung und -Abwehr
Dramatische Sicherheitslücke in Virenschutz-Software von Windows geschlossen (8)

Link von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Neue Wissensbeiträge
Administrator.de Feedback

Umgangsformen auf der Seite

(3)

Information von Frank zum Thema Administrator.de Feedback ...

Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(10)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Exchange Server
gelöst RU 17 Exchange 2010 . Erfahrungen? (11)

Frage von keine-ahnung zum Thema Exchange Server ...

Windows Server
Festplatten Ruhezustand Windows Server 2016 (10)

Frage von ahaeuser zum Thema Windows Server ...

Datenbanken
gelöst MySQL Zeiterfassungs-Problematik (wer ist eingecheckt) (9)

Frage von NativeMode zum Thema Datenbanken ...