Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Software per WSH deinstallieren

Frage Entwicklung VB for Applications

Mitglied: David81

David81 (Level 1) - Jetzt verbinden

30.03.2007, aktualisiert 12.04.2007, 8646 Aufrufe, 3 Kommentare

Sallo zusammen

Habe hier ein VBScript (WSH)

Ich möchte ein Script per GPO verteilen und so gewisse Software aus der Systemsteuerung deinstallieren. Habe zu diesem Thema folgendes gefunden, nun ist mir aber unklar, wie ich dies auf den Rechner anpassen kann, wo die GPO greift.

' Deinstall_Software.vbs
' Deinstalliert Software auf einem entfernten Rechner
' Autor: Thomas@Gartner-IT.net
' verwendet: WMI
'

Dim objWMIService, colSoftware, objSoftware
Dim User, Password, Computer, ProductName

User = "Administrator"
Password = "password"
Computer = "."
ProductName = "Windows 2000 - Verwaltungsprogramme"

Set objWbemLocator = CreateObject("WbemScripting.SWbemLocator")
Set objConnection = objwbemLocator.ConnectServer _
(Computer, "root\cimv2", User, _
Password)

Set colSoftware = objConnection.ExecQuery ("SELECT * FROM Win32_Product" &_
"WHERE Name = """ & ProductName & """")

For Each objSoftware in colSoftware
objSoftware.Uninstall()
Next

Vielen Dank
Mitglied: Logan000
30.03.2007 um 13:22 Uhr
Hallo
Mir ist deine Frage etwas unklar.
Du hast also dieses Skript. Das warscheinlich funktioniert (ich habs selbst noch nicht getestet).
Jetzt willst du das skript per GPO auf Client PC ausführen?
Oder wilst Du das Skript per GPO auf den Client Kopieren um es dann vom Client aus auszuführen?

nun ist mir aber unklar, wie ich dies auf den Rechner anpassen kann
Was soll dann noch angepasst werden? In beiden beschriebenen fällen wird das Skript korrekt laufen.
Bitte warten ..
Mitglied: David81
30.03.2007 um 13:26 Uhr
Ich möchte den Script per GPO auf ausgewählen Client PC ausführen.
Bitte warten ..
Mitglied: rubberduck
12.04.2007 um 14:18 Uhr
Falls das Problem noch besteht:

Erstell in der AD eine Gruppe, weise in der Gruppenrichtlinienverwaltung diese Gruppe in der Sicherheitsfilterung zu und nimm die Clients in die AD-Gruppe auf. Wenn Du die Policy noch mit der korrekten OU verlinkst, wird es funktionieren.
Schau Dir noch "Status der Gruppenrichtlinie" an. In Deinem Fall sollte es korrekterweise auf "Benutzerkonfigurationseinstellungen deaktiviert" sein.

WMI-Filterung wäre sicher auch Lustig, aber in Deinem Fall überflüssig.

Wenn das Problem nicht mehr besteht, dann markier den Thread bitte als gelöst.
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (32)

Frage von FA-jka zum Thema Windows 10 ...

LAN, WAN, Wireless
Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

Backup
Backup Wochen- Monats- Jahressicherung (13)

Frage von Meterpeter zum Thema Backup ...

RedHat, CentOS, Fedora
Fedora, RedHat, Centos: DNS-Search Domain setzen (13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...