Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Softwareinstallation mit Gruppenrichtlinien klappt nur beim ersten Mal

Frage Microsoft Windows Server

Mitglied: hannsgmaulwurf

hannsgmaulwurf (Level 2) - Jetzt verbinden

20.08.2009, aktualisiert 17:20 Uhr, 7476 Aufrufe, 13 Kommentare

Hallo zusammen!
Ich habe via Gruppenrichtlinien die MSI-Pakete von 7-Zip (Vers. 4.42) und Adobe Reader (Vers. 8.0) auf die Computer in der Domäne verteilt. Beim ersten Hochfahren eines Clients werden auch beide Pakete installiert - alles bestens. Nun habe ich (zu Testzwecken) auf einem Client beide Programme deinstalliert und den Client neugestartet, in der Hoffnung, die Pakete würden sofort wieder installiert werden. Denkste! Nach dem Neustart passiert nix. Ein Blick in die Softwareliste zeigt: Plötzlich sind wieder beide MSI-Pakte in der Liste vorhanden. Allerdings nur die MSI-Pakete, die Programme an sich sind nach wie vor deinstalliert. Nach einem Klick auf Entfernen (des jeweiligen Paketes) werde ich aufgefordert, die Netzwerkressource anzugeben, in der sich das MSI-Paket befindet. Egal ob ich hier abbreche oder die Quelle angebe: Der Eintrag wird aus der Softwareliste entfernt. Nach einem erneuten Neustart sind die Einträge in der Softwareliste jedoch wieder da Habe ich vielleicht von vorn herein was falsch gemacht? Wüsste zwar nicht was, aber deswegen bin ich ja hier
Der Bereitsstellungszustand der Pakete ist "Zugewiesen". Beim Server (DC) handelt es sich um eine Windows Server 2003 R2 Standard Edition und bei den Clients um Windows XP Pro Clients mit SP3.
Ich danke euch und freue mich auf eure zahlreichen "man bist du doof, das musst du so machen"-Replys
Mitglied: Destry
20.08.2009 um 17:31 Uhr
Hi,

bin mir nicht ganz sicher, aber ich glaube das Verhalten ist normal.

Bitte teste mal ob sich der Adobe installiert wenn du versuchst eine pdf-Datei zu öffnen. Ich glaube dann zieht die Installation nach.
Oder mal mit "gpupdate /force" probieren und sehen ob sich was ändert.

Viel Erfolg,
Destry

P.S.: Auf Wunsch des Fragers: Man bist Du doof, das musst Du so machen.
Bitte warten ..
Mitglied: hannsgmaulwurf
20.08.2009 um 17:39 Uhr
Hallo Destry!
Danke für die schnelle Antwort, leider hat's nicht geholfen. Beim Versuch ein pdf zu öffnen fragt er nach einem Programm mit dem die Datei geöffnet werden soll - und da der Reader ja nicht installiert ist...........
gpupdate /force hab ich auch schon mehrere Male erfolglos versucht

Zitat von Destry:
bin mir nicht ganz sicher, aber ich glaube das Verhalten ist normal.

Das kann ich mir nicht vorstellen, wäre ja traurig. Sag mir einer wozu ich diese Softwareinstallation via Gruppenrichtlinien nutzen soll wenn sie gar nicht so funktioniert wie sie (aus meiner Sicht) funktionieren sollte?? *kopfschüttel*
Bitte warten ..
Mitglied: hannsgmaulwurf
20.08.2009 um 18:04 Uhr
Ergänzung:
Ich habe mal testhalber das Tool UnInstall Cleaner (http://www.pcwelt.de/index.cfm?pid=256&pk=107978) runtergeladen und probiert - es findet die Einträge von 7-Zip und Acrobat Reader gar nicht. Der RegCleaner (http://www.chip.de/downloads/RegCleaner_12991462.html) auch nicht. Also sind es wirklich nur diese blöden MSI-Pakete, die als Reste in der Softwareliste hängen bleiben und sich nicht vertreiben lassen
Werde mal versuchen, den Kram via GP wieder zu deinstallieren - wenn das überhaupt möglich ist.....
Schöne Grüße und immer fleißig weiter "Man bist Du doof, das musst Du so machen." 'en
Bitte warten ..
Mitglied: DerWoWusste
21.08.2009 um 00:59 Uhr
Das Verhalten ist normal. Willst Du sicherstellen, dass Nutzer nicht in der Lage sind, Anwendungen zu deinstallieren, dann entzieh Ihnen die Rechte.
Zum Erneuten Installieren hat MS den Punkt Redeploy (=erneut bereitstellen) am Paket selbst in der GPO vorgesehen.
Gib zum besseren Verständnis auch an, was Dich eigentlich stört.
Bitte warten ..
Mitglied: Logan000
21.08.2009 um 08:21 Uhr
Moin moin

Nun habe ich (zu Testzwecken) auf einem Client beide Programme deinstalliert und den Client neugestartet,
Die Deinstallation hast Du manuell in der Systemsteuerung vorgenommen.

Um per GPO instalierte Programme zu deinstallieren soltest du entweder im Richtlinieneditor das Paket "Entfernen" oder noch besser bei der Bereitstellung die Option "Anwendung deinstallieren, wenn Sie ausserhalb des Verwaltungsbereichs liegt" aktivieren. Dann wird die Software deinstaliert wenn die GPO nicht mehr greift (weil der PC in einer andren Gruppe/OU ist oder aus der Domäne geflogen ist).

Gruß L.
Bitte warten ..
Mitglied: hannsgmaulwurf
21.08.2009 um 13:11 Uhr
Hallo zusammen und vielen Dank für die aussagekräftigen Antworten!! Ich werde wohl - wie schon erwähnt - die Deinstallation via GPs mal genauer unter die Lupe nehmen (müssen).

Zitat von DerWoWusste:
Gib zum besseren Verständnis auch an, was Dich eigentlich stört.
Ich habe mir diese Softwareinstallation via GPs als so'ne Art Zwangsinstallation vorgestellt. Also angenommen es ist (aus welcehn Gründen auch immer) nicht möglich/sinnvoll/mit zu viel anderem Aufwand verbunden, den Usern die Rechte zu entziehen: "lass doch die User deinstallieren was sie wollen, beim Neustart müssen sie dann eben um so länger warten bis die Sachen wieder installiert sind". Das stört mich eigentlich. Mein Standpunkt ist der, dass die (Domänen)User die Bösewichte (mit Adminrechten) sind und die GPs dazu dienen sollen, das Tun und Lassen der Bösewichte einzugrenzen bzw. zu verharmlosen bzw. nichtig zu machen... Ich hab mir das wohl anders vorgestellt bzw. mir zuviel und zu Einfaches von einem AD und seinen Werkzeugen erwartet...

Zitat von Logan000:
Um per GPO instalierte Programme zu deinstallieren soltest du
entweder im Richtlinieneditor das Paket "Entfernen" oder
noch besser bei der Bereitstellung die Option "Anwendung
deinstallieren, wenn Sie ausserhalb des Verwaltungsbereichs
liegt" aktivieren. Dann wird die Software deinstaliert wenn die
GPO nicht mehr greift (weil der PC in einer andren Gruppe/OU ist oder
aus der Domäne geflogen ist).
Wie kann die Software automatisch deinstalliert werden wenn der PC gar nicht mehr in der Domäne (& event. somit nicht mehr im LAN) hängt? Ich versteh auch nicht so ganz, wo da der Unterschied ist. Also ob ich das MSI-Paket nun lokal auf einem PC ohne Domänen- und LAN-Anbindung oder via GPs installiere(n lasse): Es handelt sich doch immer um das gleiche MSI-Paket?!?
Bitte warten ..
Mitglied: Logan000
21.08.2009 um 15:16 Uhr
Moin

Wie kann die Software automatisch deinstalliert werden wenn der PC gar nicht mehr in der Domäne (& event. somit nicht mehr im LAN) hängt?
Weil die (De)Installation letzendlich lokal erfolgt.

Ich versteh auch nicht so ganz, wo da der Unterschied ist. Also ob ich das MSI-Paket nun lokal auf einem PC ohne Domänen- und LAN-Anbindung oder via GPs installiere(n lasse): Es handelt sich doch immer um das gleiche MSI-Paket?!?
Der unterschied liegt nicht in der Installation, sondern darin wer diese durchfürt.
Entweder ein Angemeldeter Benutzer (mit evtl. unzureichenden Berechtigungen) oder die Winlogon.exe mit Systemberechtigungen.

Gruß L.
Bitte warten ..
Mitglied: hannsgmaulwurf
21.08.2009 um 15:22 Uhr
Zitat von Logan000:
Weil die (De)Installation letzendlich lokal erfolgt.
lokal ja. aber automatisch??

Zitat von Logan000:
Der unterschied liegt nicht in der Installation, sondern darin wer
diese durchfürt.
Entweder ein Angemeldeter Benutzer (mit evtl. unzureichenden
Berechtigungen) oder die Winlogon.exe mit Systemberechtigungen.
Im aktuellen Szenario haben die User ja die entsprechenden Rechte. Also wenn ein User mit entspr. Rechten das MSI-Paket für 7-Zip auf einem lokalen PC (kein LAN, keine Domäne) installiert und es anschließend deinstalliert wird es wohl auch nach einem Neustart aus der Softwareliste verschwunden bleiben... Wenn das ganze aber via GP passiert (gleiches Paket), liegt doch das gleiche Paket in der Softwareliste, oder nicht? Dieses Paket taucht jedenfalls nach manueller Deinstallation immer wieder auf
Bitte warten ..
Mitglied: Logan000
21.08.2009 um 15:44 Uhr
Moin

lokal ja. aber automatisch??
Ja natürlich. Die Abarbeitung der GPOs erfolgt immer automatisch.

Im aktuellen Szenario haben die User ja die entsprechenden Rechte.
Also wenn ein User mit entspr. Rechten das MSI-Paket für 7-Zip
auf einem lokalen PC (kein LAN, keine Domäne) installiert und es
anschließend deinstalliert wird es wohl auch nach einem Neustart
aus der Softwareliste verschwunden bleiben... Wenn das ganze aber via
GP passiert (gleiches Paket), liegt doch das gleiche Paket in der
Softwareliste, oder nicht? Dieses Paket taucht jedenfalls nach
manueller Deinstallation immer wieder auf :
Das ist richtig. Ich kann die jetzt nicht sagen warum das so ist, aber ich vermute mal , das nach erfolgreicher installation per GPO, nicht bei jedem Systemstart geprüft wird ob die Software inzwischen manuell deinstaliert wurde. Wahrscheinlich wegen der Performance.

Gruß L.
Bitte warten ..
Mitglied: hannsgmaulwurf
21.08.2009 um 16:04 Uhr
Hallo nochmal an ALLE!

Danke für eure schnelle unkomplizierte Hilfe! Hab den betroffenen Rechner aus der Domäne genommen und nach dem er wieder hineingehangen wurde waren die Einträge auch aus der Softwareliste verschwunden - auf nimmer nimmer Wiedersehn'
Nachdem der PC aber wieder "leer und sauber" der Domäne hinzugefügt wurde greifen die Softwareinstallationen nicht mehr Auch ein gpupdate/force und mehrere Neustarts waren erfolglos. Vom Regen in die Traufe, jetzt klapp gar nix mehr :D
Bitte warten ..
Mitglied: hannsgmaulwurf
21.08.2009 um 16:46 Uhr
ERGÄNZUNG: Beim Hochfahren des Rechners - kurz bevor der Bildschrim "Drücken Sie Strg+Alt+Entf" erscheint - steht für den Bruchteil einer Sekunde was von "Softwareeinstellungen werden..." und "Installation von 7-Zip".... Aber wie gesagt: Es wird nur ganz kurz angezeigt aber nicht ausgeführt...
Bitte warten ..
Mitglied: DerWoWusste
21.08.2009 um 21:42 Uhr
Auf den Rechnern wird ein Marker hinterlassen "Paket installiert". Er bleibt auch bei manueller Deinstallation drin. Den müsstest Du in der Registry ausfindig machen und löschen.
Aber was soll's - Dein Wunsch wird von MS nicht erfüllt, es ist nicht so gedacht, wie Du gern hättest.
Um Deinstallationen zu vermeiden, kannst Du natürlich den Zugriff auf den Windowsinstaller verweigern. Jedoch: Admins können mit etwas Geschick jegliche Domänenrichtlinien sabotieren - ist nunmal so, wenn man den Leuten Adminrechte gibt.
Bitte warten ..
Mitglied: hannsgmaulwurf
01.09.2009 um 09:44 Uhr
Zitat von DerWoWusste:
ist nunmal so, wenn man den Leuten Adminrechte gibt.
Da hast du Recht!!

Also nochmal vielen Dank an alle (außer an MS )!!

Dann werd ich mich mal auf machen den Leuten das Fürchten bzw. das Nicht-Admin-Sein zu lehren und den GPOs meinen Gehorsam aufzuzwingen :D
Bitte warten ..
Ähnliche Inhalte
Exchange Server
"Senden als" funktioniert nur beim ersten mal
Frage von N.PalmExchange Server2 Kommentare

Hallo zusammen, folgende Grundlage. Server: Exchange 2010 OS: Windows 10 Pro Office: 2010 und 2013 in der Normal und ...

Windows 10
Windows 10 startet erst beim 2. Mal
Frage von HardwareFreakWindows 1018 Kommentare

Hallo zusammen, Ich bin neu im Forum und habe direkt mal eine Frage an euch. Mein PC hat seit ...

Mac OS X
Das erste Mal Update von Mac OS X
Frage von achkleinMac OS X7 Kommentare

Hallo, in der nächsten Woche mache ich das erste Mal für einen Freund ein Update von Mac OS X ...

Server-Hardware
Mein erstes Mal: ProLiant DL180 G6 sinnvoll? Was muss ich beachten?
gelöst Frage von alex999Server-Hardware25 Kommentare

Hallo zusammen, in meiner low budget/SOHO Umgebung läuft ein Desktop PC (i5, 2,97 GHz mit 16GB RAM) als Server ...

Neue Wissensbeiträge
Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 2 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit7 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...