Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Softwareverteilung via GPO - Probleme

Frage Microsoft Windows Server

Mitglied: PhilippH

PhilippH (Level 1) - Jetzt verbinden

02.11.2006, aktualisiert 28.05.2008, 12937 Aufrufe, 12 Kommentare

Hallo !

Ich hoffe Ihr könnt mir etwas weiterhelfen, habe auch schon recherchiert aber bin bisher nicht weitergekommen.

wollte zu Test- und Lernzwecken in unserem "Testnetzwerk" den Firefox (MSI) via GPO verteilen. (Am besten gleich bei der Anmeldung)
Haben eine einfache AD Struktur und 12 Clients, die sich daran anmelden.

Bin folgendermaßen vorgegangen:

- Active Directory Benutzer und Computer
- Rechtsklick auf die Domäne, Eigenschaften - Gruppenrichtlinie öffnen

-Unter unserer Domäne eine neue Organisationseinheit angelegt
-Unter der OU names Software ein neues Gruppenrichtlinienobjekt angelegt Namens "MSI"
-Bearbeiten von MSI

-Unter -Computerkonfiguration
-Softwareeinstellungen
-Softwareinstallation

habe ich das MSI Paket hinzugefügt. (Freigabe und Rechte stimmen)

-Bereitsstellungsmodus: Zugewiesen
-Paket bearbeitet und die Option: "Anwendung bei Anmeldung installieren" gewählt

Wenn ich mich nun mit einem Domänenbenutzer an einer Workstation anmelde, wird aber nichts installiert!?
Was habe ich vergessen?

Danke für Eure Hilfe !

Gruß Philipp
Mitglied: Anschiss78
02.11.2006 um 16:02 Uhr
ich gehe davon aus das die rechner die die gruppenrichtlinie erhalten sollen in der ou sind.

kopiere dir den angegeben pfad des msi und gib diesen bei ausführen mal ein. wenn dies funktioniert stimmt der pfad und die freigabe des ordners.

versuche dich dann als admin auf den client anzumelden. wenn es dann geht liegt es an deinen rechten die du auf den freigegeben ordner gelegt hast.


oder versuche mal den pfad in der gruppenrichlinie mit der ip des servers zu schreiben also \\xxx.xxx.xxx.x\freigabename\xxxxxx.msi


hoffe es hilft dir weiter
Bitte warten ..
Mitglied: elCativo
02.11.2006 um 16:05 Uhr
Such mal die Richtlinie "Immer mit erhöhten Rechten installieren" oder so ähnlich die muss aktiviert werden dann sollte es funktionieren.
Bitte warten ..
Mitglied: PhilippH
03.11.2006 um 08:35 Uhr
Morgen,

danke erstmal für Eure Antworten! Hab jetzt nochmal alles gelöscht was ich gestern konfiguriert habe und nochmal neu angefangen:

Habe also eine neue OU erstellt und darunter eine neues Gruppenrichtlinienobjekt.

- Habe die Freigaben überprüft und wie elCativo vorgeschlagen hat, "Immer mit erhöhten Rechten installieren" gesetzt.

Geht nicht.

habe mal auf der Kommandozeile mit gpresult > erg.txt mir die Ergebnisse angeschaut und siehe da, die OU Software wird gar nicht beachtet! Ist aber verknüpft!

Woran kann das sonst noch liegen?

Wie kann ich auch überprüfuen, ob die Rechner in meiner OU mit verknüpft sind?

Danke Euch!


Hier das Ergebnis von gpresult:


Betriebssystem Microsoft (R) Windows (R) XP Gruppenrichtlinienergebnis-Tool v2.0
Copyright (C) Microsoft Corp. 1981-2001

Am 03.11.2006 um 08:35:21 erstellt



RSOP-Ergebnisse fr BBI38RO\XXXXXX.Philipp auf BBI38RO-121 : Protokollierungsmodus
Betriebssystemtyp: Microsoft Windows XP Professional
Betriebssystemkonfiguration: Mitglied der Dom„ne/Arbeitsgruppe
Betriebssystemversion: 5.1.2600
Dom„nenname: BBI38RO
Dom„nentyp: Windows 2000
Standortname: Standardname-des-ersten-Standorts
Zwischengespeichertes Profil: \\192.168.10.1\Profile$\xxxx.philipp
Lokales Profil: C:\Dokumente und Einstellungen\TEMP
Langsame Verbindung? Nein


COMPUTEREINSTELLUNGEN
CN=BBI38RO-121,CN=Computers,DC=bbi38ro,DC=local
Zeit der letzten Gruppenrichtlinienanwendung: 03.11.2006 at 08:06:13
Gruppenrichtlinie wurde angewendet von: bbi38ro-server.bbi38ro.local
Gruppenrichtlinienschwellenwert fr langsame Verbindung: 500 kbps

Angewendete Gruppenrichtlinienobjekte
--------------------------------------
Default Domain Policy
Admins und Hauptbenutzer

Die folgenden Gruppenrichtlinie werden nicht angewendet, da sie herausgefiltert wurden.
----------------------------------------------------------------------------------------
Ordnerumleitung
Filterung: Nicht angewendet (Leer)

Datenaustausch
Filterung: Nicht angewendet (Leer)

Richtlinien der lokalen Gruppe
Filterung: Nicht angewendet (Leer)

Der Computer ist Mitglied der folgenden Sicherheitsgruppen:
-----------------------------------------------------------
Administratoren
Jeder
Benutzer
NETZWERK
Authentifizierte Benutzer
BBI38RO-121$
Dom„nencomputer


BENUTZEREINSTELLUNGEN
CN=Philipp xxxxx,CN=Users,DC=bbi38ro,DC=local
Zeit der letzten Gruppenrichtlinienanwendung: 03.11.2006 at 08:06:13
Gruppenrichtlinie wurde angewendet von: bbi38ro-server.bbi38ro.local
Gruppenrichtlinienschwellenwert fr langsame Verbindung: 500 kbps

Angewendete Gruppenrichtlinienobjekte
--------------------------------------
Default Domain Policy
Ordnerumleitung
Datenaustausch

Die folgenden Gruppenrichtlinie werden nicht angewendet, da sie herausgefiltert wurden.
----------------------------------------------------------------------------------------
Admins und Hauptbenutzer
Filterung: Nicht angewendet (Leer)

Richtlinien der lokalen Gruppe
Filterung: Nicht angewendet (Leer)

Der Benutzer ist Mitglied der folgenden Sicherheitsgruppen:
-----------------------------------------------------------
Dom„nen-Benutzer
Jeder
Benutzer
Hauptbenutzer
INTERAKTIV
Authentifizierte Benutzer
LOKAL
Bitte warten ..
Mitglied: hackfresse1703
03.11.2006 um 09:30 Uhr
Morgen,

danke erstmal für Eure Antworten! Hab
jetzt nochmal alles gelöscht was ich
gestern konfiguriert habe und nochmal neu
angefangen:

Habe also eine neue OU erstellt und darunter
eine neues Gruppenrichtlinienobjekt.

RE: Softwareverteilung via GPO - Probleme
Geschrieben von Anschiss78 am 02.11.2006 um 16:02:01 Uhr.
ich gehe davon aus das die rechner die die gruppenrichtlinie erhalten sollen in der ou sind.




- Habe die Freigaben überprüft und
wie elCativo vorgeschlagen hat, "Immer
mit erhöhten Rechten installieren"
gesetzt.

ist komplett unnötig. die Rechtesteuerung läuft über das msi paket


Geht nicht.

habe mal auf der Kommandozeile mit gpresult
> erg.txt mir die Ergebnisse angeschaut
und siehe da, die OU Software wird gar nicht
beachtet! Ist aber verknüpft!

Woran kann das sonst noch liegen?

Wie kann ich auch überprüfuen, ob
die Rechner in meiner OU mit verknüpft
sind?

Danke Euch!


Hier das Ergebnis von gpresult:


Betriebssystem Microsoft (R) Windows (R) XP
Gruppenrichtlinienergebnis-Tool v2.0
Copyright (C) Microsoft Corp. 1981-2001

Am 03.11.2006 um 08:35:21 erstellt



RSOP-Ergebnisse fr BBI38RO\XXXXXX.Philipp
auf BBI38RO-121 : Protokollierungsmodus
Betriebssystemtyp:
Microsoft Windows XP Professional
Betriebssystemkonfiguration:
Mitglied der Dom„ne/Arbeitsgruppe
Betriebssystemversion:
5.1.2600
Dom„nenname: BBI38RO
Dom„nentyp: Windows 2000
Standortname:
Standardname-des-ersten-Standorts
Zwischengespeichertes Profil:
\\192.168.10.1\Profile$\xxxx.philipp
Lokales Profil: C:\Dokumente
und Einstellungen\TEMP
Langsame Verbindung? Nein


COMPUTEREINSTELLUNGEN

CN=BBI38RO-121,CN=Computers,DC=bbi38ro,DC=local

Wie heißt die OU? Hast du sie wieder "MSI" genannt? Dann kann es nicht funktionieren!
o.a. DN sagt aus das der Cient in der OU Computers liegt!

Stefan Tolksdorf
Bitte warten ..
Mitglied: PhilippH
03.11.2006 um 09:58 Uhr
Also die OU heißt Softwareverteilung und das Objekt MSI..
An dem kann es nicht liegen
Bitte warten ..
Mitglied: hackfresse1703
03.11.2006 um 10:28 Uhr
Also die OU heißt Softwareverteilung

wir reden aneinander vorbei. der ensprechende client muss in dieser ou sein, ist er aber momentan nicht. der DN lautet gem gpresult:

CN=BBI38RO-121,CN=Computers,DC=bbi38ro,DC=local

müsste aber in

CN=BBI38RO-121,CN=Softwareverteilung,DC=bbi38ro,DC=local

liegen. Wie soll die Gruppenrichtlinie in einer OU auf den Client wirken wenn kein Client in Ihr ist?


Oder verstehe ich es falsch?
Bitte warten ..
Mitglied: PhilippH
03.11.2006 um 10:41 Uhr
Das siehst du goldrichtig und mir leuchtet das ja auch ein, dass es so nicht funktioniert.

1. Was versteht man genau unter Organisation Unit
2. Was bedeutet genau CN
3. Wie bekomme ich die Clients in die OU?

Also unter Active D. Benutzer u. Computer gibt es eine Rubrik Namens: Computers
Darunter sind alle Rechner zu finden.

Stehe mit den Gruppenrichtlinien irgendwie noch auf Kriegsfuß.

Danke für Deine Hilfe!
Bitte warten ..
Mitglied: hackfresse1703
03.11.2006 um 10:59 Uhr
Das siehst du goldrichtig und mir leuchtet
das ja auch ein, dass es so nicht
funktioniert.

1. Was versteht man genau unter Organisation
Unit

Eine OU ist eine verwaltbare Einheit auf die man mit GPO´s verknüpfen kann. Im Gegensatz zu Containern welche lediglich zum sortieren da sind.
In eine OU kannst du Computerkonten und Benutzerkonten legen. Sie sollen nicht den logischen Aufbau einer Firma wiedergeben (können aber) sondern dir die Administration erleichtern, du solltest dich an Aufgaben der Nutzer/Computer bzw. an Funktionalitäten die Sie abbilden sollen orientieren.

2. Was bedeutet genau CN

CN= Common Name

Damit wird der eindeutige LDAP Pfad eines Objektes innerhalb einer Domain angegeben angeben. AD ist ja eine Datenbank, in dieser muss eine eindeutige Ablage stattfinden. Und somit hat jedes Objekt einen DN (Distuingished Name) welcher den Pfad innerhalb der LDAP Datenbank angibt. Deswegen wusste ich genau das dein Client in dem falschem Container für deine Zwecke liegt.



3. Wie bekomme ich die Clients in die OU?

Also unter Active D. Benutzer u. Computer
gibt es eine Rubrik Namens: Computers
Darunter sind alle Rechner zu finden.

Das ist der Standard Container für neue Computerobjekte. Einfach mit der rechten Maustaste auf das Computerkonto und dann verschieben wählen.


Stehe mit den Gruppenrichtlinien irgendwie
noch auf Kriegsfuß.

Danke für deine Hilfe!

Kein Problem.
Bitte warten ..
Mitglied: PhilippH
03.11.2006 um 12:20 Uhr
Danke nochmal für die gute Erklärung.
Habe nun die Rechner aus dem Container Computers nach Softwareverteilung verschoben und auch nochmal die Policies neu erstellt und verknüpft und aktiviert.

Geht aber wieder nicht. gpresult sagt mir zwar, dass jetzt der CN=Softwareverteilung aber die Policy MSI taucht nicht unter den "angewandten" auf.

Geduld ist angesagt
Bitte warten ..
Mitglied: PhilippH
03.11.2006 um 12:40 Uhr
Es funktioniert !! die Rechner hatten nur noch nicht die aktuellen Richtlinien bekommen! Jeder PC bekommt nun den Firefox installiert

Nochmals herzlichen Dank an hackfresse1703 und ein schönes WE !
Bitte warten ..
Mitglied: hackfresse1703
03.11.2006 um 15:03 Uhr
Glückwunsch, du musst bei allen Veränderungen an der AD immer etwas Geduld haben. Zieh dir mal im www was über Replikation und Zugrifftoken rein. Da siehst du welche Veränderung an der AD wie beim Client ankommt bzw. was notwendig ist um Sie gleich zu haben.


Stefan Tolksdorf
Bitte warten ..
Mitglied: Zesa20
28.05.2008 um 23:14 Uhr
Guten Abend,
ich habe im Prinzip die selbe Situation wie PhilippH.
Ein Windows Server 2003 R2.
Windows XP Clients (Zurzeit um die 10 Rechner).

Clients sollen über die Gruppenrichtlinie Firefox installiert bekommen.
MSI-Packet vorhanden, liegt auf dem Server und ich kann auch mit \\server\freigabe\firefox.msi drauf zugreifen.

Die Gruppenrichtlinie ist Computerabhängig, d.h. Computerkonfiguration, da alle Rechner Firefox installiert bekommen sollen.

Nun macht das mein Testclient den ich über Remote von zu hause immer wieder neustarte nicht.
Ich war heute noch kurz im Büro und habs auch nochmal so versucht.
Zumindest kommt vor dem Anmeldebildschirm für eine kurze Zeit ein Fester mit "Installation Firefox" (jetzt nicht wortwortlich, aber so ungefähr).

Andere Richtlinien funktionieren Tadellos.

Wo könnte mein Fehler sein, was mache ich falsch?

Was sollte ich beachten?

Mit freundlichem Gruß

Zesa
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows 10
gelöst Leider nochmal: Probleme mit GPO (glaube ich) (3)

Frage von Dave-Bowman zum Thema Windows 10 ...

Windows Server
GPO aktiv trotz Deaktivierung (7)

Frage von XxDarkAngelxX zum Thema Windows Server ...

Windows 7
gelöst Sind euch verstärkte Probleme bei Windows 7 Updates aufgefallen? (4)

Frage von RadioHam zum Thema Windows 7 ...

Cloud-Dienste
gelöst OwnCloud 8 Probleme mit Vorschaubildern auf Mobilgeräten (1)

Frage von zeroblue2005 zum Thema Cloud-Dienste ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...