Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Softwareverteilung per GPO an Windows 7 Rechner

Frage Microsoft Windows 7

Mitglied: L0g1t3ch

L0g1t3ch (Level 1) - Jetzt verbinden

12.08.2014, aktualisiert 13:18 Uhr, 2666 Aufrufe, 25 Kommentare, 1 Danke

Aloha zusammen,

Ich habe ein kleines aber ernstes Problemchen bei einem Kunden und hoffe das Ihr mir helfen könnt.

Wir haben vor kurzem damit begonnen bei dem Kunden Software per GPO zu verteilen allerdings auf Windows XP 32bit. Das funktioniert auch soweit ohne Probleme.
Jetzt haben wir aufgrund dessen das XP aus dem Support heraus ist mit der Umstellung auf Windows 7 64bit begonnen, zumindest bei neu aufgestellten Rechner da die alten teilweiße ausgetausch werden müssen.

Das Problem das sich nun stellt ist das die Windows 7 Machinen die GPOs nicht umsetzten per gpresult sehe ich das diese zwar aktiv sind aber nicht umgesetzt werden. Für Pakete wo es Probleme gibt bzgl. 32 und 64 bit haben wir eine neue Windows 7 Regel angelegt. Aber auch diese wird konsequent ignoriert vom System.

Wie sieht die konfiguration aus:
Server 2008 (kein R2) mit einer Domänenstruktur auf Server 2003 Basis
Regeln für Installationen funktionieren auf Windows XP
Extra Regel für 64bit Programme funktionieren NICHT auf Windows 7, ebenso wenig die alten Richtlinien

Daher meine Frage wie ich dieses nun realisieren kann.

Liebe Grüße
Benjamin

EDIT: Benutzerkonten Steuerung hab ich ausgestellt und die erweiterten Anmelde Informationen an!

e7c50404e5cb74338534e53ec541c07e - Klicke auf das Bild, um es zu vergrößern
Mitglied: xbast1x
12.08.2014 um 12:08 Uhr
Hallo Logitech,

wie sieht so eine "Regel" aus?
Was sagt der Ereignislog eines Clients wo es nicht funktioniert?
Sind die Rechner in der gleichen OU wie die alten XP Clients?
Versucht du die Software auf Benutzer oder Computerebene zu verteilen?

Grüße
Bitte warten ..
Mitglied: L0g1t3ch
12.08.2014 um 12:34 Uhr
Hallo und Danke für deine schnelle Rückmeldung

Also die Regel hat unter Computerkonfiguration -> Richtlienen -> Softwareinstellungen -> Softwareinstallation das MSI Paket Verknüpft welches per Freigabe auf dem Server liegt \\server\freigabe\freigabe\paket.msi , ergo verteile ich die Software per Computerebene

Die Rechner sind alle noch in der gleichen OU weil wir hier neu beim Kunden sind und noch einiges Einstellen bzw. durch gewissen Züge einiges vorziehen müssen wie auch die Softwareverteilung.

Das Error-Log sagt hierzu leider nichts, lediglich Einträge bzgl. der Fehlerhaften Folder Redirection welche wir noch nicht ausgestellt haben sind zu sehen.

Hoffe ich konnte alle deine Fragen ausführlich beantworten damit sie die weiterhelfen
Bitte warten ..
Mitglied: Sheogorath
12.08.2014 um 12:41 Uhr
Moin,

klingt als würden die GPOs garnicht angewendet... sind Policys Gruppenbasiert? sind die PCs in den Gruppen?

Gruß
Chris
Bitte warten ..
Mitglied: TlBERlUS
12.08.2014 um 12:45 Uhr
Moin,

1. Wie mein Vorredner: Regelaufbau?
+ Einstellungen
2. Hast du eine funktionierende *.msi? / um welche Software gehts?
3. Testsystem vorhanden?
4. Die *.msi Datei muss in einer entsprechenden Freigabe/DFS-Stamm liegen(Testhalber könntest du sysvol nehmen)

Grüße,

Tiberius
Bitte warten ..
Mitglied: L0g1t3ch
12.08.2014 um 12:53 Uhr
Die Policys sind Gruppen bassiert, der PC befindet sich in der dazugehörigen Gruppe.
Bitte warten ..
Mitglied: L0g1t3ch
12.08.2014, aktualisiert um 13:18 Uhr
Eine Beispiel Software ist Firefox in seiner derzeitigen Version
--> Dieser soll per GPO verteilt werden in mti den gelichen Einstellungen auf XP kein PRoblem bei Windows 7 = Kein Erfolg
--> Für Firefox gibt es auch nur eine Regel! Keine expliziete Windows 7 Rege

--> Die MSI liegt in einer Freigabe aus welcher man die Setups auch auch so aufrufen kann Sysvol wurde schon getestet leider ohne Erfolg.

--> Ich mach für den Regelaufbau einen Screen und lad euch den gleich Hoch ok? EDIT: BILD hochgeladen diese Policy ist wiederrum der Gruppe Firfox zugeordnet und darin befindet sich der Computer auf dem das ausgeführt werden soll.
Bitte warten ..
Mitglied: Poehli
12.08.2014, aktualisiert um 13:37 Uhr
Das ist ja nun ein denkbar schlechtes Beispiel, da es als erstes die Frage aufwirft wie und woher die .msi ist, denn von Mozilla gibts keine. Ich würde empfehlen das Ganze mal mit einer Software anzugehen die von Haus aus als .msi vorliegt, und wo es erfahrungsgemäß simpler läuft und es überall Dokumentation des Vorgehens gibt. Also Adobe oder Java zum Beispiel.

Wenn du noch mehr Programme hast die eigentlich als .exe vorliegen solltest du statt GPO eher eine Verteilung per BatchDatei oder per Verteilungssoftware + WSUS vorsehen, das gibt auch besseres Feedback, denn die Verteilung per GPO gibt gar keine Infos zurück.

Edit: Ich meine mich zum Beispiel zu erinnern, als ich FF noch per GPO verteilte, da war für die FF- Frontmotion .msi's eine administrative Installation ins Serverlaufwerk nötig, die lieferte eien weitere msi plus Installationsordner, und diese mußte dann verteilt werden. Keine Ahnung ob das heute noch so ist.....
Bitte warten ..
Mitglied: L0g1t3ch
12.08.2014 um 13:32 Uhr
Gut aber selbst der Java Client lässt sich nicht verteilen und die Policiy sind alle gleich aufgebaut. Wenn der Firefox von Haus aus keine eigene MSI hat dann sollten ja zumindest die anderen Problemlos funktionieren sollte es nur daran liegen. Tun sie jedoch auch nicht.

Das Problem zieht sich durch alle MSIs seien es die von Dokuware oder OpenOffice oder sogar die von Microsoft für Outlook oder Access. Alle die die auf Windows XP funktionieren sollten dann ja auf sofern sie vom Original stammen ohne PRobleme verteilt werden können. Das das ganze mit BatchDateien ebenso funktioniert ist uns klar. Nur es muss ja einen Grund geben warum es hier nicht funktioniert.
Bitte warten ..
Mitglied: TlBERlUS
12.08.2014, aktualisiert um 13:41 Uhr
Hi,

1. man kann eine inoffizielle *.msi für Firefox downloaden, oder einen msi-Konverter nutzen.(Beides funktioniert)
2. Adobe-Reader und 7zip könnte man auch zum Testen nutzen, allerdings benötigt AdobeReader zusätzlich eine cab-Datei
3. Screenshot der Regel in der mmc-Konsole?
4. Feedback-technisch hat Poehli zwar recht, allerdings scheint ja nur eine Software betroffen zu sein, und da ist die Verteilung per GPO, mit weniger Aufwand verbunden

Grüße,

Tiberius
Bitte warten ..
Mitglied: Sheogorath
12.08.2014, aktualisiert um 13:46 Uhr
Moin,

ist es vielleicht ein berechtigungsproblem auf dem Share? versuch mal per SYSTEM auf die Freigabe zu kommen... (um als system zu arbeiten, schreibe eine 08/15 batch, die den Setup einfach irgendwo hinkopieren soll und per aufgabenplanung beim Systemstart als SYSTEM user aufrufen. wenn das nicht klappt hast du ein berechtigungsproblem auf dem Share)

du musst die Computerkonten auf deine Freigabe berechtigen, sonst funktioniert es nicht.

entweder erteilst du allen Domaincomputern freigabe auf die Datei, oder nur der Gruppe, die zur installtion notwendig ist, das überlasse ich dir.

Gruß
Chris
Bitte warten ..
Mitglied: Poehli
12.08.2014 um 13:44 Uhr
neue OU erstellen, in die jeweils ein XP, W7 und W7x 64, und dann mit neuer GPO und neuer Ou noch mal probieren. Klingt auch für mich so als ob die W7er die GPO gar nicht ziehen. client durchstarten, GPO nochmal neu ziehen lassen, und was sagt gpresult bzw. serverseitig die Gruppenrichtlinienergebnisse der W7 Rechner mit normalem Benutzer? Wird die GPO angewendet, wenn nein warum nicht ......
Bitte warten ..
Mitglied: L0g1t3ch
12.08.2014 um 13:44 Uhr
Hallo Tiberius,

Im Anfangsbeitrag konnte ich ein Bild hinzufügen hoffe das reicht euch wie die Policy eingestellt ist.

Es handelt sich um 4 Software Pakete ein Ausrollen per Batchdatei gab es vorher was der Kunde nun aber nicht mehr wünscht hier soll für Alles eine GPO benutzt werden vom Laufwerksmapping bis zur Softwareverteilung sowie Druckermapping.

Grüße
Bitte warten ..
Mitglied: TlBERlUS
12.08.2014 um 13:58 Uhr
Hi,

1. für den Share-Ordner/der Ordner in dem die Pakete liegen braucht die Computergruppe die Sicherheitsberechtigungen Lesen+Ausführen
2. Wenn die in Sysvol liegen sollten(wie in meiner Testumgebung) dürfte eigentlich keine Probleme mit den Share-Berechtigungen sein
3. Die Regel muss unter Computerkonfiguration angelegt sein
4. Gib uns mal eine Übersicht über die Konfiguration
->mmc starten
->strg+m
->Gruppenrichtlinienverwaltungseditor
->GPO suchen
->Screens vom Pfad bis zur Software-Kofig
->Screens von der Konfig(hier am besten von Firefox/Reader)
http://www.frontmotion.com/Firefox/download_firefox.htm
hier hatte ich meine msi her(Version 30.0)

Grüße,

Tiberius
Bitte warten ..
Mitglied: Poehli
12.08.2014, aktualisiert um 14:05 Uhr
Ha, da fällt mir was auf bei dir. Du sagst du hast WS 2003 Basis. Ist da eventuell ein ADM ADMX Problem vorhanden? Weil W7 zieht wohl nur noch ADMX Files, wenn deine GPO noch von Früher ist würde das den Fall erklären.
Bitte warten ..
Mitglied: L0g1t3ch
12.08.2014 um 14:18 Uhr
Es gibt neue und es gibt alte GPO's wie kann ich das denn verifizieren was er sich zieht, ob ADM oder ADMX?
Bitte warten ..
Mitglied: TlBERlUS
12.08.2014, aktualisiert um 14:25 Uhr
Hi,

Korigier mich bitte, aber die adm/admx waren doch nur die Administrativen Vorlagen, die haben imho nichts mit der Problematik zu tun.
Abgesehen davon, kann man bei Win7 auch adm-Files importieren, damit sie benutzt werden(z.B. wuau.adm von WinXP).

Abgesehen davon, du hast doch neue GPO´s für die Verteilung erstellt?

Grüße,

Tiberius
Bitte warten ..
Mitglied: L0g1t3ch
12.08.2014, aktualisiert um 14:33 Uhr
Teils Teils Anwendungen wie der Dokuware Client haben nen Xtra X64 Client der hat ne neue GPO erhalten Extra für Windows 7 diese ist exakt so konfiguriert wie die XP Richtlinie mit dem Unterschied auf ein neues MSI für 64bit.

Ebenso hat Access und Outlook eine neue Policy erhalten für X64 Betriebssysteme.

EDIT : !!! Was würde passieren wenn ich die Basis der Domänenstruktur anhebe auf 2008? Könnte es hierran liegen? !!!
Bitte warten ..
Mitglied: TlBERlUS
12.08.2014 um 14:31 Uhr
Gut, ich persönlich vertrete die Philosophie, dass pro Kofiguration eine GPO vorhanden ist(allein um schneller Fehler zu finden)
4. Gib uns mal eine Übersicht über die Konfiguration
->mmc starten
->strg+m
->Gruppenrichtlinienverwaltungseditor
->GPO suchen
->Screens vom Pfad bis zur Software-Kofig
->Screens von der Konfig(hier am besten von Firefox/Reader)
http://www.frontmotion.com/Firefox/download_firefox.htm
hier hatte ich meine msi her(Version 30.0)
Bitte warten ..
Mitglied: L0g1t3ch
12.08.2014 um 14:38 Uhr
Was würde passieren wenn ich die Basis der Domänenstruktur anhebe auf 2008? Könnte es hierran liegen?
Bitte warten ..
Mitglied: Sheogorath
12.08.2014, aktualisiert um 14:50 Uhr
Moin,

durch dein Anheben würde nicht viel passieren, du würdest neue Policy Optionen freischalten, das setzt natürlich voraus, dass alle deine DCs Ü2003 sind. Ist einer 2003 kannst du die Ebene nicht anheben.

Gruß
Chris
Bitte warten ..
Mitglied: TlBERlUS
12.08.2014 um 14:51 Uhr
Kann ich mir schwerlich vorstellen/habe ich noch nicht angezettelt.

Ansonsten erstell dir doch eine Testdomäne per VMWARE um das zu simulieren.

Btw. Screenshots?
Bitte warten ..
Mitglied: L0g1t3ch
12.08.2014 um 14:52 Uhr
Ich bin gerade einfach mal die MSI durchgegangen ob diese sich denn so Installieren lassen ich denke das Problem rührt nicht von den Policys her zumindest nicht nur.

Die MSI rufen zwar die Install auf brechen aber ab mit der Meldung bitte führen Sie das Setup aus. Sowohl bei den Microsoft Produkten als auch für Dokuware.

Den Fehler hatte ich noch nie.
Bitte warten ..
Mitglied: Poehli
12.08.2014 um 15:01 Uhr
Ah.. ja. korrekt. Mein Fehler. Das schwirrte mir wohl so durch Kopf weil es gerade für FF ja die adm-files gab und ich das hier mit W7 begraben habe.

Bleibt abzuwarten was die Richtlinienergebnisse liefern und wie die Konfig im Detail aussieht.
Bitte warten ..
Mitglied: TlBERlUS
12.08.2014, aktualisiert um 15:06 Uhr
Was sagt die msi aus dem Link, wenn du sie installierst?

http://sourceforge.net/projects/sevenzip/files/7-Zip/9.20/7z920.msi/dow ...
Bitte warten ..
Mitglied: TlBERlUS
14.08.2014 um 14:48 Uhr
Hi,

falls sich das Problem erledigt haben sollte, bitte noch auf gelöst setzen, damit wir bescheid wissen.

Grüße,

Tiberius
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows 7
Windows 7 rechner fährt nicht mehr hoch - bluescreen (10)

Frage von jensgebken zum Thema Windows 7 ...

Windows Server
Startmenü über GPO Windows 10 - DC 2008 R2 (1)

Frage von dekztar zum Thema Windows Server ...

Windows Netzwerk
gelöst VPN Verbindung von Windows 10 Rechner an FritzBox 7490 (8)

Frage von Schwalbenfahrer zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...