Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Softwareverteilung - Repaketierung - GUI von msiexec bei jedem Programmstart

Frage Microsoft Windows Server

Mitglied: utopia

utopia (Level 1) - Jetzt verbinden

04.01.2008, aktualisiert 05.01.2008, 6182 Aufrufe, 5 Kommentare

Hallo,

Gegebene Situation
Ich betreue ein kleines Netzwerk mit Windows 2003 Servern und Windows XP Clients. Die Clients werden per RIS übers Netzwerk aufgesetzt. Die RIS-Images enthalten nur die Abbilder eines Rechnertyps samt vollständiger Treiberinstallation/Treiberkonfiguration je nach Bauart. Die Software wird via Active Directory GPOs verteilt (per Machine).
Da so manche installierte Software liefert keinen bzw. einen ungenügenden Installer bzw. MSI-Paket. Also habe ich ein Paket paketiert. Als beispiel soll hier ein vorkonfiguriertes Eclipse dienen. Dieses Paket wird durch einen Snapshot erstellt, die benutzerspezifischen Einträge entfernt (C:\Dokumente und Einstellung\%USERNAME%\* und HKEY_CURRENT_USER). Die Verteilung läuft perfekt.

Problem
Sofern ein Benutzer Eclipse öffnet startet erst ein msiexec-Fester, das darauf hinweißt, dass die Software konfiguriert wird. Bis dahin ist es ja verständlich, da erst die benutzerspeziefischen Daten ins Anwendungsverzeichnis geschrieben werden. Das wird aber bei JEDEM start der Software getan, sogar in der selben Session.

Frage
Wieso wird dieses Installations-Fenster überhaupt eingeblendet, wenn das Paket Eclipse ausschließlich Dateien enthält, die nach %PROGRAMFILES%\Eclipse entpackt werden. Registry-Änderungen werden auch nicht vorgenommen?
Wieso wird dieser Dialog bei jedem Start der Software angezeigt. Die Benutzerinformationen müssten doch schon bestehen?
Wieso funktioniert die Anwendung auch dann, wenn ich beim Installer-GUI auf Abbrechen drücke?
Bei manchen Paketen funktioniert es, das sind aber sehr wenige (5 - 10%)?

Ungeeignete Lösungen
- Softwareintegrierung in RIS-Images, da häufige Updates, die mittels GPO's besser verwaltet werden können.
- Kommerzielle Drittsoftware (Kosten)
- Scriptinstallation (Teils sichtbare Anwendungsfenster des msiexec trotz silent-mode, ist mir auch etwas unsympatisch)

Vielen Dank für Eure Antworten.
Mitglied: HuskyMcFly
04.01.2008 um 08:52 Uhr
Hi.
Wenn ich Pakete über Snapshots erstelle bekomme ich teilweise auch die wildesten Fehler. Ich traue diesem Verfahren auch nicht mehr über den Weg. Vielleicht versuchst du es mal Testweise mit einem Freeware Paketierprogramm. Ich selber benutze sehr gerne den Installer2Go. Bei sichtbaren Installationen gibt es nervige Werbescreens, wenn du es aber per GPO verteilst bleibt das Paket absolut Silent. Das Programm ist so easy das man kein Manual braucht. Vom Kauf des I2G kann ich allerdings abraten. Habe mir das Programm gekauft und auch einen Registrierschlüssel bekommen. Der funktioniert allerdings nicht, und vom Support habe ich trotz mehrmaliger Nachfrage nie eine Antwort erhalten, und das ist jetzt mehr als 2 Monate her. Sehr ärgerlich!

http://www.dev4pc.com/
Bitte warten ..
Mitglied: Logan000
04.01.2008 um 09:25 Uhr
Startest Du das Progamm einmal, wenn du einen Snapshot erstellst? Soltest Du tun.
Evtl. hast Du auch zuviel aus deinem Paket herausgeschmissen.

Als beispiel soll hier ein vorkonfiguriertes Eclipse dienen...
Wenn es is erster linie um die konfiguration geht, d. h. du hast ein MSI paket und möchtest nur einstellungen des Programms ändern, dann würde ich eher die bewusten RegKeys/Dateinen ermitteln und diese seperat per GPO ändern/anlegen.
Bitte warten ..
Mitglied: utopia
04.01.2008 um 23:34 Uhr
Bei Setup's, bei denen ich genau weiß, was installiert wird mag das gehen. Wie sieht es mit Software aus, die nicht auf msi-Setup basiert, sondern eigene oder andere Installer verwendet. Wie kann ich da ermitteln, was ich wo eintragen und ändern muss.
Bitte warten ..
Mitglied: utopia
04.01.2008 um 23:35 Uhr
Nein, die Programme habe ich nicht gestartet, erstelle aber gerade ein Paket um das zu prüfen. Zuviel habe ich nicht rausgeschmissen, da ich alle Reg-Einträge überprüft habe und da nur Explorer und weiß ich was für Änderungen entfernt wurden, die nichts mit der Software zu tun hatten.
Bitte warten ..
Mitglied: utopia
05.01.2008 um 19:56 Uhr
Ich habe jetzt mal ein paar paar programme nochmal neu paketiert und dabei gestartet. Selbes Verhalten.

Hat nochjemand eine Idee?
Bitte warten ..
Ähnliche Inhalte
Windows Installation
Frage zu Parameter bei msiexec
gelöst Frage von Diddi-tbWindows Installation6 Kommentare

Hallo zusammen, ich möchte den PDF Betrachter PDF Xchange Viewer über das Netzwerk verteilen. Jetzt habe ich mal auf ...

Windows Installation
GPO: msiexec im Startup-Skript
gelöst Frage von bensonhedgesWindows Installation7 Kommentare

Hallo, ich würde gern ein MSI-Paket, welches ich mit Parameter aufrufen muss, per GPO als Startup-Skript ausführen lassen. Das ...

Visual Studio
Tastaturabfrage während Programmstart
gelöst Frage von MartinSVisual Studio2 Kommentare

Guten Tag, ich möchte während des Programmstarts meine Tastatur abfragen, ob eine bestimmte Taste gedrückt ist. Diese soll die ...

Windows Installation
CMD-Batch Programmstart Befehle
Frage von timsen96Windows Installation1 Kommentar

Schönen guten Tag zusammen, ich möchte gerne über eine cmd oder batch datei ein Programm oder Installation öffnen und ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 41 MinutenViren und Trojaner

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 4 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell8 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...