Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Softwareverteilung Software wird nicht bei den Clients angezeigt

Frage Microsoft Windows Server

Mitglied: hoerni

hoerni (Level 1) - Jetzt verbinden

29.01.2008, aktualisiert 31.01.2008, 4199 Aufrufe, 12 Kommentare

Hallo,

ich versuche gerade auf einer Testumgebung mit einem Windows Server 2003 und einem Client
die Softwareverteilung einzurichten. Aber irgendwie funktioniert es nicht so wie ich das gerne hätte
bzw. so wie es eigentlich auch funktionieren sollte.

Die Software liegt in dem Ordner den ich bei den Gruppenrichtlinien angegeben habe und es handelt
sich auch bei jedem Paket um ein MSI PAket.

Wenn ich nun auf Clientseite unter Software Neue Programme hinzufügen will erscheint leider
keine Software.

Auf dem Server seh ich aber alle Programme wenn ich dort unter Software nachschaue.

Hat vielleicht irgendwer eine Idee welche Einstellungen noch falsch sein könnten?

Die Einstellungen hab ich auf Veröffentlichen gemacht, damit jeder nach Bedarf sich die Software
installierren kann.
Mitglied: geTuemII
29.01.2008 um 17:35 Uhr
Hallo hoerni,

wird die GPO mit der Softwareverteilung denn richtig auf die OU angewandt? Hast du am Client mal einen Richtlinienergebnissatz generiert?

geTuemII
Bitte warten ..
Mitglied: Beccy
29.01.2008 um 17:42 Uhr
Hallo,

sind die Clienten zwischendurch einmal herunter gefahren und neu gestartet worden ?

Wenn nein, dann führe mal auf einem Clienten den Befehl "GpUpdate" in der Konsole aus.


Beccy
Bitte warten ..
Mitglied: geTuemII
29.01.2008 um 17:47 Uhr
@Beccy:
Das hätte ich jetzt angenommen, wenn es sogar der Server schon gemerkt hat. Aber du hast recht, manchmal kann man gar nicht so blöd denken, wie es läuft.

geTuemII
Bitte warten ..
Mitglied: hoerni
30.01.2008 um 08:35 Uhr
Danke für die guten Tips.

Leider führten sie noch zu keinem Erfolg hab gerade nochmal alles durchgegangen.
An den Clients werden lediglich die von mir vergebenen Kategorien angezeigt.
Nur leider kommt die Aussage das keine Programme im Netzwerk verfügbar wären.

Aber wenn die Clients die Kategorien angezeigt bekommen sollte ja die default grp policy
wenigstens im Ansatz funkitonieren ?
Bitte warten ..
Mitglied: hoerni
30.01.2008 um 11:07 Uhr
Hab nun noch mal verschiedene MSI Pakete in die Softwareverteilung aufgenommen.
Siehe da manche werden angezeigt im Netzwerk und andere nicht .?

Kann es sein das der Server manche MSI Pakete nicht bereitstellt und er selber eine
vorauswahl trifft ? Wäre aber eigentlich ziemlich dumm da es sich in den meisten
fällen um eigene Microsoft Pakete handelt.

z.b der ShadowCopyClient.
Bitte warten ..
Mitglied: Beccy
30.01.2008 um 11:15 Uhr
Hallo,

Deine Default Domain Policy scheint zu stimmen.

Sind die Pfadangaben denn korrekt ?

Normalerweise werden die Pogramme unter "Neue Programme hinzufügen" in der Software angezeigt. Und wenn man dann versucht, das programm auf dem Clieten zu installieren, dann kann bei falschem Pfad das natürlich nicht klappen.

Aber die Clienten zeigen es an, wenn der Pfad nicht stimmt und melden, dass das Progamm auf dem
Server nicht gefunden werden kann.

LG.

Beccy
Bitte warten ..
Mitglied: hoerni
30.01.2008 um 11:21 Uhr
Also ich habe nun zu Versuchszwecken 7 verschiedene MSI Pakete auf dem
Server im selben Ordner abgelegt. Alle Pakete sollten in der Softwareverteilung
angezeigt werden.

Auf dem Server werden auch alle 7 Pakete unter Neue Programme hinzufügen angezeigt,
auf dem Client leider nur 3 Pakete.?
Bitte warten ..
Mitglied: Beccy
30.01.2008 um 11:40 Uhr
Hallo,

wenn die Pakete, bzw. die Software bereits auf den Clienten, z.B. durch die Installation der Clienten bereits installiert sind, werden sie natürlich nicht mehr als hinzufügbare Software angezeigt.

Worum handelt es sich bei den 4 übrigen MSI-Paketen genau ?

Beccy
Bitte warten ..
Mitglied: hoerni
30.01.2008 um 12:14 Uhr
Bei den Paketen handelt es sich um das Shadowcopytool von Microsoft, PPointviewer von Microsoft und einen eigens erstelltes MSI Paket vom Foxitreader.

Hab gerade nochmal die ganze Software überprüft. Die ganzen Pakete sind nicht installiert
und sollten eigentlich angezeigt werden.

Komisch war bzw. ist das bei dem Client die BerkeleyDB installiert war und man sie dennoch
unter Software gesehen hat.
Bitte warten ..
Mitglied: Beccy
30.01.2008 um 13:33 Uhr
Die Pakete von Microsoft sollten keine Probleme machen.

Wie es mit dem Foxitreader aussieht, kann ich Dir nicht sagen, aber ich schlage vor, Du zerlegst das MSI und schaust Dir die Berechtigungen der Exe und der restlichen Dateien an.

Und ich muss einen Irrtum zugeben: Bereits installierte Programme werden unter Software weiter angeboten.

Es kann aber auch sein, dass die BerkeleyDB etwas durcheinander gebracht hat.

Und ausserdem überprüfe bitte auch einmal die Berechtigungen für die Ordner und die Files.

LG.

Beccy
Bitte warten ..
Mitglied: hoerni
30.01.2008 um 13:40 Uhr
Ja das mit den Microsoft Dateien hab ich auch gedacht. Aber ist schon komisch die ganze
Sache. Die Berechtigungen auf den Ordner und auf die Files habe ich auch schon auf
Vollzugriff geändert. Leider auch erfolglos

Wenigstens bin ich beruhigt das schonmal etwas angezeigt wird und ich nicht
kompletten mist gebaut.

Ich werde nochmal alles genau überprüfen.
Bitte warten ..
Mitglied: hoerni
31.01.2008 um 08:42 Uhr
Neuer Tag neues Glück

gerade noch ein bissel gelesen und dann bin ich noch auf etwas gestossen was ich noch nicht
gesehen hatte bzw. nicht beachtet habe.

unter bereitstellung von software --> erweiterung --> den haken sprache beim bereitstellen der software ignorieren einfach setzen.

Siehe da es werden endlich alle Pakete dargestellt.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
gelöst Software auf Clients per Skript de-installieren (10)

Frage von ArnoNymous zum Thema Batch & Shell ...

Windows Update
WSUS zeigt max. 69 Clients an (2)

Frage von TheGoodOne zum Thema Windows Update ...

Backup
Clients als Server missbrauchen? (21)

Frage von 1410640014 zum Thema Backup ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...