Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Sondertasten der Intelli Maus funktionieren nicht bei Programmen die als Admin ausgeführt werden.

Frage Microsoft

Mitglied: Agenor

Agenor (Level 1) - Jetzt verbinden

30.08.2010 um 15:54 Uhr, 3934 Aufrufe, 2 Kommentare

Ich habe die zusätzlichen Tasten meiner Intelli Maus mit Sonderfunktionen belegt. Diese funktionieren nicht, wenn ein Programm bei aktiver UAC mit der Funktion "Ausführen als Administrator" gestartet wird.

Hallo!

Ich verwende ein Microsoft Wireless Laser Keyboard 6000 v2 und eine Wireless Laser Mouse 6000. Maus und Tastatur verfügen über einige Sondertasten der Funktionen man über die Intelli Software fast beliebig frei einstellen kann. So habe ich z.B. an Maus und Tastatur Tasten mit den Befehlen "Kopieren" und "Einfügen" belegt. Das Ganze funktioniert wunderbar und sehr zuverlässig. Da durch die Funktionen scheinbar einfach die Standardkommandos Strg+C und Strg+V ausgelöst werden, funktionieren die Tasten bisher in allen Programmen ohne Probleme.

Ich verwende Windows 7 mit einem Admin-Account mit aktiver UAC. Wenn ich nun ein Programm mit Admin-Rechten starte, funktionieren die Sondertasten innerhalb dieses Programms nicht mehr wie gewünscht. Statt der eingestellten Funktionen "Kopieren" und "Einfügen" werden nun die Standardfunktionen der Sondertasten ausgeführt. Bei der Maus sind dies z.B. "Vor" und "Zurück". Es ist natürlich extrem lästig, wenn man von einer Taste eine bestimmte Aktion gewöhnt ist und dann auf einmal eine ganze andere Aktion ausgeführt wird.

Vermutlich liegt die Ursache des Problem darin, dass beim "Ausführen als Administrator" das Programm unter einem anderen Benutzerkonto ausgeführt wird. In diesem Konto sind die Sondertasten nicht speziell konfiguriert und haben daher eben ihre Standardfunktionen. Um dies zu prüfen habe ich aber auch schon das Konfigurationsprogramm für Maus und Tastatur mit Admin-Rechten gestartet. Hier werden die Belegungen der Tasten korrekt angezeigt...

Bei deaktiviertet UAC tritt das Problem nicht auf (hier muss ja auch nicht "Als Admin" gestartet werden), aber nur aus diesem Grund die UAC zu deaktivieren ist natürlich wenig sinnvoll. Speziell auf Windows 7 ist das Problem nicht beschränkt. Zuvor unter Vista habe ich es ebenfalls beobachtet.

Da die Intelli Hardware von Microsoft ja eigentlich recht weit verbreitet ist und die zugehörigen Tasten bestimmt auch oft selbst konfiguriert werden, sollte das Problem auch bei anderen auftreten. Gibt es also jemanden der Erfahrung hiermit hat und vielleicht sogar eine Lösung kennt?

Besten Dank
Agenor
Mitglied: atbs84
30.08.2010 um 16:42 Uhr
Moin,

das Problem hast wohl nicht nur du:
http://www.google.de/#hl=de&source=hp&q=intellimouse+uac+button ...

Eine Lösung ist wohl da nicht gefunden, aber der Hinweise auf andere Software, die Maus-Buttons konfigurieren kann - probier doch mal sowas.
Bitte warten ..
Mitglied: DerWoWusste
30.08.2010 um 18:41 Uhr
Das ist ein Problem, welches durch die Architektur von Windows (seit Vista) entsteht und somit kein Bug.
Der Prozess, der die Sonderbelegungen auswertet, läuft mit Nutzerrechten und kann somit keine Tastendrücke an Anwendungen senden, die mit höheren Rechten laufen.
Dies verhindertshatter attacks und das ist auch gut so.

Abhilfe nur über das Starten des Prozesses selbst mit hohen Rechten, so geht es bei mir. Ich habe hier jedoch keinen Maustreiber, sondern lediglich ein Miniprogramm (doppelklick.exe), das die Radtaste als Doppelklick auswertet.
Bitte warten ..
Ähnliche Inhalte
Hyper-V
Maus und Tastatur funktionieren in HyperV nicht (4)

Frage von manuelw zum Thema Hyper-V ...

Windows Server
gelöst Windows Server 2003 unter HyperV 2012 R2: Keine Maus (2)

Frage von StefanMUC zum Thema Windows Server ...

Windows 7
Performance Probleme bei Programmen und Windows (10)

Frage von Kunzi333 zum Thema Windows 7 ...

Neue Wissensbeiträge
Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(1)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(38)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
POS Hardware und alternativen zu Raid 1? (21)

Frage von Brotkasten zum Thema Festplatten, SSD, Raid ...

Viren und Trojaner
Verschlüsselungstrojaner simulieren (18)

Frage von AlbertMinrich zum Thema Viren und Trojaner ...

Windows 10
Windows 10 Home "Netzlaufwerk nicht bereit" (12)

Frage von Oggy01 zum Thema Windows 10 ...

SAN, NAS, DAS
+100tb Storagelösung (10)

Frage von Data-Fabi zum Thema SAN, NAS, DAS ...