Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Spalten aus mehreren Tabellen zusammenfassen

Frage Microsoft Microsoft Office

Mitglied: gnom379

gnom379 (Level 1) - Jetzt verbinden

17.10.2010 um 17:02 Uhr, 4418 Aufrufe, 5 Kommentare

Hallo!
ich bräuchte mal wieder ein paar Denkanstöße. Ich habe leider noch nichts passendes zu meinem Problem gefunden.

Mein Problem ist es, dass ich aus 2 Tabellen eine Tabelle bauen muss/ soll.

Tabelle1 (tab1) sieht wie folgt aus:

Spalte A Spalte B Spalte C
Name,Vorname Daten Daten


Tabelle 2(tab2) ist das gleiche Format wie Tabelle 1 nur das in der 2.Tabelle einige Zeilen (Namen) fehlen bzw. mehr drin sind.

Die Zusammenführung sollte dann in der 3.Tabelle (Auswertung) erfolgen und folgendes Format heben:

Spalte A tab1.Spalte B tab1.Spalte C tab2.Spalte B tab2.SpalteC


Wie bekomme ich das am einfachsten hin?

Ich habe Office 2003.

Wenn ihr mehr Input braucht schreibt es einfach.

Vielen Dank im Voraus


der gnom
Mitglied: bastla
17.10.2010 um 19:49 Uhr
Hallo gnom379!

Falls es sich dabei um eine einmalige Aktion handeln soll, würde ich die Werte aus "tab 1" komplett in die Auswertungstabelle kopieren und in den Spalten D und E per "SVERWEIS()" die Werte aus "tab 2" ergänzen - für D2 wäre die Formel dann etwa (den Zeilenwert 1000 musst Du noch an Deine Gegebenheiten anpassen, wobei Du hier problemlos einen zu hohen Wert verwenden kannst):
=SVERWEIS(A2;'tab 2'!$A$1:$C$1000;2;0)
In der Spalte E müsstest Du aus der letzten 2 eine 3 machen.

Datensätze, die in "tab 2" nicht enthalten sind, kannst Du an der Fehlermeldung "#NV" erkennen - was damit geschehen soll, musst Du selbst wissen ...

Um auch umgekehrt die überzähligen Zeilen aus "tab 2" zu finden, könntest Du eine ähnliche Formel in der Spalte D von "tab 2" verwenden:
01.
=SVERWEIS(A2;'tab 1'!$A$1:$A$1000;1;0)
Für alle nicht auch in "tab 1" enthaltenen Datensätze bekommst Du wiederum die Fehlermeldung "#NV". Wenn Du jetzt noch nach der Spalte D sortierst, befinden sich alle "#NV"-Zeilen in einem Block und Du kannst die Spalten A-C dieser Zeilen markieren, ans Ende der Liste in der Auswertungstabelle kopieren und dort die Spalten B und C noch nach D und E verschieben (wo ja auch oberhalb bereits die übrigen Werte aus "tab 2" stehen).

Grüße
bastla
Bitte warten ..
Mitglied: gnom379
17.10.2010 um 20:42 Uhr
Hallo!
Danke für deine Antwort. Welche Möglichkeiten habe ich wenn ich dies öfter machen muss?

Danke im Voraus

der gnom
Bitte warten ..
Mitglied: bastla
17.10.2010 um 20:49 Uhr
Hallo gnom379!
Welche Möglichkeiten habe ich wenn ich dies öfter machen muss?
VBA (oder die Aufteilung von Vornherein vermeiden ) ...

Grüße
bastla
Bitte warten ..
Mitglied: gnom379
17.10.2010 um 22:58 Uhr
VBA (oder die Aufteilung von Vornherein vermeiden ) ...

Die Aufteilung darf ich leider vorher nicht machen. so hatte ich das als
erstes bis der Datenschützer unserer Firma kam und sagte alles
in zwei Dateien nur für die Auswertung zum drucken.

Grüße
der gnom
Bitte warten ..
Mitglied: Biber
17.10.2010 um 23:23 Uhr
Moin gnom379,

was soll dann eine komfortablere Bearbeitung "wenn ich das öfter machen muss" ??
Wenn der eigentliche Prozess schräg ist und gewünschtermaßen schräg bleiben soll - dann lass es dir gemäß verbratener Arbeitsstunden bezahlen.

Diser Abgleich scheint ja offensichtlich NICHT das Ziel zu haben, diese beiden Tabelleninhalte einmalig abzugleichen und eine neue Referenztabelle zu erzeugen. Vielleicht findet ja dieser Abgleich statt - aber dennoch entstehen wieder irgendwo neue Tabellen A und B.
Unabhängig davon wird noch jemand anders damit beschäftigt, auf einer "Auswertung" die dubiosen Fällen mit gelben und grünen Textmarker hervorzuheben.

Sorry, auch wenn sich da natürlich etwas "automatisieren" lässt mit VBA oder ähnlichem...
... dadurch wird es nicht zu einem optimiertem Prozess.
Eher verhindert VBA in diesem Fall, dass diese Mimik mal auf den Prüfstand kommt.

Grüße
Biber
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...