Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Speicherpfad in Fussziele bei Word 2007

Frage Entwicklung VB for Applications

Mitglied: Chris85

Chris85 (Level 1) - Jetzt verbinden

03.08.2009, aktualisiert 11:42 Uhr, 5563 Aufrufe, 1 Kommentar

Hi Leute

Ich habe folgendes Problem:

ich habe mir bei Word 2003 ein Makro erstellt, welches mir den Speicherpfad in der Fusszeile eines Dokuments eingeblendet bzw. auch wieder ausgeblendet hat. Nun habe ich versucht dies unter Word 2007 zu erstellen.

Meine Vorgehensweise:

1. Entwicklertools eingeblendet
2. Makro aufzeichnen
3. Einfügen Fusszeile
4. Schnellbaustein - Feld - Feldname - FileName - Startbuchstaben Groß - Pfand einblenden
5. Fusszeilenansicht beednen
6. Makroaufzeichnung beenden

Es erscheint beim Ausführen des Makros der Laufzeitfehler 5941 "Das angeforderte Element ist nicht in der Sammlung vorhanden".

Im Debug-Mode wird folgendes angezeigt:

Sub Makro1()
'
' Makro1 Makro
'
'
WordBasic.ViewFooterOnly
ActiveDocument.AttachedTemplate.BuildingBlockEntries(" Leer").Insert Where _
:=Selection.Range, RichText:=True
ActiveWindow.ActivePane.View.SeekView = wdSeekMainDocument
End Sub


Der Marker liegt auf:

ActiveDocument.AttachedTemplate.BuildingBlockEntries(" Leer").Insert Where _
:=Selection.Range, RichText:=True


Da ich mich in der VBA-Programmierung nicht auskenne wollte ich fragen, ob mir jemand weiterhelfen könnte.

Für Hilfe bin ich sehr dankbar

Chris
Mitglied: Chris85
10.08.2009 um 09:32 Uhr
Hi

Also des Rätsels Lösung ist die beiden Zeile auf denen der Marker liegt auszukommentieren!

Gruß

Chris
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Microsoft Office
gelöst Schnellbausteine aus Word 2007 nach Word 2016 übernehmen (2)

Frage von TiTux zum Thema Microsoft Office ...

Microsoft Office
gelöst Standard Ansicht Word Navigationsleiste (9)

Frage von leofabian zum Thema Microsoft Office ...

Basic
gelöst Mit vb.net PDF in Word-Dok einfügen (10)

Frage von ahstax zum Thema Basic ...

Microsoft Office
Word doc kann nicht geöffnet werden abe nach umbenennung zu docx (3)

Frage von henschel87 zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...