Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Sporadischer Paketverlust zwischen Firewall und Modem

Frage Netzwerke Router & Routing

Mitglied: dq28121989

dq28121989 (Level 1) - Jetzt verbinden

30.05.2013 um 11:07 Uhr, 2622 Aufrufe, 5 Kommentare, 2 Danke

Hallo Community,

ich habe das Problem, dass meine Fortinet-Firewall gelegentlich 30% Paketverlust hat. Gelegentlich heisst, dass es meist klappt aber ab und zu ein paar Stunden das Surfen unmöglich wird, weil der Verbindungsaufbau dauernd abbricht.

Ich habe zum Test Pings von verschiedenen Clients abgesendet. Das Ergebnis war, dass intern alles läuft wie es soll und einzelne Pings, welche an google.de, heise.de oder facebook.com gehen einfach nicht zurückkommen. Die Latenzen sind stabil und die ttl varriiert auch nur zwischen einen Hop.
Ich habe mich auch direkt ans Modem gehängt und von dort aus getestet ob mir Pakete verloren gehen. Dort lief alles einwandfrei. Von der Fortinet über die CLI abgesendeten Pings gehen allerdings auch verloren. Das Kabel, welches ich zum testen direkt an dem Modem verwendet habe, ist das selbe welches in der Fortinet steckt.

Es handelt sich um eine Fortinet wifi 40C und ein Cisco EPC3212 Modem.

Der ISP ist Kabel Deutschland mit einer 100 Mbit/s Leitung. Es gab vorher die Probleme, dass Kabel Deutschland nicht die Bandbreite liefern konnte, die versprochen wurde. Dies ist mittlerweile gelöst. Meine Theorie ist, dass Kabel Deutschland QOS-Mechanismen verwendet und die Pakete deshalb verworfen werden. Bin aber kein QOS-Experte und weiß nichts über Kabel Deutschlands interne Architektur.

Hat vielleicht jemand eine Idee wo das Problem seinen Ursprung hat? Gibt es Kompaktibilitätsprobleme zwischen Fortinet und Cisco?

Gruß dq
Mitglied: aqui
30.05.2013, aktualisiert um 14:17 Uhr
Es könnte ein Autonegotiation Problem zwischen Modem Port und Firewall Port sein. Das kommt häufig mal vor zw. Fremdherstellern. Dadurch kommt es dann bei Traffic zu Kollisionen an diesem Port durch den Speed oder Duplex Mismatch, die genau das Fehlermuster zeigen wie bei dir.
Dadurch das du direkt einen Testrechner am Modem hast zum Pingen und das fehlerfrei rennt sieht es sehr nach diesem Problem aus.
Gleichzeitig zeigt es das es niemals QoS Probleme sein können, denn diese schliesst du damit ja faktisch aus.
Es ist aber klar und auch bekannt bei TV Kabelmodems bzw. Anschlüssen, das man sich die "letzte Meile" mit hunderten und mehr anderen Teilnehmer teilen muss. Du hast also rein nur einen physische 100 Mbit Connect Rate, was nachher als wirkliche Paket Forwarding Rate durch das Netz geht steht auf einem ganz anderen Blatt Papier und darüber wahrt der Kabelprovider auch striktes Stillschweigen.
Dieses Sharing bewirkt aber niemals das es bei extrem langsamen Pings im 1 Sekunden Rhythmus zu Paketverlusten kommt. Die hat man ja noch nicht einmal auf einer "Bauern DSL" Leitung mit 384 kBit/s.
Du kannst das Problem aber ganz einfach lösen indem du den Fortinet Port fest, statisch auf 100 Mbit, Fullduplex setzt und auch analog den Modemport auch fest auf 100Mbit, Fullduplex einstellst.
Damit sollte das Problem dann nicht mehr auftreten.
Bitte warten ..
Mitglied: dq28121989
30.05.2013 um 15:48 Uhr
Vielen Dank für die Antwort aqui. Daran habe ich noch nicht gedacht, sehr gute Idee.
Ich werde es testen und berichten.

Gruß dq
Bitte warten ..
Mitglied: MrNetman
30.05.2013 um 17:12 Uhr
Und das Modem ist kein reines Modem im herkömmlichen Sinne.
Es ist ein Router, der weitere Geräte mit Hilfe eines Switches ins Internet bringen kann.

Achte bei der Verbindung der Fortinet auch auf das Kabel (Crossover halb, crossover voll, gerades Patchkabel) und teste alle manuellen Konfigurationen auch auf die Geschwindigkeit hin. Duplex-Missmatch wird leider erst in den TCP-Schichten repariert. Der Geschwindigkeitseinbruch bei Vollast ist merklich, bei Teillast kaum zu erkennen.
Achtung:
FDX auf Auto = Missmatch
HDX auf Auto = ident aber nur 100Mbit/s halbduplex.
Gigabit Auto und Gigabit FDX vertragen sich gar nicht.

Gruß
Netman
Bitte warten ..
Mitglied: dq28121989
30.05.2013 um 17:17 Uhr
Vielen Dank für die Hinweise.
Bitte warten ..
Mitglied: dq28121989
01.06.2013 um 17:28 Uhr
Update: Es war wohl ein defektes Patch-Kabel ... Beide Seiten standen auf Auto und haben Fullduplex Gigabit-Lan ausgehandelt.

Gruß
dq
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst VLAN zwischen Routern und Firewall (9)

Frage von Seoxx1 zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Empfehlung günstiges ADSL2+ nur Modem (10)

Frage von TimMayer zum Thema Router & Routing ...

Netzwerkmanagement
IPTV hinter einer Firewall (T-Entertain an Fritzbox+ZyWALL) (7)

Frage von Venator zum Thema Netzwerkmanagement ...

Humor (lol)
Der Unterschied zwischen USA und USB

Link von BirdyB zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...

DSL, VDSL
DSL-Signal bewerten (8)

Frage von SarekHL zum Thema DSL, VDSL ...