Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Sporadischer Ping-Verlust bei Webserver - Erreichbarkeit eingeschränkt

Frage Netzwerke

Mitglied: Ediorus

Ediorus (Level 1) - Jetzt verbinden

19.07.2010 um 17:22 Uhr, 4126 Aufrufe, 7 Kommentare

(Web)Server im LAN (Apache 2.2) ist teilweise nicht erreichbar

Hallo zusammen!

Ich habe mich jetzt schon schusselig gesucht und nichts hilfreiches gefunden, daher beschreibe ich Euch mal mein Problem:

Wir haben hier im Firmennetzwerk einen Webserver für unsere Intranet-Webseiten, internes Forum, etc.

Bis vor Kurzem lief das Ganze auf einem alten Server (Uralt-Apache auf Suse, Version unbekannt). Eines Tages trat o.g. Problem auf, ohne dass es eine Änderung an Netzwerk- und Serverhardware gab.
Von Zeit zu Zeit (mehrmals am Tag, geschätzt alle 60 Minuten) war die Webseite nicht erreichbar und der Browser meldete einen Timeout.
Um dem Problem auf den Grund zu gehen liess ich einfach mal tagsüber einen Dauerping laufen. Dieser zeigte, dass - natürlich - in der Zeit der "Nicht-Erreichbarkeit" - der Server keine Antwort schickte.
Die Dauer des Ganzen beschränkte sich auf ca. 2-5 Minuten, anschliessend lief es wieder.
Ich dachte erst an ein Hardware-Prob, also tauschte ich erst die NIC, dann die Kabel und zu guter letzt wechselte ich auch noch auf einen anderen Switch. Keine Besserung...

Also nahm ich einen frisch installierten Windows Server 2003 (Standard Edition), der gerade sonst nichts zu tun hatte, installierte den aktuellen Apache (für Windows versteht sich, also keine VM o.ä.), PHP4
(mit 5 läuft das CMS nicht), und die aktuellste Version von MySQL.
Also komplett anderes OS, andere Hardware (die bis dato einwandfrei lief), andere und neuere Versionen der Webserverumgebung.

Der einzige Unterschied, den ich jetzt feststellen konnte, besteht darin, dass der "neue" Server die "Ausfälle" deutlich seltener zeigt, nur noch 1-3 Mal pro Arbeitstag.
Ein Tausch der entsprechenden Komponenten brachte auch hier keine Besserung.

Vielleicht noch ein nicht unwichtiger Hinweis: Wir haben zwar selbstverständlich eine Firewall (Astaro), jedoch sind die betroffenen Client-PCs bzw. die beiden erwähnten Server im selben NW-Segment,
von daher schliesse ich den Einfluss der Astaro erstmal aus.
Weiterhin waren/sind von den Ping-Ausfällen nur die beiden erwähnten Server betroffen.

Hat vielleicht einer von Euch eine Idee dazu?

Gruß,

Ediorus
Mitglied: dog
19.07.2010 um 18:04 Uhr
IP-Adressen-Konflikt?
Passiert es auch wenn du nur einen PC direkt verbindest?
Bitte warten ..
Mitglied: headbanger9
19.07.2010 um 18:16 Uhr
Spanning-Tree, UPNP, IP-Adress-Konflikt ...

Switchport mirrorn und Wiresark ranhängen,
logging auf den Swiches angeschaut ?

cu h.
Bitte warten ..
Mitglied: fisi-pjm
20.07.2010 um 08:36 Uhr
Hi,

da du sagst "gleiches Netzwerksegment" denk ihr habt ein Router dazwischen. Kontrollier mal die Routen, Vll stehen irgendwo 2 gleiche IPs drin.
Bitte warten ..
Mitglied: Ediorus
20.07.2010 um 08:46 Uhr
Zitat von dog:
IP-Adressen-Konflikt?
Passiert es auch wenn du nur einen PC direkt verbindest?

IP-Adressen-Konflikt habe ich schon ausgeschlossen, aber danke für den Hinweis.

Die direkte Verbindung konnte ich noch nicht testen, müsste ich dann mal am Wochenende tun...
Bitte warten ..
Mitglied: Ediorus
20.07.2010 um 08:48 Uhr
Zitat von headbanger9:
Spanning-Tree, UPNP, IP-Adress-Konflikt ...

Switchport mirrorn und Wiresark ranhängen,
logging auf den Swiches angeschaut ?

cu h.



Habe mir alle möglichen Logs und Tests auf unserem Dell PowerConnect 5448 angeschaut, der entsprechende Port ist allerdings völlig unauffällig
Bitte warten ..
Mitglied: Ediorus
20.07.2010 um 08:50 Uhr
Zitat von fisi-pjm:
Hi,

da du sagst "gleiches Netzwerksegment" denk ihr habt ein Router dazwischen. Kontrollier mal die Routen, Vll stehen
irgendwo 2 gleiche IPs drin.

Verstehe Deine Meldung nicht so ganz, gleiches NW-Segment heisst für mich (Beispiel):
192.168.1.XXX <- Client
192.168.1.XXX <- Server

Von daher brauche ich doch keinen Router dazwischen?
Bitte warten ..
Mitglied: fisi-pjm
20.07.2010 um 13:36 Uhr
da du gleiches Netzwerksegemnt extra betont hast dachte ich ihr habt noch andere netzwerksegmente, die ihr wahrscheinlich durch einen Router getrennt habt. Gehen die Clients bzw. die Server aus irgend einem Grund über den Router und es gibt dort 2 einträge zur zeil ip die identisch sind aber jeweils auf einen anderen Port verweisen kanns auch mal zu komischen Fehlern kommen. Aber ich glaube das ist bei dir eher nicht das Problem. Es war nur ein weiterer Ansatz.

Gruß PJM
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Batch & Shell
gelöst Batch um mehrere IP-Adressen via Ping auf Erreichbarkeit zu prüfen (5)

Frage von Galindiesel zum Thema Batch & Shell ...

Groupware
Newsletter Mails vom Webserver oder Mailserver versenden? (10)

Frage von Lakatusch zum Thema Groupware ...

Google Android
ANDROID - PING (2)

Frage von MrRobot1997 zum Thema Google Android ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...