Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Sporradisch auftretendes Schreibrechteproblem und Windows 2003 R2 Server

Frage Microsoft Windows Server

Mitglied: optimax

optimax (Level 1) - Jetzt verbinden

11.01.2007, aktualisiert 13.01.2007, 7539 Aufrufe, 11 Kommentare

Hallo,

zuerst möchte ich sagen das ich kein Netzwerkguru bin. Habe mich dennoch auf die Installation eines einfachen Netzwerkes mit 3 Clients (1 NB mit WinXP Prof., 1 NB mit WinXP Home sowie eine PC Workstation mit WinXP Home) und ein Windows 2003 R2 Server von Dell gewagt. Ein vorhandener DSL Router (Draytek) verbindet nun das Netzwerk.
Ich weiss eine haarsträubende Konstellation.

Auf dem Server soll eigentlich nur Lexware Financial Office laufen. Laut Angabe von Lexware brauchen die nur schreibrechte auf das Installationsverzeichnis auf dem Server. Nach der Serverinstallation und Anlage einer Gruppe sowie der Benutzer, habe ich das Installations-Verzeichnis für die Gruppe freigegeben. Auf den Clients habe ich eine Batch mit dem "net use" Befehl geschrieben und in den Autostart reingesetzt.

@echo off
@354 use L: \\SERVERNAME\FREIGEGEBENESVERZEICHNIS passwort /USER:benutzername /persistent:yes

Somit wird ein Laufwerk bei Windowsstart auf das Installationsverzeichnis von Lexware Office gemappt.

Die Benutzer melden sich also auf dem Server nicht direkt an, also keine Domäne und keine festen IPs vergeben macht der Router. Hat alles so funktioniert so ca. 3 Monate lang.

Jetzt kommt allerdings öfters eine Fehlermeldung von Lexware, "Kein Schreibrecht auf Verzeichnis xxxxxxx...... vorhanden" oder so ähnlich.

Rechte und Freigaben sind aber vorhanden. Nach mehrmaligem Aufruf des Lexware Office Programmes (nach ca. 10 bis 20 mal, manchmal mehr manchmal weniger) startet aber das Program ganz normal.

Ich wollte die IPs festvergeben aber dann ging nichts mehr. Irgendwie ist das schon anders als bei Windows 2000 Server. Könnte hierbei auch Hilfe gebrauchen.

Was kann also diesen Zugriffsproblem verursachen? Kann die Datenbank (SQL) das verursachen? Sie wurde ja mit der Zeit etwas größer.

Bin für jede Antwort und Hilfe dankbar.
Viele Grüße
optimax
Mitglied: Tundra
11.01.2007 um 07:44 Uhr
Bei Freigaben unter w2k3 muss man gegenüber w2k extra die Berechtigungen auf die Freigabe setzen.
Du musst also Freigabe- und NTFS-Berechtigungen setzen.
Außerdem solltest Du "system" Vollzugriff auf die zu schreibenden Ordner von dem Programm setzen.

Grüße
Guido
Bitte warten ..
Mitglied: geTuemII
11.01.2007 um 09:34 Uhr
Das klingt für mich weniger nach einem Berechtigungsproblem, sondern eher nach einem Problem mit dem DNS.

Erkläre mir bitte nochmal deine konfiguration:
Der Router macht DHCP, der DHCP des Servers ist nicht konfiguriert und läuft auch nicht? Läuft der DNS auf dem Server, und (wenn ja) wird er mit dem DNS abgeglichen? Ist der DNS den Clients bekannt? Hat wenigstens der Server eine feste IP?

geTuemII
Bitte warten ..
Mitglied: optimax
11.01.2007 um 10:31 Uhr
Das klingt für mich weniger nach einem
Berechtigungsproblem, sondern eher nach einem
Problem mit dem DNS.

Erkläre mir bitte nochmal deine
konfiguration:
Der Router macht DHCP, der DHCP des Servers
ist nicht konfiguriert und läuft auch
nicht
? Läuft der DNS auf dem Server,
und (wenn ja) wird er mit dem DNS
abgeglichen? Ist der DNS den Clients bekannt?
Hat wenigstens der Server eine feste IP?

geTuemII

So ist es der Router macht immo DHCP. Der Server hat keine feste IP. Alles läuft über den Router.
Das mit der DNS ???? Kann ich später dazu was sagen. Komme heute noch dazu, denke ich.
Bitte warten ..
Mitglied: geTuemII
11.01.2007 um 11:13 Uhr
Läuft der DNS auf dem Server, und (wenn ja) wird er mit dem DNS abgeglichen?

Das möchte natürlich heißen:
Läuft der DNS auf dem Server, und (wenn ja) wird er mit dem DHCP abgeglichen?

Sorry, geTuemII
Bitte warten ..
Mitglied: optimax
11.01.2007 um 14:27 Uhr
Sollte (muß) ein DNS Server laufen auf dem Server? Und ist es zwingend erforderlich? Es ist noch kein DNS Server und DHCP Server eingerichtet. Es läuft nur der Dateiserver.

Jetzt habe ich auf dem Server eine feste IP vergeben. Aber keine Besserung.

Was wäre eine Musterlösung für diese einfache Anforderung?
Bitte warten ..
Mitglied: geTuemII
11.01.2007 um 16:56 Uhr
Geht es denn nach der festen IP für den Server, daß das LW per Angabe der IP sauber verbunden werden kann?

@354 use L: \\SERVER_IP\FREIGEGEBENESVERZEICHNIS passwort /USER:benutzername /persistent:yes

geTuemII
Bitte warten ..
Mitglied: optimax
11.01.2007 um 21:47 Uhr
Ja. Der net use Befehl funktioniert schon richtig. Auch vorher schon, ohne Feste IP-Vergabe. D.h. ich habe schon Schreibrecht auf das gemappte Laufwerk L: .
Kann also vom Client PC aus Dateien auf das freigegebene Serververzeichnis schreiben. Nur bei Programmaufruf kommt die Fehlermeldung, "Kann Lexware nicht starten da die entsprechenden Schreibrechte auf das Verzeichnis L:\XXXX nicht vorhanden sind".
Wenn ich dann weiter probiere zu starten, dann geht es ja irgendwann.
Habe heute neue Benutzerkonten erstellt auf den Clients, identisch mit Benutzernamen und Kennwörtern auf dem Server. Kleine Besserung, der Probierzyklus zum Programstart wurde etwas kürzer
Aber das ist ja keine Lösung.
Bitte warten ..
Mitglied: geTuemII
11.01.2007 um 23:39 Uhr
Ich erkläre dir jetzt mal den Hintergrund meiner Fragen. Wenn dein DHCP auf dem Router liegt, vergibt dieser die Adressen an alle Clients (und bis heute auch an den Server). Wenn in deinem Netz kein DNS-Server konfiguriert ist, der die Namensauflösung macht (also die Zuordnung der Rechnernamen zu den IP-Adressen und umgekehrt), benötigen die Clients sehr lange, um den Server zu finden, auf dem Lexware liegt.

Sie stehen quasi im Wald und rufen nach dem Guide, der die Karte hat, mit der sie die nächste Straße finden können. Dieser Guide ist dein DNS, den gibt es aber nicht in diesem Wald. Also müssen die Clients jeden verfügbaren Weg "ablaufen", um irgendwann zufällig auf die Straße zu treffen. Und das dauert....
So ähnlich geht es übrigens auch den Mitgliedern des "Fähnlein SQL-Schweif", die den SQL-Server.... aber lassen wir das.

Zurück zu deinem Problem: Ich kann mir vorstellen, daß es durch Timeouts und Problem des Netzwerks ausgelöst wird. Bekommst du denn irgendwelche Fehlermeldungén in den Ereignisprotokollen des Servers bzw. der Clients, evtl Time- und/oder Kerberos-Fehler? Ok, das hätte ich eingentlich schon fürher fragen können.

geTuemII
Bitte warten ..
Mitglied: geTuemII
13.01.2007 um 13:33 Uhr
Hallo,

da ist mir gerade noch was eingefallen:
Wenn du da experimentierst, kann es sein, daß dir der ARP-Chache dazwischenlangt. Also vor neuen Tests mal den ARP-Cach löschen.

arp -d *

geTuemII
Bitte warten ..
Mitglied: optimax
13.01.2007 um 16:07 Uhr
Danke nochmal für die Tips.
An den Server komme ich erst nächste Woche wieder dran. Habe in der Zwischenzeit andere Beiträge hier im Forum gelesen und denke malich komme nicht umhin den Domänencontroler, DNS Server und DHCP Server zu installieren.
Frage ist nur wenn ich das alles nachträglich installiere, ob die Lexwareinstallation incl. der Datenbank danach noch funktioniert. Oder kann da nichts passieren.
Vor allem muß ich bei der Installation etwas beachten, oder kann ich die Standardangaben so übernehmen?
Alternativ könnte ich den Server neu aufsetzen und die Software neu aufspielen und die Daten anschließend Rücksichern. Viel Arbeit aber eine Lösung muß her.
Bitte warten ..
Mitglied: geTuemII
13.01.2007 um 19:58 Uhr
Hallo,

falls du DNS und DHCP wirklich noch nicht installiert hast, kannst du die nachinstallieren (evtl. mußt du sie auch nur konfigurieren), und durch ein dcpromo wird der Server zum Dommaincontroller. Normalerweise ist das eher unproblematisch, aber ein funktionierendes Backup ist natürlich Pflicht. Da du offenbar keine weiteren Server hast und dein Netz sehr überschaubar ist, sollte sich die Installationsroutine von selbst erklären. Wichtig ist noch, daß in dem Netz nur ein DHCP läuft, der des Routers muß also abgeschaltet werden.

Viel Glück,
geTuemII
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (22)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...