Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
Kommentar vom Moderator Dani am 01.06.2009 um 17:51:24 Uhr
Bilder im Forum hochgeladen. Bitte in Zukunft diese Funktion nutzen...
GELÖST

Keine SQL Verbindung mehr möglich

Frage Microsoft Windows Server

Mitglied: thedot

thedot (Level 1) - Jetzt verbinden

31.05.2009, aktualisiert 01.06.2009, 5216 Aufrufe, 3 Kommentare

Nach dem Neustart kann ich mich nicht an meinen SQL verbinden

Hallo,

Zur Story:
ich weiß nicht was passiert ist. Alles lief wunderbar. Ich hatte heute auf 2 anderen Servern je den Applikationsserver(firmeninterne Software) installiert und dachte schon wenn ich die beiden neustarte, starte ich auch einfach den SQL Server neu. Nach dem Neustart, hatte ich aber plötzlich keine Verbindung mehr zum SQL Server. Ich gehe wieder drauf, dachte es reicht nur den Dienst zu starten. Also hab ich das auch gemacht. Unter SQL Dienst Manager ist der Pfeil auf grün - also müsste gehen, aber falsch gedacht.

Zum System:
Windows Server 2003 SP2
MS SQL 2000 SP4

Auf dem Server läuft wirklich so gut wie gar nichts außer dem SQL 2000. Es lief bis heute auch problemlos, weiß nicht warum das nun nach dem Neustart plötzlich nicht geht.

Der Benutzer ist ein Administrator mit allen Rechten die man sich nur vorstellen kann. SQL ist im gemischten Mode installiert. Kann mich aber auch nicht als sa anmelden.

Was ich schon versucht habe:

Ich habe bei MS nachgelesen, dass man auf die DB gehen kann und dann unter Eigenschaften den Mode so umstellen, dass beides wie Windows so auch SA funktionieren können aber wenn ich auf die DB im Enterprise Manager gehe, bekomme ich folgende Meldung:

c91e401da43a75d7cc3e3183f498a4f5-sqlw - Klicke auf das Bild, um es zu vergrößern

Wenn ich versuche mich mit sa anzumelden, diese hier:

a3349013590f1898cddbcd926eca07e0-sql1 - Klicke auf das Bild, um es zu vergrößern

Ich bin langsam echt verzweifelt und weiß gar nichht mehr weiter. Bin nur froh dass morgen Feiertag ist und ich da hoffentlich Zeit hab das ganze zu beheben. Hoffe auf eure Hilfe.

Kann ich den SQL neuinstallieren und wenn ja, wie soll ich vorher die DB sichern?

EDIT: Ist denn eine Neuinstallation von MS SQL 2000 ratsam? Würde dadurch die DB Schaden nehmen oder rührt die Installation die Datenbanken nicht an? Kann mir das einer beantworten?
Mitglied: thedot
01.06.2009 um 00:32 Uhr
Zu der Neuinstallation von SQL.

Ich habe eben auf einem Testserver probiert und SQL deinstalliert und neuinstalliert (gleiches Verzeichnis). Die DB behält er zwar nach der Installation im Verzeichnis, jedoch erkennt SQL nach der Neuinstallation die DB im Verzeichnis nicht an. Zumindest wird diese im Enterprise Manager nicht angezeigt.
Bitte warten ..
Mitglied: ilmo
01.06.2009 um 10:30 Uhr
Hallo,

hast Du mal unter Dienste geschaut ob der MSSQLSERVER läuft? Wenn nein, dann dort mal den Dienst starten. Wenn er dann nicht läuft in der Ereignisanzeige schauen, da sollte dann eine Fehlermeldung stehen.

Wenn er läuft (was ich nicht glaube), dann stimmt was mit dem Passwort nicht. Oder es sind mehrere Instanzen des SQL-Server installiert und Du versucht dich am falschen anzumelden.

Beim Testserver: einfach eine DB anlegen, den SQL-Dienst stoppen und mal die Dateien der neuen Datenbank löschen und die alte DB-Dateien so umbenennen, wie die neuen lauteten. Dann den SQL wieder starten und dann solltest Du darauf zugreifen können. Ist keine Musterlösung, aber so kannst DU schnell sehen ob die DBs noch korrekt sind.

Gruß Ilja
Bitte warten ..
Mitglied: thedot
01.06.2009 um 14:51 Uhr
Zitat von ilmo:
Hallo,

hast Du mal unter Dienste geschaut ob der MSSQLSERVER läuft?
Wenn nein, dann dort mal den Dienst starten. Wenn er dann nicht
läuft in der Ereignisanzeige schauen, da sollte dann eine
Fehlermeldung stehen.

Wenn er läuft (was ich nicht glaube), dann stimmt was mit dem
Passwort nicht. Oder es sind mehrere Instanzen des SQL-Server
installiert und Du versucht dich am falschen anzumelden.

Beim Testserver: einfach eine DB anlegen, den SQL-Dienst stoppen und
mal die Dateien der neuen Datenbank löschen und die alte
DB-Dateien so umbenennen, wie die neuen lauteten. Dann den SQL wieder
starten und dann solltest Du darauf zugreifen können. Ist keine
Musterlösung, aber so kannst DU schnell sehen ob die DBs noch
korrekt sind.

Hallo Ilja,

danke für Deine Rückmeldung. Ich habe heute Nacht auch eine Lösung gefunden, zwar keine Musterlösung aber die DB lief und die Kollegen freuten sich.

Ich hab den SQL einfach neuinstalliert und die LIVE DB über die Funktion anhängen, einfach ins System eingehängt. Nun funktioniert wieder alles. Weiß nicht was da war. Und MSSQL Server lief ebenfalls, hatte alles probiert, war dann irgendwann gegen 3 Uhr mit allem fertig.

Die Datenbank hängt man an in dem man den Enterpise Manager aufmacht dann im Konsolenstamm auf den Ordner Datenbanken geht, dann mit der Rechten Maustaste das Kontexmenü auswählt und Punkt "Datenbank anhängen" wählt.

http://img33.imageshack.us/img33/1818/unbenanntuvb.png
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (8)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...