Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Squeeze LVM Problem

Frage Linux Linux Netzwerk

Mitglied: Wild-Wolf

Wild-Wolf (Level 1) - Jetzt verbinden

22.09.2012 um 22:25 Uhr, 2891 Aufrufe, 2 Kommentare

Hallo,

ich habe da ein kleines Problem was mich bescheuert macht, zumal ich weiß das es schon einmal funktioniert hat.
Und zwar folgendes Szenario.

Debian Squeeze Server mit 900 GB HDD HW Raid 5
So folgendes soll erstellt werden.

200 MB Boot
100 GB Home
4 GB swap
Rest root

Habe wie folgt gemacht.

Linux bis zum Punkt der Festplattenpartitioierung installiert.
Dann Partitionierung -> Manuel

|-HDD
|--boot (seperat)
|--Rest (LVM) Physikalisches Volume für LVM

Als nächstes:
- Volume-Gruppe erstellen
- Logisches Volume erstellen

Als logische wurden in der LVM
|--root
|--home
|--swap
erstellt.

mein Problem ist das ich nun gerne das bekomme:
http://s14.directupload.net/images/120922/wggnzsbp.jpg

kann mir da wer helfen?
Mitglied: 16568
23.09.2012, aktualisiert um 00:05 Uhr
Zitat von Wild-Wolf:
...
Habe wie folgt gemacht.

Linux bis zum Punkt der Festplattenpartitioierung installiert.
Dann Partitionierung -> Manuel

|-HDD
|--boot (seperat)
|--Rest (LVM) Physikalisches Volume für LVM

Als nächstes:
- Volume-Gruppe erstellen
- Logisches Volume erstellen

Als logische wurden in der LVM
|--root
|--home
|--swap
erstellt.

Brrrrr, swap würde ich NIE in LVM schieben...
Wozu auch?
Die Swap-Partition wird während des Systemstarts zu einem frühen Zeitpunkt im Init-V-Prozess aktiviert. Zu diesem Zeitpunkt muss LVM bereits laufen.

Entweder, Du kannst abschätzen, wie viel Du swappen mußt, dann legst Du den Wert an, ansonsten Faustregel 2x RAM.
(wobei ich das eigentlich nie mache; wenn, dann eher RAM nachschieben...)


Lonesome Walker
Bitte warten ..
Mitglied: Lochkartenstanzer
23.09.2012, aktualisiert um 10:58 Uhr
Zitat von 16568:
Brrrrr, swap würde ich NIE in LVM schieben...

Würde ich auch nciht, aber der z.B. Ubuntu-Installer macht so einen quatsch, wenn man es ihm nicht ausredet.

Wozu auch?

Meist, weil man es nicht besser weiß.

Die Swap-Partition wird während des Systemstarts zu einem frühen Zeitpunkt im Init-V-Prozess aktiviert. Zu diesem
Zeitpunkt muss LVM bereits laufen.

und deswegen muß lvm ins initrd, ansonsten hat man verloren.

Entweder, Du kannst abschätzen, wie viel Du swappen mußt, dann legst Du den Wert an, ansonsten Faustregel 2x RAM.
(wobei ich das eigentlich nie mache; wenn, dann eher RAM nachschieben...)

Das mit den 2xRAM war sinnvoll als man nur wenige KB/MB RAM zur Verfügung hatte und dauernd an die Grenzen des Speichers gestoßen ist (Ich sach nur Eight Megabytes And Continously Swapping).

Heutzutage ist aber i.d.R. alles was über einen einstelligen GB-Bereich hinausgeht verschwendeter Plattenplatz, es sei denn, man braucht den, um den Computer schlafen zu schicken statt auszuschalten. Plattenplatz ist nie sinnvoller Ersatz für RAM.

Aber zum Problem des TO:

  • Check mal die initrd, ob alle benötigten Module drin sind.
  • Mach swap aus dem LVM raus
  • prüfe die UUIDs der Filesysteme/devices in der grub.cfg und in fstab.

lks
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...

Windows Netzwerk
gelöst Problem mit PSexec64 von Sysinternals (8)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...