Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Squid und Anonymous FTP-Login

Frage Linux

Mitglied: phat

phat (Level 1) - Jetzt verbinden

22.01.2006, aktualisiert 31.01.2006, 15050 Aufrufe, 4 Kommentare

Hi

So - nun zu meinem Problem.
Suse Linux 10 läuft bei mir als Router.
Über diesen gehe ich mit einem Win2000-Client ins Netz.
Squid-Proxy in der Version 2.5 stable10 läuft auf dem Router.

Das Problem besteht darin das Squid mir kein Login-Fenster im Browser am Client eröffnet wenn ich auf FTP-Server bei denen kein Anonymous-Login erlaubt ist zugreife. Ohne Squid bekomme ich das Login-Fenster.
Alles andere funktioniert einwandfrei.
Auch wenn ich mich auf den FTP mittels benutzername:passwort@ftpserver (als Adresse) einlogge klappt es.
Nur bekomme ich eben kein Login-Fenster wenn ich nur den FTP-Server (ohne name:pw) als Adresse eingebe.

Ohne Squid: Versuch FTP-UserAnonymous -> klappt nicht -> Login-Fenster
Mit Squid: Versuch FTP-UserAnonymous -> klappt nicht -> Fehlermehldung (wie folgt) -> KEIN Login-Fenster

Fehlermeldung im Browser:

Ein FTP-Berechtigungsfehlschlag ist aufgetreten während des Versuches, den URL: ftp://xxxxxxx zu laden.
Squid sendete den folgenden FTP-Befehl:
PASS <yourpassword>
und erhielt die Antwort:
Login or Password incorrect.

Die access.log vom Squid gibt folgendes preis:
1136419109.632 3590 192.168.x.x(client-ip) TCP_MISS/401 1406 GET ftp://(adresse)/ - DIRECT/x.x.x.x(ftp-ip) text/html

Meine squid.conf:
http_port 192.168.x.x:3133
icp_port 0
cache_mem 16 MB
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443
acl Safe_ports port 80
acl Safe_ports port 21
acl Safe_ports port 443
acl CONNECT method CONNECT
acl lokal_net src 192.168.x.0/24
acl url_ads url_regex "/etc/squid/banner-ads.acl"
deny_info NOTE_ADS_FILTERED url_ads
http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access deny url_ads
http_access allow localhost
http_access allow lokal_net
http_access deny all
http_reply_access allow all
icp_access deny all
forwarded_for off
log_icp_queries off
header_access Allow allow all
header_access Cookie allow all
header_access Set-Cookie allow all
header_access Authorization allow all
header_access WWW-Authenticate allow all
header_access Cache-Control allow all
header_access Content-Encoding allow all
header_access Content-Length allow all
header_access Content-Type allow all
header_access Date allow all
header_access Expires allow all
header_access Host allow all
header_access If-Modified-Since allow all
header_access Last-Modified allow all
header_access Location allow all
header_access Pragma allow all
header_access Accept allow all
header_access Accept-Charset allow all
header_access Accept-Encoding allow all
header_access Accept-Language allow all
header_access Content-Language allow all
header_access Mime-Version allow all
header_access Retry-After allow all
header_access Title allow all
header_access Connection allow all
header_access Proxy-Connection allow all
header_access All deny all
header_replace User-Agent blablub
error_directory /usr/share/squid/errors/German

Alle anderen Einstellungen in der squid.conf sind Default-Werte wie auch einige von den obigen.
Auch wenn alle Werte der squid.conf auf default sind (also z.B. die Anonymizer) besteht das Problem.

Ich hoffe Ihr könnt mir bei diesem etwas kniffligen Problem helfen weil ich da schon seit Tagen am probieren und suchen bin.

MfG Phat
Mitglied: bitmaster
29.01.2006 um 19:06 Uhr
Hi,

1. squid "übersetzt" http in ftp, er ist also kein echter ftp proxy
2. um auf nicht-anonyme ftp-Sites zuzugreifen,
kann man username/password in der url unterbringen:

http://user:password@ftp.ftpcompany.com

Viel Spass!
Ralf
Bitte warten ..
Mitglied: phat
30.01.2006 um 05:05 Uhr
Hi

Ja das es mit username:passwort in der Adresse funktioniert weiß ich doch.

Die Sache ist nur die, dass ein Bekannter von mir dieses Login-Fenster bekommt wenn er username:passwort NICHT in der Adresse angibt.
Ich habe schon mit seiner squid.conf verglichen und keine entscheidenden Unterschiede festgestellt.
Der einzige Unterschied ist: er verwendet squid 2.5 stable 6 und ich die 2.5 stable 10.
Ob es tatsächlich an der Version liegt?

MfG phat
Bitte warten ..
Mitglied: bitmaster
30.01.2006 um 15:59 Uhr
Ups, hat ich übersehen.

Ist das Verhalten im Konqueror/Firefox auf der SuSE-box identisch?
Bitte warten ..
Mitglied: phat
31.01.2006 um 13:09 Uhr
Das kann ich nicht testen da auf der Suse-Box kein Konqueror/Firefox installiert ist. Dort ist garkein X11 installiert. Zum Surfen wird einzig und allein der Client benutzt.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Powershell anonymous FTP Upload
gelöst Frage von MarabuntaBatch & Shell5 Kommentare

Hallo, ich will eine Datei hochladen, anonymous Zugriff ist auf der QNAP Nas aktiviert. Dann noch ein Skript gefunden ...

Ubuntu
Squid kein login cachemgr.cgi
Frage von ChontaUbuntu

Hallo, ich versuche gerade auf einem ubuntu 16.04 ein squid 3.5.12 zum laufen zu bekommen. Der Webbrowser ist nginx ...

Windows 8
Login problem 503 auf meinem ftp server
gelöst Frage von tobias3355Windows 84 Kommentare

hallo, ich habe unter windows 8 den ftp sowie den iis installiert und eine ftp-site eingerichtet. diese hab ich ...

Linux Netzwerk
Squid Fehlermeldung
gelöst Frage von AKillerInHellLinux Netzwerk5 Kommentare

Naben liebe Admins Habe folgendes Problem auf meiner CentOS VM mit Squid und Webmin. Es ist erstmal nur eine ...

Neue Wissensbeiträge
Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 3 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 4 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 16 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 22 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement17 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...