Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SSH und WebMin extrem langsam

Frage Linux Linux Tools

Mitglied: g-tech

g-tech (Level 1) - Jetzt verbinden

12.06.2007, aktualisiert 19.06.2007, 6583 Aufrufe, 7 Kommentare

Server ist ein:
Suse 10.1
AMD Athlon 64 3700+
1 GB DDR400 RAM
von Hetzner

auf dem lediglich ein LAMP-Stack plus Postfix & FTP am laufen sind.

Hallo zusammen,

habe seit einigen Wochen massive Geschwindigkeitseinbrüche im SSH-, bzw. Webminzugriff auf meinen Server.

Genauergesagt:

SSH:
Funktioniert soweit, allerdings braucht mein Server nach Eingabe von Benutzername und Passwort gute 20-30 sek., bis ich angemeldet bin. Das war zuvor eine Sache von ein paar Sekunden.

WebMin:
Lief anfänglich super schnell, hat mittlerweile auch Ladezeiten von bis zu 30 sek. oder noch länger

Alle anderen Dienste:
Apache, mySQL, Postfix, etc laufen einwandfrei (schnell) Webseiten werden ohne größere Verzögerungen ausgeliefert.


Der Server dient im Moment als einfache Webserver, sprich LAMP-Stack + Postfix und ist wenn ich uptime aufrufe im Schnitt mit allen drei Angaben unter 0,2.

"Top" zeigt mir auch nahezu immer 99% idle an.


Kann mir einer von euch sagen, warum der Server bei SSH und WebMin derart in die Knie geht???

Vielen Dank im vorraus
Mitglied: spacyfreak
12.06.2007 um 20:44 Uhr
Gehackt?

Was sagt

tail -200 /var/log/messages

Vor allem - wer hat sich eingeloggt, bzw. versucht sich einzuloggen?

Sniff mal den Traffic

tcpdump -i eth0 -vvv > tcpdump$date.txt

more tcpdump$date.txt


Wahrscheinlich wird dein Server längst als Spamschleuder, Scanner oder Fileserver "missbraucht".
Bitte warten ..
Mitglied: g-tech
12.06.2007 um 21:00 Uhr
jain, habe vorhin eine Liste meiner Prozesse mit

"ps -ef | more > file"

erstellt - kannst Dir gerne anschaun unter:
"http://www.g-dev.de/tmp/ps.txt"

sieht aber eigentlich recht normal aus.

was ich viel habe, sind Loginversuche via SSH, allerdings soweit ich es bisher ersehen konnte ohne Erfolg.

hier ein Auszug aus:
"tail -n 500 -f /var/log/messages | grep ssh > /srv/www/htdocs/tail.txt"

Die ersten beiden Zeilen hab ich zu hunderten, deshalb habe ich jetzt den SSH-Port geändert.

Jun 12 09:24:54 suse101lamp sshd[28717]: Address 88.248.240.14 maps to e-webtr.com, but this does not map back to the address - POSSIBLE BREAKIN ATTEMPT!
Jun 12 09:24:56 suse101lamp sshd[28719]: Address 88.248.240.14 maps to e-webtr.com, but this does not map back to the address - POSSIBLE BREAKIN ATTEMPT!
sshd[29382]: Did not receive identification string from 69.15.220.37
Jun 12 18:06:55 suse101lamp sshd[29721]: Accepted keyboard-interactive/pam for binda from 84.156.176.123 port 46824 ssh2
Jun 12 18:11:15 suse101lamp sshd[29796]: Accepted keyboard-interactive/pam for binda from 84.156.176.123 port 42801 ssh2
Jun 12 19:43:36 suse101lamp sshd[30388]: Accepted keyboard-interactive/pam for binda from 84.156.147.187 port 35075 ssh2
Bitte warten ..
Mitglied: spacyfreak
12.06.2007 um 21:16 Uhr
SSHd Port ändern ist schonmal keine schlechte Idee.
Weiterhin könntest Du direkten root login per ssh verbieten, oder nur Authentisierung per ssh key erlauben, das ist wohl das sicherste.

Im ps File seh ich auch nix was mir aufstossen würde, bin aber auch kein Crack in dem Bereich.

Mal den Server neugestartet spasshalber?

tcpdump probiert was so im netz los ist?
Bitte warten ..
Mitglied: g-tech
12.06.2007 um 21:22 Uhr
Direktes SSH-Login für root ist auch schon abgedreht...

Server hab ich vorhin "spasshalber" neugestartet, ist allerdings genauso langsam wie davor...

tcpdump hab ich grade mal angeworfen, soweit ich es erkennen kann auch nichts wirklich dramatisches enthalten...

http://www.g-dev.de/tmp/tcp_dump.txt

Falls Du es Dir noch kurz ansehn magst...
Bitte warten ..
Mitglied: spacyfreak
12.06.2007 um 21:38 Uhr
Ok, da seh ich auch nix was ins Auge sticht.

Mal die Logfiles der Datenbank und der anderen Dienste angeschaut, unter /var/log/apache2 oder so ähnlich glaub ich usw?

Hast du mal probiert, mit nem anderen Client zuzugreifen? Vielleicht liegts ja nichtmal am Serv er...
Bitte warten ..
Mitglied: g-tech
12.06.2007 um 21:50 Uhr
ne, außer so wie es aussieht etliche aufgrund von reverse-dns (o.ä.) abgeblockten email, und ein paar Einträgen, dass meine mailtables nicht ganz aktuell sind auch nichts weiter auffälliges...

mysql findet ein paar Tabellen nicht mehr, was aber auch nichts machen sollte, da diese Datenbanken im Moment nicht mehr benutzt werden...


sch*** technik...
Bitte warten ..
Mitglied: freesmurf
19.06.2007 um 15:54 Uhr
Hallochen

Hab genau das selbe Problem, lustigerweise auch auf einem Hetzner Server. Und auch das Gefühl, nicht gehackt zu werden, auf Apache kein riesen Traffic, genau wie von meinem Vorgänger beschrieben...
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Vmware
gelöst Server 2008 R2 in VMware (ESX-Farm) extrem langsam (10)

Frage von YotYot zum Thema Vmware ...

Windows Update
gelöst WSUS-Downloads im LAN extrem langsam seit Win-10-Anniversary-Update 1607 (1)

Frage von departure69 zum Thema Windows Update ...

Hyper-V
gelöst Win Server 2012 und Hyper V gleich Netzwerk extrem langsam (20)

Frage von Edaseins zum Thema Hyper-V ...

Windows 10
FTP ist extrem langsam (3)

Frage von grka zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...