Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ssl einbindung

Frage Entwicklung

Mitglied: ACI-Piewo

ACI-Piewo (Level 1) - Jetzt verbinden

10.05.2010 um 15:36 Uhr, 2060 Aufrufe

Hallo bin neu hier habe aber genau das gleiche Problem

Hallo lieber Forum

Ich genau das gleiche Problem seit dem ich ein SSl Zertifkat benutze kann ich mich nicht mehr in meinen Adminbereich einloggen. (Oscommerce 2.2) Die Frage von Simon sei anscheinend schon im Forum gelöst worden Leider finde ich hier keine Dokumentation im Forum. Kann mir jemand den Pfad zur Erklärung geben, oder vielleicht mir einen Tipp geben, wie ich mein Problem lösen kann.

Vielen Dank




Hallo lieber Forum,

ich habe meinen Shop soweit fertiggestellt. Läuft alles super und durchsteigen tue ich eigentlich auch. Zum Schluss ist mir das mit SSL noch eingefallen, was ich total vergessen hatte. Ich habe dann erstmal, da ich bei 1&1 Kunde bin, mein GoTrust Zertifikat für die Shopdomain beantragt und bestätigt bekommen. Jetzt wollte ich das alles einrichten und habe mich durchs Forum gelesen. Doch erstens ruft er die SSL Verbindung gar nicht auf wenn ich z.B. in den Kundenbereich gehe. Erst wenn ich selber https://... eingebe dann tut er das aber ohne mir ein Schloss im IE7 anzuzeigen. Zudem fragt er mich ob ich unsichere Elemente anzeigen möchte, wenn ich dort auf Nein klicke macht er die komplette Seite ohne Bilder, ohne Textformatierung, sogar das Trust Zertifikat wird nicht angezeigt. Kennt sich vieleicht einer mit dem GoTrust Zertifikat aus und kann mir evtl. sagen wie ich das einrichten muss. Im Forum von OScommerce finde ich leider kein Thread darüber. Vieleicht habe ich auch ein generelles Problem.
Ich habe im OS Shop lediglich die beiden Configure.php im Code:

define('ENABLE_SSL', true);

auf "true" gesetzt und nach Angaben von 1&1 da das nicht funktioniert hatte, im Root Verzeichnis meiner HP die .htaccess den Code

RewriteEngine On RewriteCond %{SERVER_PORT} !=443 RewriteRule ^(.*)$ https://ihre-webhosting-domain.de/$1 [R=301,L]

eingefügt. Ist das überhaupt ausreichend? (ihre-webhosting-domain.de - habe ich natürlich in meine Domain abgewandelt!)

Bitte um Hilfe.

Mit besten dank und freundlichen Grüßen
Simon
Neuester Wissensbeitrag
Ähnliche Inhalte
Exchange Server
gelöst Exchange 2016 nach Einbindung SSL Zertifikat funktioniert AutoDiscover nicht mehr (3)

Frage von DKowalke zum Thema Exchange Server ...

Ubuntu
SSL Zertifikat für Webmin (2)

Frage von ClepToManix zum Thema Ubuntu ...

Sonstige Systeme
SSL -Zertifikate für interne Webdienste (3)

Frage von JoHeAnDr zum Thema Sonstige Systeme ...

Heiß diskutierte Inhalte
Viren und Trojaner
gelöst Wie werde ich den Mist "fanli90" wieder los? (18)

Frage von Taumel zum Thema Viren und Trojaner ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (17)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Grafikkarten & Monitore
Neue Graifkkarte - kein Bild (10)

Frage von bestelitt zum Thema Grafikkarten & Monitore ...