Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Sssd liefert Fehlermeldung -- ldapsearch funktioniert

Frage Linux Linux Userverwaltung

Mitglied: LLIILLAA

LLIILLAA (Level 1) - Jetzt verbinden

13.08.2013 um 11:10 Uhr, 2234 Aufrufe

Hallo Forum,

vielleicht hat jemand eine Idee, wie ich folgendes Problem lösen könnte:

  • ldapsearch -x funktioniert
  • getent liefert kein Ergebnis
  • folgende Fehlermeldung unter: /var/log/sssd/sssd_LDAP.log
01.
... 
02.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [sdap_id_op_connect_step] (0x4000): beginning to connect 
03.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [fo_resolve_service_send] (0x0100): Trying to resolve service 'LDAP' 
04.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [get_server_status] (0x1000): Status of server '[server]' is 'name resolved' 
05.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [get_port_status] (0x1000): Port status of port [port] for server '[server]' is 'not working' 
06.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [get_port_status] (0x0100): Reseting the status of port [port] for server '[server]' 
07.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [fo_resolve_service_activate_timeout] (0x2000): Resolve timeout set to 10 seconds 
08.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [get_server_status] (0x1000): Status of server '[server]' is 'name resolved' 
09.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [be_resolve_server_process] (0x1000): Saving the first resolved server 
10.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [be_resolve_server_process] (0x0200): Found address for server [server]: [x.x.x.x] TTL 172800 
11.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [sss_ldap_init_send] (0x4000): Using file descriptor [20] for LDAP connection. 
12.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [sdap_async_sys_connect_send] (0x0020): connect failed [13][Keine Berechtigung]. 
13.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [sss_ldap_init_send] (0x0400): Setting 6 seconds timeout for connecting 
14.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [sss_ldap_init_sys_connect_done] (0x0020): sdap_async_sys_connect request failed. 
15.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [sdap_sys_connect_done] (0x0020): sdap_async_connect_call request failed. 
16.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [sdap_handle_release] (0x2000): Trace: sh[0x79b550], connected[0], ops[(nil)], ldap[(nil)], destructor_lock[0], release_memory[0] 
17.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [fo_set_port_status] (0x0100): Marking port [port] of server '[server]' as 'not working' 
18.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [fo_resolve_service_send] (0x0100): Trying to resolve service 'LDAP' 
19.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [get_server_status] (0x1000): Status of server '[server]' is 'name resolved' 
20.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [get_port_status] (0x1000): Port status of port [port] for server '[server]' is 'not working' 
21.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [fo_resolve_service_send] (0x0020): No available servers for service 'LDAP' 
22.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [be_resolve_server_done] (0x1000): Server resolution failed: 5 
23.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [sdap_id_op_connect_done] (0x0020): Failed to connect, going offline (5 [Eingabe-/Ausgabefehler]) 
24.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [be_mark_offline] (0x2000): Going offline! 
25.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [be_run_offline_cb] (0x0080): Going offline. Running callbacks. 
26.
(Mon Aug 12 10:28:22 2013) [sssd[be[LDAP]]] [sdap_id_op_connect_done] (0x4000): notify offline to op #1 
27.
...
  • authconfig --test
01.
caching is disabled 
02.
nss_files is always enabled 
03.
nss_compat is disabled 
04.
nss_db is disabled 
05.
nss_hesiod is disabled 
06.
 hesiod LHS = "" 
07.
 hesiod RHS = "" 
08.
nss_ldap is disabled 
09.
 LDAP+TLS is enabled 
10.
 LDAP server = "ldap://[server]:[port]/" 
11.
 LDAP base DN = "dc=xx,dc=de" 
12.
nss_nis is disabled 
13.
 NIS server = "" 
14.
 NIS domain = "" 
15.
nss_nisplus is disabled 
16.
nss_winbind is disabled 
17.
 SMB workgroup = "" 
18.
 SMB servers = "" 
19.
 SMB security = "user" 
20.
 SMB realm = "" 
21.
 Winbind template shell = "/bin/false" 
22.
 SMB idmap range = "16777216-33554431" 
23.
nss_sss is enabled by default 
24.
nss_wins is disabled 
25.
nss_mdns4_minimal is disabled 
26.
DNS preference over NSS or WINS is disabled 
27.
pam_unix is always enabled 
28.
 shadow passwords are enabled 
29.
 password hashing algorithm is sha512 
30.
pam_krb5 is disabled 
31.
 krb5 realm = "EXAMPLE.COM" 
32.
 krb5 realm via dns is disabled 
33.
 krb5 kdc = "kerberos.example.com" 
34.
 krb5 kdc via dns is disabled 
35.
 krb5 admin server = "[server]" 
36.
pam_ldap is disabled 
37.
 LDAP+TLS is enabled 
38.
 LDAP server = "ldap://[server]:[port]/" 
39.
 LDAP base DN = "dc=xx,dc=de" 
40.
 LDAP schema = "rfc2307" 
41.
pam_pkcs11 is disabled 
42.
 use only smartcard for login is disabled 
43.
 smartcard module = "" 
44.
 smartcard removal action = "" 
45.
pam_fprintd is disabled 
46.
pam_winbind is disabled 
47.
 SMB workgroup = "" 
48.
 SMB servers = "" 
49.
 SMB security = "user" 
50.
 SMB realm = "" 
51.
pam_sss is enabled by default 
52.
 credential caching in SSSD is enabled 
53.
 SSSD use instead of legacy services if possible is enabled 
54.
IPAv2 is disabled 
55.
IPAv2 domain was not joined 
56.
 IPAv2 server = "" 
57.
 IPAv2 realm = "" 
58.
 IPAv2 domain = "" 
59.
pam_cracklib is enabled (try_first_pass retry=3 type=) 
60.
pam_passwdqc is disabled () 
61.
pam_access is enabled () 
62.
pam_mkhomedir or pam_oddjob_mkhomedir is enabled () 
63.
Always authorize local users is enabled () 
64.
Authenticate system accounts against network services is disabled
  • sssd.conf
01.
[domain/default] 
02.
ldap_id_use_start_tls = True 
03.
enumerate = True 
04.
cache_credentials = True 
05.
ldap_search_base = dc=xx,dc=de 
06.
krb5_realm = EXAMPLE.COM 
07.
krb5_server = kerberos.example.com 
08.
id_provider = ldap 
09.
auth_provider = ldap 
10.
chpass_provider = ldap 
11.
ldap_uri = ldap://[server]:[port]/ 
12.
ldap_tls_cacertdir = /etc/openldap/certs 
13.
ldap_tls_reqcert = never 
14.
 
15.
[domain/LDAP] 
16.
enumerate = true 
17.
cache_credentials = true 
18.
id_provider = ldap 
19.
auth_provider = ldap 
20.
chpass_provider = ldap 
21.
ldap_uri = ldap://[server]:[port]/ 
22.
ldap_search_base = dc=xx,dc=de 
23.
ldap_id_use_start_tls = true 
24.
ldap_tls_cacertdir = /etc/openldap/certs 
25.
ldap_tls_reqcert = never 
26.
debug_level = 9 
27.
 
28.
[sssd] 
29.
config_file_version = 2 
30.
reconnection_retries = 3 
31.
sbus_timeout = 30 
32.
services = nss, pam 
33.
domains = LDAP 
34.
 
35.
[nss] 
36.
filter_groups = root 
37.
filter_users = root 
38.
reconnection_retries = 3 
39.
entry_cache_timeout = 300 
40.
entry_cache_nowait_percentage = 75 
41.
 
42.
[pam] 
43.
reconnection_retries = 3 
44.
offline_credentials_expiration = 2 
45.
offline_failed_login_attempts = 5 
46.
offline_failed_login_delay = 5 
47.
 
48.
[sudo] 
49.
 
50.
[autofs]
Ähnliche Inhalte
PHP
PHP Script Interpreter als Plugin liefert keine vernünftigen Fehlermeldungen
Frage von AndroxinPHP

Hallo zusammen, ich sitze gerade etwas ratlos vor meinem FileMaker und habe ein Problem mit der Verwendung von PHP ...

Microsoft Office
DateDiff liefert unteschiedliche Werte
gelöst Frage von GundelputzMicrosoft Office3 Kommentare

Hallo alle zusammen, habe hier ein merkwürdiges verhalten von Excel 2010 VBA Ich möchte die differenz von zwei Datumswerten ...

Entwicklung
Powershell liefert -1 zurück
Frage von H41mSh1C0REntwicklung2 Kommentare

Hi@All, um die RSAT auf den Windows 8.1 Clients auszurollen wird im verteilten Paket folgender PS Befehl abgesetzt. Die ...

Windows Server
Zertifikat funktioniert mit Internet Explorer bei Firefox und anderen kommt Fehlermeldung
gelöst Frage von 116480Windows Server6 Kommentare

Hallo, ich habe aus einem *.pfx File 3 Exporte gemacht Export the private key file from the pfx file ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 21 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...