Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

start (wait) mit leerzeichen in dateiname und parameter

Frage Entwicklung Batch & Shell

Mitglied: halo7one

halo7one (Level 1) - Jetzt verbinden

09.08.2008, aktualisiert 15:04 Uhr, 14648 Aufrufe, 3 Kommentare

Problem mit dem Aufruf einer Datei per start (/wait) und Leerzeichen sowohl in Dateiname, als auch in einem Parameter:

Hi @ all,

ich habe folgendes feststellen müssen:

Wenn ich eine Datei unter oben genannten Umständen öffnen will, dann gibt es Probleme mit den Leerzeichen im Pfad (die Leerzeichen werden außer Kraft gesetzt bzw. falsch interpretiert!?):
01.
:: Dies geht nicht (es wird nur "C:\irgend" als Pfad erkannt) :: 
02.
start /wait "" "C:\irgend was\teste etwas.bat" param1 "param2 param2" 
03.
 
04.
:: Wenn der Dateiname allerdings keine Leerzeichen enthält (ich brauche keine " ) oder ich kein start benutze geht es :: 
05.
start /wait C:\irgendwas\test.bat param1 "param2 param2" 
06.
 
07.
"C:\irgend was\teste etwas.bat" param1 "param2 param2"
Da ich auf das Ende des Programms warten will, muss ich start benutzen, weshalb die 2. funktionierende Methode nicht in Frage kommt.

Kann mir jemand sagen, was denn genau falsch interpretiert wird, also warum nur "C:\irgend" als Pfad erkannt wird bzw. die Anführungszeichen des Pfads "außer Kraft gesetzt werden"?

Ich kenne zwar die 8.3-Namen (C:\irgen~1\teste~1.bat), doch ich würde diese Lösung nur ungern in betracht ziehen. Gibt es nicht noch eine andere Methode?

Ich hoffe euch fällt was ein ;)

halo7one
Mitglied: bastla
09.08.2008 um 11:47 Uhr
Hallo halo7one!

Auf die Schnelle hätte ich diesen Workaround anzubieten:
01.
start /wait "" /D"C:\irgend was" "teste etwas.bat" param1 "param2 param2"
[Edit] Gegen den Nebeneffekt, dass der Schalter "/D" einem "cd /d" entspricht, fiele mir allerdings nur ein, das aktuelle Verzeichnis (falls überhaupt im aufgerufenen Batch benötigt) als weiteren Parameter "%cd%" zu übergeben ... [/Edit]

Grüße
bastla
Bitte warten ..
Mitglied: miniversum
09.08.2008 um 14:21 Uhr
Mir würden noch folgende Möglichkeiten einfallen die Du ausprobieren könntest:
01.
start /wait "" C:\"irgend was\teste etwas".bat param1 "param2 param2"
01.
start /wait "" C:\"irgend was"\"teste etwas".bat param1 "param2 param2"
Bitte warten ..
Mitglied: halo7one
09.08.2008 um 15:04 Uhr
Danke euch beiden!

@bastla: deine Version funktioniert wunderbar (den schalter /d kannte ich noch nicht bei start ;)
Vielen Dank für die schnelle Lösung!

@miniversum: die Anführungszeichen im Pfad anders zu setzten zeigt leider keine Wirkung, was ich auch schon ausprobiert hatte. Trotzdem thx.

Und wieder ein Problem gelöst
Die Lösung ist bastlas Version!

MfG,
halo7one
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Outlook 2010 - Exchange Konto Passwortabfrag beim Start (1)

Frage von survial555 zum Thema Microsoft Office ...

Windows 7
gelöst Unter Windows 7 kein Start von Skype 7.33.0.104 (4)

Frage von Orko2010 zum Thema Windows 7 ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (35)

Frage von FA-jka zum Thema Windows 10 ...

LAN, WAN, Wireless
Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

CMS
Lokales Wordpress im LAN - wie aufsetzen? (13)

Frage von Static zum Thema CMS ...

Backup
Backup Wochen- Monats- Jahressicherung (13)

Frage von Meterpeter zum Thema Backup ...