Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Startskript läuft nicht innerhalb einer Batch

Frage Microsoft Windows Server

Mitglied: jimmyone

jimmyone (Level 1) - Jetzt verbinden

07.08.2008, aktualisiert 17:41 Uhr, 3451 Aufrufe, 2 Kommentare

Hallo zusammen,

ich habe gerade etwas Ärger mit einem Startskript.
Und zwar wird die über unsere Softwareverteilung (ADS) eine Software auf Rechner installiert. Um den Licensekey nicht manuell eingeben müssen habe ich ein .reg Script geschriben, welches unter Local_Machine in der Registry den entsprechenden Eintrag vornehmen soll...

Um aber nicht immer die Meldung zu haben, klicken Sie auf Ja zum hinzufügen habe ich eine Batch dazu gelegt, welche nach dem Muster: Regedit /s datei.reg fungiert.

Dummerweise klappt das aber nicht... Sprich das Batch wird nicht angewendet. Der Eintrag wird der Registry nicht hinzugefügt.
Lasse ich das Batch weg und setze nur den Eintrag für das .reg wird zwar vor der Benutzeranmeldung, die Meldung, ob ich die Infos zur Registry hinzufügen will eingeblendet, klicke ich aber da auf Ja dann sind die Infos in der Registry.

Warum geht denn das mit dem Batch nicht?

Danke für die Hilfe.

Viele Grüße
Jimmy
Mitglied: 60730
07.08.2008 um 16:37 Uhr
Servus,


Warum geht denn das mit dem Batch nicht?
komplizierte Frage, die sich durch ein weglassen des Parameters /s erklären würde.
Passt das Batch, kommt das Popup - passt es nicht - kommt ein weiteres, daß die .reg nicht gefunden wurde.

Wahrscheinlich passt es besser, wenn du regedit /s meinlaufwerk\mein Pfad\meinswimmingpool.reg schreibst...
Try it

Gruß
Bitte warten ..
Mitglied: jimmyone
07.08.2008 um 17:41 Uhr
Hi...

Joo bedankt.
Hattest recht mit dem UNC Pfad.

Und ich dachte, es wär egal, wenn das File im selben Ordner liegt.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Batch Skript läuft merkwürdig.
Frage von pixel0815Batch & Shell15 Kommentare

Hallo zusammen, ich habe ein komisches Phänomen. Dieses unten stehende Skript läuft in einer Citrix Umgebung Dies dient dazu ...

Batch & Shell
Batch läuft nicht so rund
gelöst Frage von pixel0815Batch & Shell5 Kommentare

Hallo liebe Gemeinde, vielleicht weiß einer Rat warum der Befehl nicht ausgeführt wird? :O) Ausgabe Gruß Heiko

Batch & Shell
Homelaufwerke im Startskript zuweisen
Frage von SirTomBatch & Shell3 Kommentare

Hallo, ich möchte gerne die Homelaufwerke in einem Startskript (vbs, Windowsumgebung) zuweisen. Momentran sieht das so aus (nur Teile ...

Windows Server
Problem mit Startskript via Gruppenrichtlinie
gelöst Frage von ofodagWindows Server13 Kommentare

Hallo zusammen, also so langsam weiß ich nicht weiter. Folgende Umgebung, Windows Server 2012 R2 und Windows 7/10 Clients. ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 13 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 18 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 19 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Windows XP
Windows XP Aktivieren geht nicht
Frage von tetikmiroWindows XP13 Kommentare

Hallo Ich habe einen Windows XP mit einen vCenter Converter umgezogen auf eine ESXI. Soweit funktioniert dies auch ohne ...

Blogs
Immer wiederkehrende PHP Fehlermeldung bei Wordpress UTF-8 - ASCII
gelöst Frage von vcdweltBlogs11 Kommentare

Hi, seit einiger Zeit wird mein error_log meines Wordpress Blogs mit immer der gleichen Fehlermeldung überschwemmt. 14-Dec-2017 08:18:05 UTC ...

Switche und Hubs
Redundante L2 LWL Leitung über 2 Standorte - Spanning Tree - HP Equipment
gelöst Frage von ResolvSwitche und Hubs10 Kommentare

Hallo, ich stehe vor der Herausforderung eine Redundante L2 LWL Leitung über 2 Standorte herzustellen. Grundsätzliches Switching Know How ...