Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Statische Route zwischen Modem und Router

Frage Netzwerke Netzwerkmanagement

Mitglied: Alex1500

Alex1500 (Level 1) - Jetzt verbinden

14.06.2014, aktualisiert 15.06.2014, 3901 Aufrufe, 11 Kommentare, 1 Danke

Hallo erstmal,

Meine Überschrift hört sich ja ganz einfach zu beantworten aus, aber ist in meinem Fall nicht ganz so leicht. Zumindest ist meine Logik am Ende.

Also Ich habe einen Linksys X3000 Modem Router der sich mit dem Internet verbindet. Dieser soll einfach als "dummes" Modem alles zu meinem Netgear R7000 weiterleiten. Das funktioniert ja auch alles im "normalen" Betrieb. Aber ich benutze auf meinem Netgear Router per OPN-VPN Client einen anonymen VPN Service. Sprich ab dem Netgear ist mein Netz ausschließlich über VPN. Dies funktioniert auch, aber nicht so wie es soll. Sprich durch Konflikte mit dem Routing des Modems stürtzt das Netz von Zeit zu Zeit (bei aktivierten VPN; ohne VPN nicht) immer wieder ab. Ich zerbreche mir daher den Kopf wie ich das Modem "dumm" bekomme ohne das Netz bei dem Netgear zu verlieren... Denn wenn ich DHCP, NAT, Dynamic-Routing deaktiviere und eine statische Route einrichte, kann ich zwar vom Router auf das Modem zugreifen, aber das Netz ist weg. Irgendwo habe ich einen Logikfehler in meinem Netzaufbau, daher hoffe ich, dass ihr den mit mir finden könntet. Also kurz detailiert das ganze und was ich gemacht habe:

Also Ausgangssituation: Cisco: 192.168.1.1 (alles an; sprich nicht "dumm")
Netgear: 192.168.2.1 (Gateway Modus; VPN-Verbindung)


Was ich versucht habe:

Cisco NAT, DYN, DHCP deaktiviert und statische Route eingerichtet. 1b4b6f3a0420554b0d5f88a7d3e8b660 - Klicke auf das Bild, um es zu vergrößern
(NAT war natürlich deaktiviert nur Beispiel Foto)
Netgear Internetaufbau auf statisch gesetzt und eingerichtet. f01ac06d114ce813a7f870ba7efdf1f6 - Klicke auf das Bild, um es zu vergrößern


So habe ich zwar zugriff auf das Modem, aber nicht auf das Internet. Mir ist klar das ich irgendwas falsch mache, doch langsam gehen mir die Ideen aus.

Danke für jede Hilfe,
Alex

Mitglied: Dobby
14.06.2014, aktualisiert um 14:11 Uhr
Hallo,

lass den ersten Router mit dem Modem im so genannten "Bridged Modus" laufen,
also nur als reines Modem agieren und gut ist es.

Ansonsten hast Du eine Routerkaskade und auch zwei mal NAT hintereinander!
Und da kommt dann Dein OpenVPN nicht durch.

Gruß
Dobby
Bitte warten ..
Mitglied: aqui
14.06.2014, aktualisiert um 14:15 Uhr
Dieses Tutorial sollte alle deine Fragen beantworten:

http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...

Lies dir besonders die Punkte zum Thema NAT (IP Adress Translation) durch !
Das ist vermutlich genau dein Thema ?!

Hilfreich dazu auch:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...

Thema: "OpenVPN hinter einm NAT Router" denn das behandelt dein (NAT) Szenario !
Bitte warten ..
Mitglied: Alex1500
14.06.2014 um 14:17 Uhr
Also sprich welcher Modus hier? e16110388c5f9499de9232cdcc519013 - Klicke auf das Bild, um es zu vergrößern

Überbrückungsmodus oder Weiterleitung?
Bitte warten ..
Mitglied: aqui
14.06.2014 um 14:31 Uhr
Lies dir bitte dises Tutorial durch:
http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ... --> Alternative 2
Das beantwortet alle Fragen !!

Nur soviel:
PPPoE --> Enkapsulierung zum DSL Provider
Am kaskadierten Router also der netGear Gurke muss dann "Static" eingestellt sein oder "DHCP".
Static mit einer statischen IP Adresse ist hier zu bevorzugen wenn du Port Forwarding machen musst wenn man dieses beim NetGear nicht abschalten kann !
Bitte warten ..
Mitglied: Alex1500
14.06.2014, aktualisiert um 15:32 Uhr
Das ganze bringt mich leider nur bedingt weiter, da ich immer noch nicht weiß, was ich wo machen soll. Zum ersten einmal habe ich PPPoA und nicht PPPoE wodurch ich eben nicht weiß, wie ich Methode 1 verwenden kann, was ich viel lieber möchte, da ja alles über den internen Router läuft. Stelle ich eine statische Route für den internen auf ist das Netz weg. Daher kann ich auch den DHCP nicht deaktivieren, da ich ohne DHCP kein Netz bekomme. Daher komme ich nicht weiter da ich nirgends einen Lichtblick habe und auch nicht sehe wenn ich etwas richtig mache. Fakt ist ohne Veränderungen in den Einstellungen funktiniert das VPN trotz beiden NAT. Doch stürtzt das ganze gerne mal ab. Es läuft immer alles über VPN doch eben nicht ganz stabil was der Grund ist, dass ich die Konflikte eliminieren möchte, doch an dem WIE scheitere.
Bitte warten ..
Mitglied: orcape
14.06.2014 um 16:56 Uhr
Hi,
ich eben nicht weiß, wie ich Methode 1 verwenden kann
Wenn Dein Linksys die Einwahldaten für Deinen Provider hat, PPPoA, arbeitet er als Router.
Für die Funktion als Modem solltest Du im Linksys PPPoE-Passthrough aktivieren.
Dann musst Du aber im Netgear die Einwahldaten eingeben.
Unabhängig davon, sollte der VPN-Tunnel auch über 2x NAT problemlos laufen.
Bei Deinen Problemen tippe ich mal eher auf einer Instabilität des Netgear-Routers, die für Stabilität ja nicht gerade bekannt sind.
Gruß orcape
Bitte warten ..
Mitglied: Alex1500
14.06.2014, aktualisiert um 18:23 Uhr
Nein der Netgear funktioniert toll. ;) Ich habe mir extra nach langer Suche den R7000 gekauft, da er von der Hardware her keine Wünsche mehr offen hält, ebenfalls läuft er mit DD-WRT perfekt. Früher hatte ích einen einfachen wrt54gl benutzt der aber mit dem VPN gar nicht zu recht kam (Speed etc.), aber das Problem mit dem abstürzen haben beide. Da bei mir das mit dem Open-VPN Client settings nicht ganz funktioniert, benutze ich ein Startup Setting http://pastebin.com/3PqWEGuc . Eine Funktion PPPoE-Passthrough kann ich jetzt beim Cisco nicht finden. (siehe Bild oben)


Ps: Unter Absturz verstehe ich kein Internet, betrifft nicht das lokale Netz. Sprich habe ich die Möglichkeit eine Funktion zu erstellen die mir die VPN Verbindung überprüft und gegebenfalls neustartet?


Edit: Habe jetzt einmal beim Netgear KeepAlive auf die Google Standard Ip 8.8.8.8 gesetzt. Also sollte es rein theoretisch neustarten wenn die Verbindung abbricht.
Bitte warten ..
Mitglied: orcape
15.06.2014 um 11:57 Uhr
Hi,
Eine Funktion PPPoE-Passthrough kann ich jetzt beim Cisco nicht finden. (siehe Bild oben)
http://screenshots.portforward.com/routers/Cisco/Linksys_X3000/VPN_Pass ...
Bridged Modus in Verbindung mit PPPoE-Passthrough solltest Du mal testen...
Gruß orcape
Bitte warten ..
Mitglied: aqui
LÖSUNG 15.06.2014, aktualisiert um 14:05 Uhr
Im Grunde sind deine statischen Einstellungen oben aus dem NetGear WAN Port Screenshot schon alle richtig mit einem fatalen Fehler allerdings !
Du hast keinen DNS Server eingestellt und damit ist für die Clients dort eine Namensauflösung unmöglich !

Richtig ist also wenn du dort die folgenden Adressen einträgst:
WAN Modus: Static
WAN IP Adresse: 192.168.1.254
(ACHTUNG !: Diese IP darf NICHT im DHCP Adresspool des Cisco Routers liegen !!)
Maske: 255.255.255.0
Gateway: 192.168.1.1
DNS: 192.168.1.1


Wenn du das genau so machst dann wird das auch fehlerlos funktionieren und du hast "Internet" !
Übrigens hattest du das auch schon vorher immer nur deine Namensauflösung hat nicht funktioniert ! Wenn du im Browser mal eine nackte IP ohne DNS wie http://82.149.225.18 eingegeben hättest, dann wärst du bei Administrator.de gewesen ! Fazit: Immer mal intelligent nachdenken beim Troubleshooten !!
Das Dauerpingen der 8.8.8.8 also Googles DNS Name Server solltest du besser lassen. Sehr erfreut werden die nicht darüber sein !
Bitte warten ..
Mitglied: Alex1500
15.06.2014 um 14:05 Uhr
Das ist mal ne Lösung ;). Super immer die kleinen Fehler... Wieder was gelernt.
Bitte warten ..
Mitglied: aqui
15.06.2014 um 14:44 Uhr
Na komm....das ist eigentlich IP Grundschule 1. Klasse !

Klasse wenns nun klappt wie es soll.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
gelöst Fritz.Box statische Route zu anderem Subnetz (16)

Frage von Frankenstein zum Thema Router & Routing ...

Voice over IP
gelöst Modem + Router einzeln kaufen bei VOIP (3)

Frage von danielr1996 zum Thema Voice over IP ...

Router & Routing
VigorNIC 132 (PCI-e Card) - PCIe Karte Modem/Router (16)

Link von Dobby zum Thema Router & Routing ...

LAN, WAN, Wireless
Fritzbox 3170 als modem und Lancom 1781ew+ als Router (6)

Frage von ItGeek zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...