Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Store.exe belegt viel RAM - trotz Anpassung keine Verbesserung

Frage Microsoft Exchange Server

Mitglied: noname666

noname666 (Level 1) - Jetzt verbinden

06.08.2013, aktualisiert 10:26 Uhr, 2732 Aufrufe, 16 Kommentare

Hallo zusammen

Ich habe nun mehrfach versucht, die store.exe (Exchange 2010) zu begrenzen.

Laut folgenden Berichten/Themen:
1. http://www.sysadminslife.com/windows/exchange-storeexe-hohe-ram-auslast ...
2. http://www.kuehleis.de/knowhow/windows-exchange-store-exe-speicherausla ...
3. http://www.dacomsys.de/2013/01/exchange-2010-arbeitsspeicher-der-store- ...
sollte das ganze ja völlig einfach sein.

Leider hat das bisher nie funktioniert (wurde an zwei Servern getestet). Nun die Frage an Euch, stimmen die Anleitungen nicht oder gibt es noch etwas zu beachten?

Ich hoffe Ihr habt mir nen Tipp.

Danke vorab

Daniel

PS: Wie gross sollte die store.exe minimal sein? Gibt es hierfür bestimmte Richtwerte?
Mitglied: d4shoerncheN
06.08.2013, aktualisiert um 10:33 Uhr
Hallo,

warum willst du sie begrenzen?

Es ist doch ganz normal, dass sich der Store-Speicher vom Exchange sich den verfügbaren Speicherplatz nimmt. Wird dieser benötigt, so sinkt auch der Anspruch der store.exe.

Ihr habt auch kein Performance-Gewinn dadurch, dass sich euer Server langweilt. Solang er den Speicher nutzen kann, solltet ihr das auch so weiterführen.

"Es macht ja auch wenig Sinn sich einen Porsche zu kaufen und diesen im 2 Gang maximal bis 50km/h zu fahren um Sprit zu sparen"

Gruß
@d4shoerncheN
Bitte warten ..
Mitglied: Dani
06.08.2013 um 10:36 Uhr
Moin Daniel,
was veranlasst dich zu dieser Idee? Wollt ihr dem Exchangeserver noch einen SQL-Server aufdrücken?
Laufen lassen wie es ist... wir haben z.B. 32GB RAM zugewiesen. Richtet sich natürlich nach den Datenbanken und Postfächern.


Grüße,
Dani
Bitte warten ..
Mitglied: noname666
06.08.2013 um 10:39 Uhr
Hoi zusammen

Naja, was mich dazu veranlasst?
Gute Frage - ich habe das Gefühl, dass alles recht träge ist, wenn der Server so dermassen ausgelastet ist.
Ich habe das schon getestet, wenn ich normal auf dem Server arbeite, ist der recht langsam und zäh, kaum starte ich die store.exe neu, ist das Arbeiten flüssig.
Das selbe habe ich aber auch beim Zugriff auf den Server von den Clients aus festgestellt -> bilde ich mir das nur ein?

Gruss

Daniel
Bitte warten ..
Mitglied: kn0rki
06.08.2013 um 10:59 Uhr
moin,

ist das ein SBS2011?
Bitte warten ..
Mitglied: Phalanx82
06.08.2013 um 11:00 Uhr
Zitat von noname666:
Hoi zusammen

Naja, was mich dazu veranlasst?
Gute Frage - ich habe das Gefühl, dass alles recht träge ist, wenn der Server so dermassen ausgelastet ist.
Ich habe das schon getestet, wenn ich normal auf dem Server arbeite, ist der recht langsam und zäh, kaum starte ich die
store.exe neu, ist das Arbeiten flüssig.
Das selbe habe ich aber auch beim Zugriff auf den Server von den Clients aus festgestellt -> bilde ich mir das nur ein?

Gruss

Daniel

Dann würde ich mal auf unterdimensionierte Hardware tippen? Wenn noch RAM frei ist liegts wahrscheinlich an den Platten.
Wenn kein RAM mehr frei ist, swappt Windows wie gestört alles auf die Platte(n) und das kostet Performance.
Wenn die CPU nicht am Anschlag läuft und trotzdem Performance Probleme da sind und freier RAM, dann definitiv die Platten.

Wahrscheinlich reichen deine IOps nicht aus um alles zu bedienen. Was für Platten hast Du denn in der Kiste drin und welches
Raid, falls vorhanden? Am besten gleich mal die gesamte Hardware und Software auflisten ;)


Mit freundlichen Grüßen.
Bitte warten ..
Mitglied: noname666
06.08.2013 um 11:06 Uhr
@kn0rki: Ja, es ist ein SBS2011

@Phalanx82: Die Performanceprobleme sind nur da, wenn der RAM voll ausgelastet -> durch store.exe. Die CPU ist nicht betroffen. Es ist ein Raid 5 mit 4 x 300GB 6G SAS 10k Platten
Bitte warten ..
Mitglied: Pjordorf
06.08.2013 um 11:18 Uhr
Hallo,

Zitat von noname666:
Ja, es ist ein SBS2011
Hehe. Wie schon von allen hier vermutet.

Die Performanceprobleme sind nur da, wenn der RAM voll ausgelastet -> durch store.exe
Klar, dann wird ja auch auf der Festplatte ausgelagert. Die Festplatten sind das langsamste bei dir.

Die CPU ist nicht betroffen.
Welche ist denn verbaut und ist es mehr als eine?

Es ist ein Raid 5 mit 4 x 300GB 6G SAS 10k Platten
Und? Wer ist für dieses RAID zuständig? Eine onboard Chip oder eine echter RAID Kontroller?

Wie viel RAM hat deine Kiste?
ECC RAM oder nicht?
Mainboard = Serverboard oder doch nur ein Desktopboard vom Spielplatz?
Wie viel Benutzer?
Was läuft ausser dem SBS 2011 noch da drauf?

Gruß,
Peter
Bitte warten ..
Mitglied: noname666
06.08.2013 um 11:25 Uhr
Letzendlich ist es der Server:
http://www8.hp.com/ch/de/products/proliant-servers/product-detail.html? ...
Verändert wurde hardwaretechnisch nichts.

User haben wir nur 4

Es läuft nur der SBS, sonst nichts.

Gruss
Bitte warten ..
Mitglied: SlainteMhath
06.08.2013, aktualisiert um 11:33 Uhr
Moin,

Ich habe das schon getestet, wenn ich normal auf dem Server arbeite, ist der recht langsam und zäh, kaum starte ich die
store.exe neu, ist das Arbeiten flüssig.
Grundsätzlich gilt: ein Server ist für das abarbeiten von Hintergrunddiensten optiomiert, nicht für Interaktives Arbeiten an der Server Console; deswegen ist das arbeiten am Server immer langsamer als am Client.

Das selbe habe ich aber auch beim Zugriff auf den Server von den Clients aus festgestellt -> bilde ich mir das nur ein?
Evtl. solltest Du dein Gefühl durch Messwerte (ping / NetIO / Iperf / IOMeter) untermauern.

Und verrate uns doch mal wieviel RAM der Server hat, wie groß die Postfächer/die DB ist/sind, und wieviele User auf der Kiste arbeiten.

/EDITH. Ah, sehe gerade deinen Post. Der Server sollte aber mit 32GB bei 4 Usern nicht durch den Exchange in die Knie gehen. Läuft ein Virenscanner? Sind die Exchange DBs und Logs von Scan ausgenommen?

lg,
Slainte
Bitte warten ..
Mitglied: noname666
06.08.2013, aktualisiert um 11:35 Uhr
Läuft ein Virenscanner?
Nein
Sind die Exchange DBs und Logs von Scan ausgenommen?
Ja


Das ist es ja, was mich so wundert.
Bitte warten ..
Mitglied: Pjordorf
06.08.2013 um 11:45 Uhr
Hallo,

Zitat von noname666:
> Läuft ein Virenscanner?
Nein
> Sind die Exchange DBs und Logs von Scan ausgenommen?
Ja
Ein bischen verwirrend deine Antwort, oder?

Was läuft sonst noch aouf der Kiste was nicht zum SBS 2011 im Standard dazugehört?
Wie ist dein RAID5 tatsächlich Konfiguriert sprich welche Einstellungen hast du für dein RAID 5 gewählt, auch die Einstellungen des Controllers selbst?

Lasse mal die Exchangedienste nicht Automatisch starten (Aufschreiben wie die Einstelleungen waren) und dstarte dann den SBS. ist es dann auch langsam vom Client her? Was ist Langsam? HTTP? HTTPS? Freigaben? WSUS? Was sagt der Taskmanager? Wieviel RAM wird denn für welche Prozess zugeordnet? Was ist mit der Performance des RAIDS? Was sagt der RAID Controller dazu?

Mit NetIO mal das Netz Prüfen.

Gruß,
Peter
Bitte warten ..
Mitglied: noname666
09.08.2013 um 08:17 Uhr
Moin

Klar ist meine Antwort verwirrent, sorry hab ich verlesen.
Virenscanner ist keiner installiert -> somit hat sich Frage zwei erledigt.

Es läuft wirklich ausschliesslich der SBS, sonst nichts.
Die Einstellungen vom Raid kann ich Dir so prompt nicht liefern, da ich das Raid nicht eingerichtet habe.
Kann Dir nur sagen, dass das Raid anfangs aus 4 Platten im Raid 5 bestand. Mitlerweile besteht das Raid aus 7 Platten im Raid 5 plus 1 Ausfallplatte.

Das Einzige, was langsam ist, ist der Zugriff auf die Freigaben.

Habe alles geprüft, schein auch alles in Ordnung zu sein.

Ich werde mich weiter mit dem Thema auseinandersetzen und dann berichten.

Danke vorab
Daniel
Bitte warten ..
Mitglied: goscho
09.08.2013 um 09:27 Uhr
Zitat von noname666:
Moin
Morgen
Es läuft wirklich ausschliesslich der SBS, sonst nichts.
Die Einstellungen vom Raid kann ich Dir so prompt nicht liefern, da ich das Raid nicht eingerichtet habe.
Kann Dir nur sagen, dass das Raid anfangs aus 4 Platten im Raid 5 bestand. Mitlerweile besteht das Raid aus 7 Platten im Raid 5
plus 1 Ausfallplatte.
Diese Hardware sollte den SBS spielend vertragen, bei 4 Usern.
Das Einzige, was langsam ist, ist der Zugriff auf die Freigaben.
Wie äußert sich das denn genau?

Sind Kopiervorgänge von Client zur Freigabe oder anders herum langsam?
Dann würde ich die Netzwerkkonfiguration, die DNS-Einstellungen und den Client-AV überprüfen.
Bitte warten ..
Mitglied: noname666
09.08.2013 um 09:33 Uhr
Hi

Ja eben, ich denke die Hardware lacht sich dabei eher schlapp.

Das Kopieren vom sowie zum Server ist recht langsam - aber eben nur, wenn der RAM durch die store.exe belegt ist.
Sobald ich diese neu starte (Infospeicher) und der RAM wieder in normalem Bereich läuft, ist das Kopieren schneller.

Somit sollte es mit DNS usw. auch nichts zu tun habe, oder?
Bitte warten ..
Mitglied: Pjordorf
09.08.2013 um 11:14 Uhr
Hallo,

Zitat von noname666:
Die Einstellungen vom Raid kann ich Dir so prompt nicht liefern, da ich das Raid nicht eingerichtet habe.
Aber du kannst dir die Konfiguration im laufenden Betrieb schon ansehen / ändern, oder?

Kann Dir nur sagen, dass das Raid anfangs aus 4 Platten im Raid 5 bestand.
War es hier auch schon zu deinen Problem gekommen oder erst nachdem

Mitlerweile besteht das Raid aus 7 Platten im Raid 5 plus 1 Ausfallplatte
weitere Platten hinzugefügt wurden?
.
Das Einzige, was langsam ist, ist der Zugriff auf die Freigaben.
Wie äußert sich dies? Mit NetIO hast du ausgeschlossen das es am LAN / Switche / NICs selbst liegt?

Habe alles geprüft, schein auch alles in Ordnung zu sein.
Taskmanager, Resourcenmonitor etc können dior da schon mal helfen.

Gruß,
Peter
Bitte warten ..
Mitglied: Pjordorf
09.08.2013 um 11:21 Uhr
Hallo,

Zitat von noname666:
aber eben nur, wenn der RAM durch die store.exe belegt ist.
Wie viel ist denn dann tatsächlich belegt?

Sobald ich diese neu starte (Infospeicher) und der RAM wieder in normalem Bereich läuft,
Was zum Teufel ist denn das für eine Größenangabe mit deinem "wenn der RAM im normalen Bereich läuft"? Läuft der dann im Olympiastadion? ist dir aufgefallen das du es bis jetzt ernergisch vermieden hast auch nur einmal eine Zahl zu deinem "mein RAM ist das problem" geliefert hast? Jetzt sagst du "RAM im normalen Bereich"! Was ist Normaler Bereich? Wir wissen es nicht. Guter RAM ist genutzter RAM. Warum RAM kaufen wenn er nicht genutzt werden soll? Warum 32 GB RAM in einer Kiste rein wenn ich doch nur 4 GB nutzen will?

Ich kann mir unter deinem normalen RAM verbrauch wirklich keine Zahl oder Größenangabe vorstellen um zu wissen was du damit wirklich meinst.

Du möchtest Hilfe, nicht wir.

Gruß,
Peter
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
RAM Berechung für TS (5)

Frage von MegaGiga zum Thema Windows Server ...

RedHat, CentOS, Fedora
gelöst Erstellen von Desktopverknüpfungen und Anpassung der Taskleiste (2)

Frage von honeybee zum Thema RedHat, CentOS, Fedora ...

Windows Server
Google Chrome Web Store Problem auf Terminal Farm

Frage von dakoerry zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...