Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Stream-Problem mit Windows Media Player

Frage Multimedia Audio

Mitglied: remat

remat (Level 1) - Jetzt verbinden

13.07.2006, aktualisiert 17.10.2008, 21080 Aufrufe, 1 Kommentar

Der Windows Media Player streamt nicht von einer lokalen IP. Winamp und andere Programme funktionieren aber ohne Problem...

Hallo und Servus!

ich habe hier ein sehr komisches Problem.

Situationsbeschreibung:

In einem Studentenwohnheim wird ein Streamingserver betrieben. Soweit läuft auch alles wunderbar.
Der Streaming-Server (Windows 2000 Server, Icecast2, Oddcast-plugin für Winamp) hat 2 IP-Adressen. Dies ist deswegen so da eine Fritzbox betrieben wird, die ihrern eigenen IP-Bereich besitzt (man bekommt im Wohnheim nicht beliebig viele Adressen).
Also, der Streaming Server hat die IP 192.168.118.9 und die 169.245.100.3 (beides ja Adressen, die nicht in Internet geroutet werden).
Auf dem Server läuft noch ein http Server, der z.B. anzeigt, was gerade gespielt wird etc. Auf einer dieser Seiten habe ich den Windows Media Player mittels object-tags eingebunden. Z.B. so wie auf www.rockantenne.de. Dabei muss natürlich angegeben werden, welche Datei/Stream abgespielt werden soll. Und jetzt wird's interessant:

Die Adresse zum Stream ist einmal die http://169.254.100.3:8000/stream.ogg , die zweite mit der zweiten IP Adresse. Unter Winamp ist der Stream auf beiden Adressen zu erreichen. Mit dem Mediaplayer nur unter der 169.254.100.3.
Klar, man könnte nur Winamp hernehmen - aber der Stream soll ja eingebettet auf der Seite zu erreichen sein, also Mediaplayer (will nicht Realplayer nehmen - ausserdem hat ja jeder MP). Und dazu muss er eben auch unter der 192.168.118.9 zu erreichen sein - weil die aus dem Adressbereich des Wohnheim ist. Sonst kommen nur Leute aus dem Anderen bereich drauf, das sind grad mal 4....

Warum ist der Stream also aus dem Mediaplayer nicht unter beiden Adressen zu erreichen?! Der Mediaplayer reagiert übrigens nicht mehr, sobald ein Verbindungsversuch mit der 192.168.... versucht wird.
Ach ja...ogg-Plugin für mediaplayer natürlich installiert, es funktioniert ja auch mit der 169.254....)
Ich kenn mich nimmer aus...

Kann mir da jemand helfen?!

Vielen Dank im Voraus

remat

EDIT:
Nach etwas testen:
Es funktioniert von anderen Rechnern im Wohnheim - scheinbar nur nicht von den 4 mit 2 IP-Adressen... liegt wohl einfach an Microsoft... wenn jemand was weiß - ich freu mich trotzdem noch auf eine Lösung
Mitglied: onegasee59
17.10.2008 um 14:24 Uhr
Zitat von remat:

nicht Realplayer nehmen - ausserdem hat ja jeder MP). Und dazu muss er
eben auch unter der 192.168.118.9 zu erreichen sein - weil die aus dem
Adressbereich des Wohnheim ist. Sonst kommen nur Leute aus dem Anderen
bereich drauf, das sind grad mal 4....

Wie sind denn die Einstellungen des WMP bei Euch unter Extras- Optionen im Register Netzwerk?
Evt. ist da die Einschränkung.

onegasee59
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Routing Problem (Windows Server Routing und RAS) (5)

Frage von filou204 zum Thema Router & Routing ...

Windows Update
gelöst Windows Server 2012 R2 - WSUS Problem (1)

Frage von aladin.inder zum Thema Windows Update ...

Neue Wissensbeiträge
Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
VPN Tunnel aufbauen (16)

Frage von Hajo2006 zum Thema LAN, WAN, Wireless ...

Router & Routing
ASUS RT-N18U mit VPN Client hinter Fritzbox - Portforwarding (13)

Frage von marshall75000 zum Thema Router & Routing ...

Microsoft Office
Saubere HTML aus Word-Dokument (13)

Frage von peterpa zum Thema Microsoft Office ...

E-Mail
gelöst Probleme beim E-Mail Empfang (12)

Frage von TommyB83 zum Thema E-Mail ...