Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Microsoft Office

GELÖST

Suche ähnliche Formel wie Zählenwenn

Mitglied: kiim

kiim (Level 1) - Jetzt verbinden

16.10.2009 um 11:08 Uhr, 4669 Aufrufe, 14 Kommentare

Hallo Zusammen,

Also ich hab folgendes Problem und weiss momentan wirklich nicht mehr weiter:

Ich habe 2 Tabellenblätter. In einem habe ich die Rohdaten mit 2 Spalten (passiv/depot und db II) --> Bild1
Im zweiten Tabellenblatt mache ich eine auswertung aufgrund diese zahlen. --> Bild2

es ist ein bisschen schwer zum erklären drum einfach mal kurz die bilder anschauen. Also eine Formel, damit ich die Anzahl der Kunden auflisten kann habe ich bereits gefunden, bin mir aber nicht sicher ob diese ganz stimmt:

=(ZÄHLENWENN('Zahlen Auswertung'!G$2:G$804;">0")+ZÄHLENWENN('Zahlen Auswertung'!G$2:G$804;"<900000"))-ANZAHL('Zahlen Auswertung'!G$2:G$1441)

--> Beispiel für Zelle C7

Nun brauche ich noch eine Formel um den db auszurechnen.

--> Beispiel für Zelle E7
Folgende Kriterien müssen erfüllt sein: Passiv/ Depot zwischen 0 und 899000 (Spalte G bei den Rohdaten), dabei muss es dann aber die Zahl von der gleichen Zeile, aber von der Spalte D nehmen, danach müssen alle diese Zahlen, die das Kriterium erfüllen summiert werden.


Ich hoffe irgendwer versteht mich. :D Weiss nicht genau, wie ich es sonst erklären soll.

Besten Dank schon im Voraus

Kiim


BILD 1
e1bc0184b37aa7c5261b9d72ce422345-bild1 - Klicke auf das Bild, um es zu vergrößern


BILD 2
ec60c3e46e8a3db3e0ea0b551a1ea833-bild2 - Klicke auf das Bild, um es zu vergrößern
Mitglied: 76109
16.10.2009 um 14:53 Uhr
Hallo kiim!


Die Spalte C in Tabelle 2 könnte so aussehen:
C
07 =ZÄHLENWENN(Tabelle1!$G:$G;"<=899000")
08 =ZÄHLENWENN(Tabelle1!$G:$G;"<=999000")-SUMME(C7)
09 =ZÄHLENWENN(Tabelle1!$G:$G;"<=1999000")-SUMME(C7:C8)
10 =ZÄHLENWENN(Tabelle1!$G:$G;"<=2999000")-SUMME(C7:C9)
11 =ZÄHLENWENN(Tabelle1!$G:$G;"<=3999000")-SUMME(C7:C10)
12 =ZÄHLENWENN(Tabelle1!$G:$G;"<=4999000")-SUMME(C7:C11)
13 =ZÄHLENWENN(Tabelle1!$G:$G;"<=5999000")-SUMME(C7:C12)
14 =ZÄHLENWENN(Tabelle1!$G:$G;"<=9999000")-SUMME(C7:C13)
15 =ZÄHLENWENN(Tabelle1!$G:$G;"<=14999000")-SUMME(C7:C14)
16 =ZÄHLENWENN(Tabelle1!$G:$G;">=15000000")


Die Spalte E in Tabelle 2 könnte so aussehen:
E
07 =SUMMEWENN(Tabelle1!$G:$G;"<=899000";Tabelle1!$D:$D)
08 =SUMMEWENN(Tabelle1!$G:$G;"<=999000";Tabelle1!$D:$D)-SUMME(D7)
09 =SUMMEWENN(Tabelle1!$G:$G;"<=1999000";Tabelle1!$D:$D)-SUMME(D7:D8)
10 =SUMMEWENN(Tabelle1!$G:$G;"<=2999000";Tabelle1!$D:$D)-SUMME(D7:D9)
11 =SUMMEWENN(Tabelle1!$G:$G;"<=3999000";Tabelle1!$D:$D)-SUMME(D7:D10)
12 =SUMMEWENN(Tabelle1!$G:$G;"<=4999000";Tabelle1!$D:$D)-SUMME(D7:D11)
13 =SUMMEWENN(Tabelle1!$G:$G;"<=5999000";Tabelle1!$D:$D)-SUMME(D7:D12)
14 =SUMMEWENN(Tabelle1!$G:$G;"<=9999000";Tabelle1!$D:$D)-SUMME(D7:D13)
15 =SUMMEWENN(Tabelle1!$G:$G;"<=14999000";Tabelle1!$D:$D)-SUMME(D7:D14)
16 =SUMMEWENN(Tabelle1!$G:$G;">=15000000";Tabelle1!$D:$D)

Gruß Dieter
Bitte warten ..
Mitglied: kiim
16.10.2009 um 15:36 Uhr
wunderbar danke.

hat alles tiptop funktioniert.

danke für die hilfe!

lg kim.
Bitte warten ..
Mitglied: 76109
16.10.2009 um 16:02 Uhr
Hallo Kim!

Gern geschehen

Ein schönes WE

Gruß Dieter

PS. In Spalte E Zeile 9 war ein '='-Zeichen abhanden gekommen. Muss natürlich '<=' heißen.
Bitte warten ..
Mitglied: Biber
16.10.2009 um 18:57 Uhr
Moin kiim & didi1954,


auch wenn es schon auf "Gelöst" steht....

Lesbarer/Wartbarer als diese "Summe Gesamt abzüglich Summe Bisher"-Konstruktion finde ich

[in 07] =SUMMENPRODUKT((Tabelle1!$G$4:$G$804>=0)*(Tabelle1!$G$4:$G$804<=899000))
[in 08] =SUMMENPRODUKT((Tabelle1!$G$4:$G$804>899000)*(Tabelle1!$G$4:$G$804<=999000))
....

Etc.-- wenn es um die ANZAHL geht.

in der Spalte E oder wo auch immer die SUMMEN stehen sollen
-->einfach noch eine dritte "*( Bereich-ohne Bedingung)"-Klammer anfügen.

[in 07] =SUMMENPRODUKT((Tabelle1!$G$4:$G$804>=0)*(Tabelle1!$G$4:$G$804<=899000) * (Tabelle1!$G$4:$G$804))
[in 08] =SUMMENPRODUKT((Tabelle1!$G$4:$G$804>899000)*(Tabelle1!$G$4:$G$804<=999000)* (Tabelle1!$G$4:$G$804))
....

Grüße
Biber
Bitte warten ..
Mitglied: 76109
16.10.2009 um 20:13 Uhr
Hallo Biber!

Auch ne Möglichkeit, aber ob's am Ende effektiver ist? Keine Ahnung. Und wo ist die Summe aus Spalte D?

Sieht jedenfalls gut aus

Gruß Dieter
Bitte warten ..
Mitglied: Biber
16.10.2009 um 22:03 Uhr
Moin didi1954,
Zitat von 76109:
Auch ne Möglichkeit, aber ob's am Ende effektiver ist?
Wenn ich dadurch auch nur einen übersehenen Tippfehler weniger in der Jahresbilanz habe, ist es effektiver... ;)

Und wo ist die Summe aus Spalte D?

Ja wie jezz'????
Soll ich die Prozente denn aus den -zigtausend Einzeldaten errechnen???
Die hätte ich als als Laie in Blatt2 aus den Werten auf Blatt2 berechnet....

Oder bringt das weniger, falls ich nach geleisteten Arbeitsstunden bezahlt werde?

Grüße und schönes Wochenende
Biber
Bitte warten ..
Mitglied: 76109
16.10.2009 um 22:32 Uhr
Hallo Biber!

Also, einer von uns beiden steht jetzt irgendwie auf der Leitung

Es geht um die db-Summen in Tabelle1 Spalte D in Abhängigkeit der Test's aus Spalte G.

Auch Dir ein schönes WE

Gruß Dieter
Bitte warten ..
Mitglied: Biber
17.10.2009 um 01:06 Uhr
Moin didi1954,

sorry, das war ich, der auf der Leitung stand...

In diesem Fall (Spalte G soll (auf die zwei Bedingungen > x und <= y) geprüft werden, aber die Daten aus Spalte D geholt werden:

[in 07] =SUMMENPRODUKT((Tabelle1!$G$4:$G$804>=0)*(Tabelle1!$G$4:$G$804<=899000) * (Tabelle1!$D$4:$D$804))
[in 08] =SUMMENPRODUKT((Tabelle1!$G$4:$G$804>899000)*(Tabelle1!$G$4:$G$804<=999000)* (Tabelle1!$D$4:$D$804))

Kann natürlich kein Schwein lesen, aber
  • wenn Tabelle1!$G$4:$G$804 den Namen "PuD" wie "Passiv und Depot" hätte und
  • wenn Tabelle1!$D$4:$D$804) den Namen "Dbii" hätte,

Dann reduziert es sich auf:
[in 07] =SUMMENPRODUKT((PuD>=0)*(PuD<=899000) * (Dbii))
[in 08] =SUMMENPRODUKT((PuD>899000)*(PuD<=999000) * (Dbii))

... und dann fängt es für mich an "wartbar" zu werden.

Grüße
Biber
Bitte warten ..
Mitglied: 76109
17.10.2009 um 11:29 Uhr
Hallo Biber!

Schon besser. Und Funktioniert sogar

Jetzt hat Kim die freie Auswahl!

Gruß Dieter
Bitte warten ..
Mitglied: Biber
17.10.2009 um 11:47 Uhr
Moin didi1984,

der nächste logische Schritt zur Lesbarkeit wäre, die Unter/Obergrenzen ( 0 bis 899000, 899000 bis 999000 etc) nicht mehr hart in diese Formeln zu hacken, sondern die aus zwei Spalten zu holen, aus denen sich auch die Von-Bis-Anzeigespalten links bedienen.
Oder diese Anzeigespalten als Quelle zu benutzen.

Aber da warten wir mal auf kiim, bis sie diese Idee hat...

Grüße
Biber
Bitte warten ..
Mitglied: 76109
17.10.2009 um 12:15 Uhr
Hallo Biber!

Zitat von Biber:
der nächste logische Schritt zur Lesbarkeit wäre, die
Unter/Obergrenzen ( 0 bis 899000, 899000 bis 999000 etc) nicht mehr
hart in diese Formeln zu hacken, sondern die aus zwei Spalten zu
holen, aus denen sich auch die Von-Bis-Anzeigespalten links bedienen.
Daran hatte ich auch schon gedacht. Aber mit den Großen Zahlen in Spalte A und B, sieht das rein optisch auch nicht so toll aus. Oder eventuell versteckte Zellen verwenden?

Ist eine gute Anregeung und Kim kann die Formel ja entsprechend anpassen.

Gruß Dieter
Bitte warten ..
Mitglied: Biber
17.10.2009 um 12:51 Uhr
Moin didi1954,

Aber mit den Großen Zahlen in Spalte A und B, sieht das rein optisch auch nicht so toll aus

Is' jetzt ein Späßken, oder?
Ich meine, selbst ich würde es ja noch auch unter Lesbarkeitskeitsgesichtspunkten für vertretbar halten, wenn in den A/B-Anzeigespalten 0 und 899, 899 und 999 etc als Zahlenwerte stehen und in den Formelspalten dann jeweils "* 1000" steht.

Also sinngemäß statt
=SUMMENPRODUKT((PuD>899000)*(PuD<=999000) * (Dbii))
sowas wie
=SUMMENPRODUKT((PuD>($A7*1000))*(PuD<=($B7*1000)) * (Dbii))

Oder steh ich wieder auf der Leitung?

Grüße
Biber
P.S. Grmpf... wir müssen wohl eh kürzere Formeln nehmen bei diesem neuen ###-Seitenlayout...
Bitte warten ..
Mitglied: 76109
17.10.2009 um 14:02 Uhr
Hallo Biber!

Zitat von Biber:
Is' jetzt ein Späßken, oder?
stehen und in den Formelspalten dann jeweils "* 1000"
Naja, wenn schon, dachte ich zumindest, dann nur die Zelle in die Formel schreiben
Aber ich habe grad was mit Zellformatierung probiert. Wenn ich das Format '#.###.' verwende, dann zeigt er z.B. bei 899000 nur 899 an und bei 999 dann die 1 usw.
Oder steh ich wieder auf der Leitung?
Nö, diesesmal stand wohl ich auf der Leitung
P.S. Grmpf... wir müssen wohl eh kürzere Formeln nehmen bei diesem neuen ###-Seitenlayout...
Wenn das so bleibt, dann werde ich die Threads zur besseren Lesbarkeit, in Zukunft in eine PDF-Datei drucken?

Gruß Dieter
Bitte warten ..
Mitglied: Biber
17.10.2009 um 23:56 Uhr
<OT>
Zitat von 76109:
> P.S. Grmpf... wir müssen wohl eh kürzere Formeln nehmen bei diesem neuen ###-Seitenlayout...
Wenn das so bleibt, dann werde ich die Threads zur besseren Lesbarkeit, in Zukunft in eine PDF-Datei drucken?
Auf eine Rolle Klopapier?

Grüße
Biber
</OT>
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Excel Zählenwenn
gelöst Frage von Florian86Microsoft Office7 Kommentare

Hallo, gibt es eine Möglichkeit bei Zählenwenn bzw. den Inhalt einer Formel so zu gestalten, dass man die Wahl ...

Microsoft
ZÄHLENWENN Excel
gelöst Frage von ExcelOpferMicrosoft7 Kommentare

Hallo liebe Community Ich habe mal wieder ein für mich unlösliches Problem! Ich habe eine Liste von Einzelwartungen die ...

Hosting & Housing
Suche FTP Ersatz, ähnlich wie WeTransfer
gelöst Frage von D-LineHosting & Housing4 Kommentare

Hallo Zusammen Zuerst möchte ich erwähnen, dass ich die Suchfunktion benutzt habe und auch einige Threads über FTP Alternativen ...

Microsoft Office
Excel: Zählenwenn mit mehreren Bedingungen
Frage von VancouveronaMicrosoft Office1 Kommentar

Hi, ich bräuchte eine Zählenwenn Funktion, die mehrere Bedingungen auswertet. Geht das inzwischen mit Office 2012/2013? Oder muß ich ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 1 TagLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 2 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 2 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 2 TagenSicherheit10 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
E-Mail
Erfahrungen mit hMailServer gesucht
Frage von it-fraggleE-Mail10 Kommentare

Hallo, meine neue Stelle möchte einen eigenen Mailserver. Ich als Linuxkind war direkt geistig mit Postfix dabei. Leider wollen ...

Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall9 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

Entwicklung
VBS: alle PDF-Dateien in einem Ordner gleichzeitig öffnen
gelöst Frage von JuweeeEntwicklung9 Kommentare

Hallo, ich habe in deiner Ordnerstruktur (.\Tagesberichte\xx.18\) mehrere dynamische PDF-Formulare (mit LCD erstellt). Die Berichtsformulare sind im Layout alle ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen7 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...