Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Suche Excel Formel

Frage Microsoft Microsoft Office

Mitglied: klooon

klooon (Level 1) - Jetzt verbinden

21.08.2011 um 18:13 Uhr, 3544 Aufrufe, 11 Kommentare

Hallo,

ich habe 2 Excel Tabellen mit der selben Spalte Namens Artikelnummer, also wie ein Primätschlüssel.

Jetzt ist es so das Tabelle 1 unter anderem eine Spalte Geschmack hat welche Tabelle 2 nicht hat.

Nun würde ich gerne diese Spalte in Tabelle 2 hinzufügen indem geschaut wird ob Artikelnummer aus Tabelle 1 mit der Artikelnummer aus Tablle 2 übereinstimmt und wenn ja dann soll die dazugehörige Zelle Geschmack in Tabelle 2 hinzugefügt werden.

Ich hoffe mal ich konnte mich verständlich ausdrücken.

Wäre super wenn ihr mir helfen könntet.

Danke
Mitglied: Xboxer
21.08.2011 um 18:21 Uhr
Hi,

schau dir mal SVERWEIS an.

Gruß
Christoph
Bitte warten ..
Mitglied: dog
21.08.2011 um 18:21 Uhr
SVERWEIS
Bitte warten ..
Mitglied: winf-hst
21.08.2011 um 18:21 Uhr
Hallo Klooon,

du brauchst doch lediglich eine Wenn-Formel benutzen.
Also in etwa so: wenn(a2=a1;b1)
Sprich wenn Artikelnummer in a2 gleich der in a1 ist dann nimm für diese Zelle den Wert von b1.
Wobei a2 die Artikel Nummer in Tabelle 2 und a1 die in Tabelle 1 ist und b1 dann der Geschmack.

Ich hoffe es hilft dir.

gruß
Bitte warten ..
Mitglied: Solarius
21.08.2011 um 18:22 Uhr
Auch Hallo,

teste mal die Funktion "Sverweis" damit sollte das gelöst werden können.

Schönen Sonntag noch.

Solarius

da waren wieder alle schneller
Bitte warten ..
Mitglied: Niklas434
21.08.2011 um 18:53 Uhr
Primätschlüssel meinst Primärschlüssel naja Excel ist keine Datenbank aber ich Versteh was du meinst Nimm den Sverweis schau dir zur not videos bei youtube an
Bitte warten ..
Mitglied: Zollwurf
21.08.2011 um 21:31 Uhr
=SVERWEIS([Suchwert];[Suchmatrix];[RückgabeSpalte])

Liest sich komplex, ist aber recht "easy":
  • In Suchwert gehört deine Artikelnummer aus Tabelle2
  • In Suchmatrix gehört der Bereich aus Tabelle1 mit Artikelnummer und Geschmack, beginnend mit der Spalte der Artikelnummer
  • RückgabeSpalte ist die Nummer der Spalte rechts der Spalte mit der Artikelnummer (aus Tabelle1)

Angenommen, in Tabelle1 stünde (in Spalten)
A |B|C
1234| Kaviar | salzig
3421|Honig | süss

und in Tabelle2
A|B
ArtNr.|Geschmack
3421|=SVERWEIS(A1;Tabelle1!$a:$c;3)

Wenn das ganze unsortiert ist, benötigst du eventuell es letzten (optionalen) Parameters der SVERWEIS-Funktion.
Bitte warten ..
Mitglied: bastla
21.08.2011 um 21:47 Uhr
@Zollwurf
Wenn das ganze unsortiert ist, benötigst du eventuell es letzten (optionalen) Parameters der SVERWEIS-Funktion.
Auch wenn's sortiert ist, würde ich lieber eine Fehlermeldung erhalten (oder, besser, mit "WENN(ISTNV(..." abfangen), als dass stillschweigend der Wert aus der nächst(best)en Zeile genommen wird - daher in solchen Fällen immer noch ein ",0" (für "0 Toleranz beim Suchen" ) hinten dran ...

Grüße
bastla

[Edit] Etwas verzögert Vorschlag mit "ISTNV()" hinzugefügt - hat sich daher mit Zollwurfs Hinweis überschnitten [/Edit]
Bitte warten ..
Mitglied: bastla
21.08.2011 um 21:50 Uhr
[OT]
@Solarius
da waren wieder alle schneller
Nicht alle ...

Grüße
bastla
[/OT]
Bitte warten ..
Mitglied: Zollwurf
21.08.2011 um 21:53 Uhr
Auch kein Problem. Frage den #NV-Error ab. In der Wenn-Funktion kannst du dir dann das ausgeben lassen, was beliegt. Oder Userdef-Function schreiben

Gruß
Bitte warten ..
Mitglied: bastla
21.08.2011 um 21:59 Uhr
@Zollwurf
In der Wenn-Funktion kannst du dir dann das ausgeben lassen, was beliebt.
Das wäre der Plan ...

... und für einen (wie es scheint) einmaligen Vorgang sicher ausreichend.

Grüße
bastla
Bitte warten ..
Mitglied: klooon
05.09.2011 um 10:57 Uhr
Super ich danke euch allen für die schnelle Hilfe, -> Problem gelöst!
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
MS Office Excel - Formel wird angezeigt, aber nicht berechneter Wert!

Tipp von holli.zimmi zum Thema Microsoft Office ...

Microsoft Office
gelöst Excel-Formel oder VBA (7)

Frage von nicki01 zum Thema Microsoft Office ...

Microsoft Office
gelöst Dateiliste in Excel 2010 wird nur nach Formel löschen aktualisiert (1)

Frage von dressa zum Thema Microsoft Office ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Festplatten, SSD, Raid
PC stellt nach dem Bios ab (20)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

iOS
16 iPads zentrall verwalten (18)

Frage von simonlohr zum Thema iOS ...

Server-Hardware
Einem Stromausfall entgegen wirken (15)

Frage von OIOOIOOIOIIOOOIIOIIOIOOO zum Thema Server-Hardware ...

Windows 7
Freeware MSI Tool (13)

Frage von uridium69 zum Thema Windows 7 ...