Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Suse RAID-1 scheinbar defekt - allerdings beide Festplatten

Frage Linux Suse

Mitglied: FalkIT

FalkIT (Level 1) - Jetzt verbinden

18.02.2014 um 17:44 Uhr, 1721 Aufrufe, 10 Kommentare, 1 Danke

Hi zusammen,
ich sitze hier aktuell vor einem Webserver (SuSE Linux 9.0) auf dem das RAID-1 defekt sein soll.
cat /proc/mdstat liefert mir folgende antwort:

Personalities : [raid1]
read_ahead 1024 sectors
md0 : active raid1 sda1[1]
1052160 blocks [2/1] [_U]

md1 : active raid1 sdb2[0]
513984 blocks [2/1] [U_]

md2 : active raid1 sda3[1]
513984 blocks [2/1] [_U]

md3 : active raid1 sda5[1]
10490304 blocks [2/1] [_U]

md4 : active raid1 sda6[1]
10490304 blocks [2/1] [_U]

md5 : active raid1 sda7[1]
1052160 blocks [2/1] [_U]

md6 : active raid1 sdb8[0]
174112320 blocks [2/1] [U_]

Was mich wundert, ist dass mal die eine und mal die andere Platte nicht genutzt wird, mdadm --detail /dev/mdX gibt mir für die fehlerhafte Platte "faulty removed" aus.
Wenn hier wirklich die Hardware defekt sein soll, würde mich das sehr wundern, so viel "Glück" kann man doch nicht haben, dass sich die Plattenfehler genau an den richtigen Stellen abwechseln?
Ein Verzeichnis /etc/mdadm existiert nicht, eigentlich hatte ich hier die mdadm.conf erwartet, um mir die config ansehen zu können.

Kennt jemand von euch einen solchen Fall? Vielleicht muss ich der Kiste ja nur sagen, dass er bitte das spiegeln wieder anfangen soll.

Vielen Dank schon mal

Falk
Mitglied: Dobby
18.02.2014 um 17:51 Uhr
Hallo,

in der Regel sieht es so aus das nur eine HDD Kaputt
ist und dann besorgt man sich eine zweite neue und baut
diese dann in den Server ein und stößt einen Rebuild Prozess
an, der dann erst das RAID wieder herstellt!

Sollten allerdings beide HDDs defekt sein ist das unter Umstände
so dann nicht mehr möglich, dann hilft oft nur zwei neue HDDs zu
kaufen und zu verbauen und dann das Backup wieder einzuspielen.

Vielleicht muss ich der Kiste ja nur sagen,
dass er bitte das spiegeln wieder anfangen soll.
Wohl eher nicht, denn Du solltest erst einmal heraus
finden was genau defekt ist und dann erst weitermachen.

In der Regel wollen RAIDs auch immer eine formatierte neue HDD
haben und dann erst kann man den Rebuild Prozess wieder anstoßen.

Gruß
Dobby
Bitte warten ..
Mitglied: FalkIT
18.02.2014 um 17:58 Uhr
Hi Dobby,
erst mal danke für die schnelle Antwort.

Sollten allerdings beide HDDs defekt sein[...]

Wie gesagt kommt es mir sehr unwahrscheinlich vor, dass auf sda die Bereiche für md2, md3, md7 und auf sdb die für md0, md1, md4, md5, md6, md8 defekt sein sollen.

Wohl eher nicht, denn Du solltest erst einmal heraus
finden was genau defekt ist und dann erst weitermachen.

Hast du hierzu eine Idee wie ich das herausfinden soll? mdadm sagt mir nur im wechsel "faulty removed" zu den beiden Platten.

Danke & Gruß

Falk
Bitte warten ..
Mitglied: Dobby
18.02.2014 um 18:56 Uhr
Also so wie ich das sehe solltest Du dann einfach mal ein
Backup zur Hand haben und die ganze Sache neu aufsetzen
bzw. zwei neue HDDs besorgen und dann eben diese auswechseln
respektive noch einmal ein Rebuildversuch anstoßen und wenn das
nicht funktioniert sollte man den Server wohl platt machen und
das Backup wieder einspielen.

Was soll es denn auch wenn beide HDDs hinüber sind kann man
wohl oder übel nichts mehr machen und wenn keine anderen
Tools zur Verfügung stehen sollte man das auch in Betracht
ziehen dürfen.


Gruß
Dobby
Bitte warten ..
Mitglied: Lochkartenstanzer
18.02.2014 um 19:34 Uhr
Zitat von FalkIT:

Was mich wundert, ist dass mal die eine und mal die andere Platte nicht genutzt wird, mdadm --detail /dev/mdX gibt mir für
die fehlerhafte Platte "faulty removed" aus.

Warum die Platte "faulty" ist, kann viele gründe haben. Vielleicht hat sie nur zu lange gebraucht, um zu antworten, z.B. weil die Platten zuviele schwebende Lesefehler haben. Da es durchaus sein kann, daß beide Platten Ausfallerscheinungen zeigen, insbesodnere wenn es baugleiche aus der gleichen Charge sind, kann sowas diuchaus passieren, wenn mal die eine und mal die andere zu langsam antwortet. Dann fliegt halt die Partition aus dem RAID raus, bei der das zuerst pasiert.

Wenn hier wirklich die Hardware defekt sein soll, würde mich das sehr wundern, so viel "Glück" kann man doch
nicht haben, dass sich die Plattenfehler genau an den richtigen Stellen abwechseln?

Nicht wil die sich abwechseln, sondern weil mal die ein udn mal die andere zu langsdam antwortet.

Ein Verzeichnis /etc/mdadm existiert nicht, eigentlich hatte ich hier die mdadm.conf erwartet, um mir die config ansehen zu
können.

Muß auch nicht existieren.


Kennt jemand von euch einen solchen Fall? Vielleicht muss ich der Kiste ja nur sagen, dass er bitte das spiegeln wieder anfangen
soll.

Vielleicht solltest Du als erstes schleunigst Deine Daten in Sicherheit bringen. Dann würde ich mal die smart-werte der Platten überprüfen, insbesodnere sowas wie "soft read error rate", "reallocation event count", etc.


Dann mal hdd-test druchlaufen lassen. eventeull hast du ja andere hardware-fehler.

lks
Bitte warten ..
Mitglied: FalkIT
19.02.2014 um 15:17 Uhr
Danke an euch beide für die Tips, ein Backup ist natürlich vorhanden.
Aktuell prüfe ich erst einmal, mittels badblocks -v /dev/sdX ob defekte Blöcke gefunden werden, momentan sind es auf sda einige aber der Scan wird wohl noch bis morgen dauern.
Bitte warten ..
Mitglied: Lochkartenstanzer
19.02.2014 um 16:22 Uhr
Zitat von FalkIT:

Danke an euch beide für die Tips, ein Backup ist natürlich vorhanden.
Aktuell prüfe ich erst einmal, mittels badblocks -v /dev/sdX ob defekte Blöcke gefunden werden, momentan sind es auf sda
einige aber der Scan wird wohl noch bis morgen dauern.

Hast Du vorher ein Image gezogen? Ein badblocks-scan kann der Platte ggf nämlich "den Rest" geben. Und so wie es bei Dir aussieht, ist die zweite Platte auch nicht frei von Fehlern.

lks
Bitte warten ..
Mitglied: Looser27
20.02.2014 um 10:57 Uhr
Moin,

bist Du sicher, dass der Raid-Controller in Ordnung ist?

Gruß

Looser27
Bitte warten ..
Mitglied: Lochkartenstanzer
20.02.2014 um 11:36 Uhr
Zitat von Looser27:

bist Du sicher, dass der Raid-Controller in Ordnung ist?

nunja, er könnte statt dem mdadm von seinem Suse den von knoppix nehmen.

lks
Bitte warten ..
Mitglied: Looser27
20.02.2014 um 11:40 Uhr
Wenn im Software-Raid-Controller ein Problem ist, haut es Dir auch sofort beide Platten weg.
Denn, nach Ausfallwahrscheinlichkeit, fallen beide Platten nur mit weniger als 1% zeitgleich aus.....
Bitte warten ..
Mitglied: Lochkartenstanzer
20.02.2014 um 11:48 Uhr
Zitat von Looser27:

Wenn im Software-Raid-Controller ein Problem ist, haut es Dir auch sofort beide Platten weg.
Denn, nach Ausfallwahrscheinlichkeit, fallen beide Platten nur mit weniger als 1% zeitgleich aus.....

nunja, wenn er mit md-devcies arbeitet, wird er vermulich keinen raidcontroller haben.

lks
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...

Peripheriegeräte
Wlan stört Funkmaus (11)

Frage von Falaffel zum Thema Peripheriegeräte ...

Peripheriegeräte
gelöst USB Festplatte verliert Laufwerksbuchstabe (9)

Frage von cese4321 zum Thema Peripheriegeräte ...