Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

System zweigt im Taskmgr Auslagerungsdatei an, die nicth vorhanden ist.

Frage Microsoft Windows Systemdateien

Mitglied: owalker

owalker (Level 1) - Jetzt verbinden

20.03.2012 um 11:52 Uhr, 2806 Aufrufe, 2 Kommentare

Hallo,

Windows macht manchmal komische Sachen:

Zur Beschleunigung habe ich die Haupt-Auslagerungsdatei (3GByte) in eine RAM-Disk verlegt. Zusätzlich gibt es noch eine mit 128 MByte auf einer Festplatte.

Die RAMDISK wird beim Hochfahren anscheinend später initialisiert wie die Auslagerungsdatei - es ist nur die "kleine" pagefile.sys korrekt im Dateisystem sichtbar; auf der Ramdisk ist nichts. Der Taskmanager zeigt sie aber an und lagert anscheinend auch darin aus. Die angezeigten Daten sind stimmig (Verlauf)

Wohin "verschwinden" die Daten? Das System läuft störungsfrei.


Konfiguration: Windows XP, 32 Bit, 16 GByte RAM (davon 12 als RAM-Disk). Ich komme mit der 32 Bit-Version aus; Umstieg auf 7 zurzeit nicht geplant (Firmenrechner).


Erhöhe ich die Auslagerugsdatei um 1 MByte (also auf 3001 MByte), wird sie als pagefile.sys mit 3001 MByte korrekt in der RAM-Disk angelegt; der Taskmanager zeigt dann die doppelte Größe (6,128 MByte) an.


Ich kann damit gut leben; mich würde aber wirklich interessieren, was da abgeht - danke schonmal für Eure Ideen.

Grüße

Olaf
Mitglied: DerWoWusste
20.03.2012 um 12:58 Uhr
Moin.

Ich glaube nicht, dass die Auslagerungsdatei der RAM-Disk benutzt wird, sofern sie im Dateisystem nicht vorhanden ist. Deutlicher: 100%ig ist das nicht so. Teste mal mit procmon, wohin denn geschrieben wird, wenn der Speicher angefüllt wird. Schreibzugriffe auf die Pagefile kann procmon darstellen, hab ich auch mal mit einer RAMdisk getestet.

Zu Deinem Problem: hatte ich auch mal. Die RAM-Disksoftware war für diese Aufgabe ungeeignet (zu spätes Mounting). Eine andere hingegen konnte es, leider in der freien Version nur mit Disks bis 4 GB: http://www.romexsoftware.com/en-us/vsuite-ramdisk/index.html - die Vollversion kann mehr.
Bitte warten ..
Mitglied: owalker
20.03.2012 um 14:03 Uhr
Hallo,

danke für die Antwort, nach einer Suche stellt es sich so da, daß das System korrekt auf die kleinere Auslagerungsdatei zugreift, allerdings mit der zahlenmäßigen Berechnung des Speichers falsch liegt; d.h. 50 % voll sind 64 MByte, stadtt 1500 MByte.

Deinem Tipp mit der Romexsoftware werde ich mal nachgehen.

Grüße

olaf
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (52)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (24)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...