Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Systemvariable APPDATA existiert nicht

Frage Microsoft

Mitglied: demokrit

demokrit (Level 1) - Jetzt verbinden

23.02.2007, aktualisiert 19.04.2007, 7047 Aufrufe, 1 Kommentar

Wie gerade mit Entsetzen feststellen musste, fehlt bei uns auf sämtlichen Rechnern (alles XP SP2) die Variable APPDATA, die leider von einer Application, die wir installieren möchten benötigt wird. Zum einen stellt sich die Frage, warum die Variable fehlt?

Zum anderen macht das Problem noch mehr Spass. Ich hab kurzerhand einen Registryeintrag geschrieben, der dann mit der Application ausgeführt und hinzugefügt wird für /HKEY_CURRENT_USER/Environment. Dort habe ich dann einen Eintrag für APPDATA = %USERPROFILE%\Anwendungsdaten erstellt. Lustigerweise kriege ich dann trotzdem keine Anzeige der Variable wenn ich ein echo %APPDATA% mache. Erst nachdem ich einmal den langen Weg über System - Umgebungsvariablen genommen habe (wo APPDATA dann übrigens auch eingetragen war) und dort über Bearbeiten die Variable nochmal 'bestätigt' habe kann ich sie über ein echo auflösen... Zumindest bis zum nächsten Neustart^^
Mitglied: demokrit
19.04.2007 um 14:56 Uhr
immer noch niemand eine Idee warum?

Die Variable fehlt hier einfach auf jedem Rechner. Wie kann das sein? Ich habe das Problem jetzt temporär gelöst, indem ich die die Variable per vb-Script über das AD beim Logon als User-Variable setze. Aber strange ist das ganze schon...
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail
gelöst Live ID im Outlook einrichten wenn die MailAdresse auch beim Provider existiert (3)

Frage von takvorian zum Thema Outlook & Mail ...

Batch & Shell
Systemvariable funktioniert im Script nicht (4)

Frage von miczar zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Installation
Eine etwas (wirklich) speziellere Frage: Windows 10-Installation über (16)

Frage von DerFurrer zum Thema Windows Installation ...

Multimedia & Zubehör
gelöst Iphone 6 prob (12)

Frage von jensgebken zum Thema Multimedia & Zubehör ...

Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (12)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...