Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Systemvariable in Batch verwenden - funktioniert nicht

Frage Entwicklung Batch & Shell

Mitglied: Deauville

Deauville (Level 1) - Jetzt verbinden

24.11.2008, aktualisiert 19:28 Uhr, 7319 Aufrufe, 12 Kommentare

Folgendes Problem:
Für eine Anwendung sind Verzeichnisse in Systemvariablen gespeichert. Nun will ich in einer Batchdatei diese Systemvariable auslesen und für einen copy-Befehl nutzen.

Diese Batchdatei habe ich bisher erstellt:


REM zeigt den Inhalt der Variable an (c:\tmp)
set wagtmp

REM soll die Datei test.txt nach C:\tmp kopieren
copy test.txt %wagtmp%



Ich erhalte immer eine Fehlermeldung, dass die Datei nicht auf sich selbst kopiert werden kann. Stimmt auch, denn in der Ausgabe von copy fehlt das Zielverzeichnis. Da sollte doch "c:\tmp" stehen???

Was läuft hier falsch? Geht das überhaupt?

Gruß Deauville
Mitglied: Bolle97
24.11.2008 um 16:38 Uhr
Hallo,

Du solltest der Variablen "wagtmp" einen Wert zuordnen, z.B. "SET wagtmp=C:\Temp".
Nur mit "set wagtmp" wird die Variable "nicht" gesetzt, also sozusagen "geleert".

Gruß René
Bitte warten ..
Mitglied: bastla
24.11.2008 um 16:41 Uhr
Hallo Deauville und willkommen im Forum!

Liefert denn die Zeile
set wagtmp
die folgende Ausgabe?
wagtemp=c:\temp
Dann wäre es tatsächlich nicht nachvollziehbar, warum in der "copy"-Zeile kein Wert für %wagtemp% vorhanden wäre - würde allerdings die Ausgabe
Die Umgebungsvariable "wagtemp" ist nicht definiert.
lauten, wäre natürlich vorweg eine Zuweisung erforderlich, also:
set "wagtemp=c:\temp"
Grüße
bastla

P.S.: Für das Posten von Code hätten wir passende Formatierungsmöglichkeiten ...
Bitte warten ..
Mitglied: bastla
24.11.2008 um 16:43 Uhr
@Bolle97

Nur mit "set wagtmp" wird die Variable "nicht" gesetzt, also sozusagen "geleert".
... stimmt nicht - es wird damit der Inhalt angezeigt; um den Inhalt zu löschen ("leeren"):
set wagtmp=
Grüße
bastla
Bitte warten ..
Mitglied: Bolle97
24.11.2008 um 16:55 Uhr
Hallo,

hoppala @bastla, hast natürlich recht.

Diese Meldung "Datei kann nicht auf sich selbst kopiert werden" erscheint wenn die Batch schon in dem Verzeichnis steht wohin eigentlich kopiert werden soll.
Also, angenommen die Variable wagtmp zeigt richtig auf "C:\tmp" und die Batchprozedur steht im Verzeichnis "C:\tmp", dann läuft das COPY auf den Fehler.

Gruß - René
Bitte warten ..
Mitglied: bastla
24.11.2008 um 16:59 Uhr
@Bolle97
Diese Meldung "Datei kann nicht auf sich selbst kopiert werden" erscheint wenn die Batch schon in dem Verzeichnis steht wohin eigentlich kopiert werden soll.
... womit Du recht hast.

Grüße
bastla
Bitte warten ..
Mitglied: Bolle97
24.11.2008 um 17:06 Uhr
Hallo,

na wenigstens ist etwas richtig.

Gruß - René
Bitte warten ..
Mitglied: Biber
24.11.2008 um 17:13 Uhr
Zitat von Bolle97:
Hallo,

na wenigstens ist etwas richtig.

Gruß - René
Na ja, da war ja sozusagen von ersten geschriebenen Wort an der Wurm drin...

Es ist ja auch keine Systemvariable....

<abduck>
Biber
Bitte warten ..
Mitglied: bastla
24.11.2008 um 17:15 Uhr
@Biber
... wobei wir ja noch nicht einmal Deauvilles System kennen ...

Grüße
bastla
Bitte warten ..
Mitglied: Biber
24.11.2008 um 17:26 Uhr
@bastla

Hmmm,

Auch wenn ich sein/ihr System nicht kenne ...
- eine Systemvariable namens wagtmp könnte höchstens von einem relativ lockeren Betriebssystem-Hersteller kommen...

Vielleicht gibt es da ja jetzt so ein neues Super-OS nur für Insider.... und die dürfen alle deswegen den Namen nicht sagen .... ist ja ein Geheimtipp....

Grüße
Biber
Bitte warten ..
Mitglied: Deauville
24.11.2008 um 18:33 Uhr
Ich glaube ich war etwas unpräzise in meinen Angaben. klar ist wagtmp keine Systemvariable, es ist eine selbst definierte Umgebungsvariable für eine Anwendung, die darüber erfahren soll, wo sich das Verzeichnis (hier beispielsweise) "tmp" tatsächlich befindet. Klappt ja auch. Jetzt will ich Updates einlesen und dieses Verzeichnis "tmp" ist auf jedem Client möglicherweise anders abgelegt, mal auf C:, mal auf D: oder sonst irgendwo.

Da war also mein Gedanke, was liegt näher, als wagtmp abzufragen?

Den Befehl

set wagtmp

wollte ich sehen, ob und was in der Variable steht. Ganz korrekt wurde dort c:\tmp ausgegeben.

Und beim copy-Befehl
01.
  copy test.txt %wagtmp% 
erscheint
  copy test.txt 
was natürlich einen Fehler gibt, da das Ziel fehlt.

Gruß Deauville

P.S. Das mit der Formatierung begreife ich nicht.
Bitte warten ..
Mitglied: Biber
24.11.2008 um 19:22 Uhr
Moin Deauville,

P.S. Das mit der Formatierung begreife ich nicht.
Kürzen wir es ab - ich editiere mal zwei Beispielzeilen in Deinem Kommentar und Du schaust es Dir an, indem Du "bearbeiten" auf Deinem letzten Kommentar drückst.

Grüße
Biber
Bitte warten ..
Mitglied: Deauville
24.11.2008 um 19:28 Uhr
Danke für die Hilfe bezgl. der Formatierung.

Gruß Deauville
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Batch & Shell
Systemvariable funktioniert im Script nicht (4)

Frage von miczar zum Thema Batch & Shell ...

Linux
LTSP: PXE Boot funktioniert nicht (16)

Frage von Fenris14 zum Thema Linux ...

Batch & Shell
Dateinamen nach Zeichnen abschneiden - Batch-Shell (9)

Frage von cberndt zum Thema Batch & Shell ...

Batch & Shell
CMD Verschlüsslung ( Batch ) (9)

Frage von clragon zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (10)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...