Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Systemvariable mit USERNAME geht nicht zu setzen bzw. wird nicht aufgelöst, nur als USER Variable

Frage Microsoft

Mitglied: Mindjogger

Mindjogger (Level 1) - Jetzt verbinden

10.09.2008, aktualisiert 11.09.2008, 9205 Aufrufe, 5 Kommentare

Das setzen einer Systemvariablem unter Verwendnung von %USERNAME% geht nicht. Suchen in der Online Hilfe und MCSE Seiten brachte kein Ergebnis

Hallo liebe Kollegen,

ich benötige eine neue System Umgebungsvariable und als Anfänger habe ich da so mein Verständnisproblem.

Name: ApplicFolder
Wert: d:\%USERNAME%

Setze ich diese als Benutzervariable, so ist das kein Problem.
Diese wird sofort umgesetzte und ist verfügbar als:
ApplicFolder=d:\Mindjogger

Setze ich diese jedoch als Systemvariable, so bekommen ich %USERNAME% als String.
Name: ApplicFolder
Wert: d:\%USERNAME%

ApplicFolder=d:\%USERNAME%

2ba8f98c973aad521d89a48b617c8cdc-clipboard01 - Klicke auf das Bild, um es zu vergrößern

Ich vermute es liegt an der Besonderheit der Variablen %USERNAME%.

Frage:
wie kann ich eine Systemweit für alle Benutzer verfügbare Variable "ApplicFolder" unter Verwendung des Login-Namens "%USERNAME% erstellen?

Danke für eure Hilfe

B.S.


PS:
Windos XP 32 bit mit SP
Mitglied: paulepank
10.09.2008 um 11:46 Uhr
Hallo Mindjogger,

das geht mit
01.
setx ApplicFolder %username% -m
Das Programm findest du z.B. im Resource Kit von W2000
EDIT:Download_Link

cu paulepank
Bitte warten ..
Mitglied: Mindjogger
10.09.2008 um 12:51 Uhr
Danke, das probiere ich gleich einmal aus.

Zum abrunden sei die Frage erlaubt:

wieso geht das nicht graphisch über die Systemeinstellung?
Bitte warten ..
Mitglied: Biber
10.09.2008 um 12:56 Uhr
wieso geht das nicht graphisch über die Systemeinstellung?
Weil es von Microsoft ist.

Spaß beiseite, die SYSTEM-Einstellungen werden ausgelesen/aufgelöst, bevor ein %USERNAME% bekannt ist.

Grüße
Biber
Bitte warten ..
Mitglied: Mindjogger
11.09.2008 um 10:08 Uhr
Danke,

nur, in einer laufenden Session (ich bin also eingeloggt) sind doch bereits alle Variablen eingelesen. Und ich bekomme auch den Usernamen ausgegeben, z.B. in einer Shell.
Bitte warten ..
Mitglied: Biber
11.09.2008 um 14:08 Uhr
Moin Mindjogger,

die SYSTEM-Einstellungen werden ausgelesen/aufgelöst, bevor ein %USERNAME% bekannt ist.

in einer laufenden Session (ich bin also eingeloggt) sind doch bereits alle Variablen eingelesen

Okay.... und wo siehst Du jetzt einen Widerspruch in unseren beiden Aussagen??

Eben weil alle SYSTEM-Variablen schon aufgelöst sind, bevor irgendetwas USER-Session-spezifisches angefasst wird (incl %USERNAME%), eben deshalb wird eine SYSTEM-Variable mit dem Wert "meinPfad\%USERNAME%" niemals zu etwas anderem aufgelöst werden können als zu "meinPfad\%USERNAME%".

Grüße
Biber
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...