Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Windows Server

GELÖST

Task wird während Ausführung abgebrochen

Mitglied: cMaster

cMaster (Level 1) - Jetzt verbinden

31.10.2009, aktualisiert 08.09.2010, 4605 Aufrufe, 14 Kommentare

Hi,

ich habe einen Rechner mit Win Home Server.

Über geplante Tasks lasse ich beim Systemstart folgende Batch-Datei ausführen, die einen Dienst nach ca. 5 min, nach Systemstart, neustarten soll:
01.
  set log=log\Dienst_hMailServer_restart.log 
02.
  echo.>>%log% 
03.
 
04.
  echo %date% %time%   Wait for MyService-Restart>>%log% 
05.
ping localhost -n 300 
06.
 
07.
  echo %date% %time%   Stop MyService>>%log% 
08.
net stop MyService 
09.
  echo %date% %time%   Start MyService>>%log% 
10.
net start MyService 
11.
  echo %date% %time%   MyService restarted>>%log%
In der bat-Datei ist kein Fehler, denn wenn ich angemeldet bin, und die bat-Datei oder den Task (der die bat-Datei startet) manuell starte, funktioniert dies Wunderbar. In meiner log-Datei steht dann folgendes:
25.10.2009 12:35:41,81 Wait for MyService-Restart
25.10.2009 12:40:59,71 Stop MyService
25.10.2009 12:41:00,34 Start MyService
25.10.2009 12:41:02,48 MyService restarted

Wenn aber niemand angemeldet ist (also bei der Ausführung beim Systemstart), funktoniert dies nicht, da schreibt er mir immer nur folgendes in meine log-Datei, weiter scheint er nicht zu kommen...
24.10.2009 7:30:56,60 Wait for MyService-Restart

Bei dem Task ist aber bei "Ausführen als..." der Administrator mit dem entsprechenden Passwort eingegeben.

Woran kann es liegen, dass der Restart des Dienstes nicht durchgeführt wird?

Schon vorab: Vielen Dank!

Gruß Stefan

Edit: evtl. Lösung: http://www.administrator.de/index.php?content=150364
Mitglied: DerWoWusste
01.11.2009 um 14:15 Uhr
Überprüf doch mal über eine mmc mit dem Dienste snapin von remote aus, ob der Dienst gestoppt und neu angeworfen wird - evtl. versagt ja nur das Logging.
Bitte warten ..
Mitglied: cMaster
01.11.2009 um 16:35 Uhr
Hi DerWoWusste,

wenn ich mich am Server abmelde, und das ganze dann von einem anderen Betriebssystem aus beobachte, muss ich folgendes feststellen: Wenn ich in geplante Tasks den Task starte, steht ca. 5 Sekunden gestartet, dran, dann scheint er wieder beendet worden zu sein... Der Dienst wird weder beendet noch wieder gestartet... Der wartet nichtmal seine Wartezeit ab...

Weiß da jemand ne Lösung für dieses Problem?

Gruß Stefan
Bitte warten ..
Mitglied: DerWoWusste
01.11.2009 um 16:38 Uhr
Fangen wir damit an, dass Du meine Rückfrage beantwortest
Bitte warten ..
Mitglied: cMaster
01.11.2009 um 17:08 Uhr
Wenn ich das von Remote beobachte, steht da in der mmc durchweg gestartet dran.
Bitte warten ..
Mitglied: DerWoWusste
01.11.2009 um 17:20 Uhr
Das liegt daran, dass das Ding nicht von alleine aktualisiert.
Setz ein paar Wartezeiten in Dein Skript (wieder mit ping) und drück dann zum rechten Zeitpunkt F5 in der mmc.
Bitte warten ..
Mitglied: cMaster
01.11.2009 um 17:34 Uhr
das hab ich, ich hab nen 60er-Ping zwischen stop und start...
anschließend starte ich den Task dann von diesem anderen Rechner aus und beobachte das mmc (klicke immer und immer wieder auf Aktualisieren)...
  • wenn niemand angemeldet ist gibt es 2 Möglichkeiten: Mglk 1) es steht 5 sec. lang gestartet dran oder Mglk 2) es steht ziehmlich genau 60 sec lang gestartet dran (trotzdem kein Erfolg)
  • wenn ich als Administrator angemeldet bin: ich sehe die Konsole und alles funktioniert, dann sehe ich auch in der Remote-mmc, dass der Dienst gestoppt wird, und dann wieder gestartet wird.
Bitte warten ..
Mitglied: DerWoWusste
01.11.2009 um 19:14 Uhr
Ein wenig mysteriös. Es darf normalerweise keinen Unterschied machen. Könnte es sein, dass Dein Dienst irgendetwas sichtbar ausführen will, also mit dem Desktop interagiert (Messages an Fenster schickt oder Ähnliches)?
Bitte warten ..
Mitglied: cMaster
01.11.2009 um 19:20 Uhr
Nein, eig. nicht. Siehst ja den Quelltext oben, mehr steht in der bat-Datei nicht drin....
Bitte warten ..
Mitglied: DerWoWusste
01.11.2009 um 19:35 Uhr
Es geht um den Dienst, nicht um Dein Skript.
Bitte warten ..
Mitglied: cMaster
01.11.2009 um 21:26 Uhr
achso, oh, Entschuldigung...
Nein, bei dem Dienst handelt es sich um den hMailServer, der is des öfteren beim Systemstart zu schnell, versucht auf die DB zu zugreifen, obwohl der MySQL noch nicht vollständig gestartet ist und hat somit keinen Erfolg, versucht es aber später kein zweites Mal. Wenn ich den dann aber nen paar Min später nochmal neustarte, läuft alles Prima.
Und das ist eig. mein Ziel.
Bitte warten ..
Mitglied: DerWoWusste
01.11.2009 um 22:22 Uhr
Beherrscht der Home Server bei den Diensten evtl. genau wie 2008 die Startart "Automatisch - verzögerter Start"?
Bitte warten ..
Mitglied: cMaster
01.11.2009 um 22:47 Uhr
Nein, leider nicht. Der HS baut aufm Kern vom Server 2003 auf...
Bitte warten ..
Mitglied: DerWoWusste
01.11.2009 um 22:58 Uhr
Teste das Ganze nochmal mit einem unkritischen Systemdienst und mach kein dolles Skript sonder nur net start dienstname alle 20 Sekunden. Dann überwach wieder mit der Remote mmc und schalte den Dienst von dort aus ab und zu ab um zu sehen, ob er wieder angeworfen wird.
Bitte warten ..
Mitglied: cMaster
03.11.2009 um 00:46 Uhr
Hi,

ich habe das ganze jetzt mal folgendermaßen getestet:

Hab das mit dem Dienst "wuauserv" (Automatisches Update) getestet, weil der keinerlei Abhängigkeiten hat.

der Quellcode der bat-Datei:
01.
net start wuauserv 
02.
 
03.
ping localhost -n 60 
04.
net start wuauserv 
05.
 
06.
ping localhost -n 60 
07.
net start wuauserv 
08.
 
09.
ping localhost -n 60 
10.
net start wuauserv 
11.
 
12.
ping localhost -n 60 
13.
net start wuauserv
  • wenn Administrator angemeldet ist, funktioniert alles wunderbar

  • wenn niemand angemeldet ist:
    • ich stoppe den Dienst
    • starte Task => 1. Befehl (Dienst-Start) wird ausgeführt => Dienst läuft wieder
    • erneutes stoppen des Dienstes (Task läuft noch)
    • Task wird/beendet sich => spätestens nach 55 sec, meistens frühestens nach ca. 35 sec => zum erneuten Start des Dienstes kommt es nicht mehr
    • wenn ich als ersten Befehl in das Script den Ping setze => Task wird beendet, bevor Wartezeit rum is
      • wenn ich allerdings eine Wartezeit von 20 sec an den Anfang setze, kann danach der Dienst noch gestartet werden, und dann wird der Task erst bei der 2. Wartezeit unterbrochen


Also für mich ist die ganze Sache höchst unverständlich und nicht nachvollzeihbar !?
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Powershell-Script über Task Scheduler zeigt CMD während Ausführung
Frage von DanielBodenseeBatch & Shell5 Kommentare

Hallo zusammen, ich habe eine Frage die nicht direkt mit Powershell zu tun hat :-) Über den Task Scheduler ...

Windows 10
Nutzer zur Ausführung von fremden Tasks berechtigen - Windows 10 kann es offenbar nicht
Frage von DerWoWussteWindows 1021 Kommentare

Hi. Mir scheint, ich bin auf einen weiteren Bug gestoßen: Ich arbeite in der Administration sehr häufig mit Tasks. ...

Batch & Shell
Probleme bei der Ausführung eines VB-Scriptes
Frage von AuricGoldfingerBatch & Shell1 Kommentar

Hallo zusammen, ich habe folgendes Script geschrieben: Leider bekomme ich bei der Ausführung den Fehler Was mache ich falsch?? ...

Server-Hardware
Server-Schrank - Kunststoff-Teil abgebrochen
gelöst Frage von JanomineServer-Hardware11 Kommentare

Hallo Community, mir ist beim Transport unseres Racks ein kleiner Kunststoff Bügel abgebrochen, scheint nicht weiter schlimm zu sein, ...

Neue Wissensbeiträge
Microsoft

Letzte Updates für Win10 und Server2016 müssen bei Bedarf über den Update catalogue in den WSUS importiert werden!

Tipp von DerWoWusste vor 4 StundenMicrosoft1 Kommentar

automatisch kommt da nichts an im WSUS und auch nicht im SCCM. Siehe Hinweise zum Bezug der jeweils neuesten ...

Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 3 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 3 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 TagenSicherheit13 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen10 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS10 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Windows Netzwerk
Ist ein Portforwarding auf einen PC ohne lauschendes Programm ein (großes) Sicherheitsproblem?
Frage von PluwimWindows Netzwerk9 Kommentare

Hallo zusammen, zur Fernwartung eines Rechners an einem anderen Ort nutze ich VNC. Da dieser Rechner einfach nur eine ...

Windows Netzwerk
Zugriff auf den Desktop Ordner eines anderen Rechners in der gleichen Domäne
gelöst Frage von JensNomaWindows Netzwerk6 Kommentare

Guten Abend, ich war neulich mit unserem Admin am Tisch gesessen. Er an seinem Notebook angemeldet mit dem Domänen-Admin, ...