Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

TCP-Fehler - Dateitransfer langsam

Frage Netzwerke

Mitglied: ReiniX

ReiniX (Level 1) - Jetzt verbinden

17.01.2010 um 22:27 Uhr, 10308 Aufrufe, 5 Kommentare

Nabend,

ich mache grade eine Ausildung zum Fachinformatiker und kämpfe da mit einem sehr seltsamen effekt in einem kleinen Testnetz:

Ich habe jweils einen
- Windows 2008 Server (nicht R2 aber SP2, 64Bit)
- Windows XP SP 3 Client (32bit)
- Windows 7 Client (64Bit, Updates aktuell)

Alle sind über einen 10/100Mbit switch miteinander verbunden
Am server ist eine freigabe eingerichtet
Nun versuche ich eine Testdatei (XPSP3, ca 300mb) aus dieser freigabe auf die clients zu kopieren.
Das Kopierfenster erzählt mir etwas von ganz kuriosen zeiten mit 42minuten oder länger.

Ich habe bereits einen anderen switch versucht, andere kabel genommen, andere clients genommen: kein unetrschied
Wenn ich die datei auf freigaben zwischen den clients kopiere geht das in einer zeit von weniger als einer minute!!!!

Meine Schlussfolgerung: Problem mit dem Serverrechner.
Oder sehr ihr das falsch?


jedenfalls habe ich gerade wireshark auf dem server installiert

dort sah ich erst ganz viele fehler hauptsächlich in SMB - aber auch in TCP paketen: Header Checksum Incorect (also der fehler war ein paar schichten weiter unten im IP protokoll)
Deswegen habe ich einen registrywert gesetzt: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters\DisableTaskOffload = 1

Nun sind die Checksumfehler zwar nicht mehr da aber es kommen meldungen wie
- This frame is a (suspected) out-of-order segment
- Duplicate to the ACK in frame: 6857
- This frame is a (suspected) fast retransmission
wenn ich über freigaben dateien kopiere

Das hat doch sicher etwas mit meinem problem zu tun? Gut ist sowas doch wohl nicht, oder?
Wenn ich zwischen den clients kopiere und mit wireshark mitschneide erhalte ich keine solche meldungen.

Ich bin gerade echt ratlos und hoffe ihr könnt mir helfen.



Ein paar weitere informationen:
- Server sollte aktuelle windowsupdates haben
- Server wurde des öfteren neu gestartet
- Ich habe glaube ich nichts an der konfiguration geändert bevor ich das problem bemerkte
- Der server hat ein asus "p5q-vm do" mainboard mit einem intel core2quad prozessor

Ich hoffe jemand hat eine idee...
Mitglied: 84544
17.01.2010 um 22:59 Uhr
Kannst ja mal die Netzwerkkarte tauschen (oder eine 2 einbauen).

Anbei: Macht der Rechner auch mit dem Internet solche Macken? Lauft ja auch über TCP

Ansonsten wurde ich die Prozesse mal checken und mal im Internet suchen ob diese Konstellation nicht Schuld ist.... obwohl es eigentlich laufen sollte.
Bitte warten ..
Mitglied: datasearch
17.01.2010 um 23:01 Uhr
Hallo ReiniX,

das Wireshark bei aktiven Offload-Features deiner Netzwerkkarten Fehler meldet ist nichts ungewöhnliches. Wireshark "hängt" hinter dem eigentlichem Treiber und logischerweise auch über der Physik. Karten mit diversen Offload-Engines haben diese in Hardware, also fest verdratet, on Board. Der Treiber aktiviert diese dann nur noch bei Bedarf.
Das ganze soll die CPU und das Betriebssystem beim berechnen der Prüfsummen (Checksum-Offload), bearbeiten großer Segmente (Large Segment Offload) oder weiteren Dingen entlasten. Alles halb so wild.

Duplicate Acks sind weniger erfreulich. Welche Hardware verwendest du? Sind du "dups" ehr zufällig oder treten sie nach einem Schema auf? Wenn du den Server anpingst, siehst du in Wireshark duplizierte "Echo Replys" oder mehrere "ECHO Requests"? Oder funktioniert ICMP normal?

Gelegentlich kann es vorkommen das Offload-Engines nicht richtig arbeiten. Bei HP hatte ich schon öfter das Problem das nach einem Update irgend eine der Offload-Engines nicht mehr richtig funktioniert. In der Regel hilft hier ein Firmware-Update.
Bitte warten ..
Mitglied: dog
18.01.2010 um 00:01 Uhr
Wenn es ein mangebarer Switch ist würde ich erstmal die Error-Counter auslesen und dann einen unabhängigen Rechner für Wireshark nehmen und dort Port Mirroring aktivieren...
Bitte warten ..
Mitglied: ReiniX
18.01.2010 um 08:45 Uhr
- Internet habe ich noch nicht mitgeschnitten
- Es ist kein managebarer Switch (beide switche sind relativ billige switche für den Hausgebrauch)

werde heute abend mal ein treiber & firmwareupgrade versuchen und berichten
Bitte warten ..
Mitglied: ReiniX
18.01.2010 um 22:57 Uhr
Treiberupdate hat die Probleme behoben! - Danke!!!
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Windows Server 2016 RDS extrem langsam nach Neustart (6)

Frage von jojo0411 zum Thema Windows Server ...

Microsoft Office
Outlook 2016 Fehler Link einfügen

Frage von Florian86 zum Thema Microsoft Office ...

Windows 7
PC fährt langsam herunter, hängt sich manchmal dabei auf (4)

Frage von SarekHL zum Thema Windows 7 ...

Neue Wissensbeiträge
Administrator.de Feedback

Umgangsformen auf der Seite

(7)

Information von Frank zum Thema Administrator.de Feedback ...

Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(11)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Windows Server
Windows Server Komplettspiegelung (13)

Frage von pdiddo zum Thema Windows Server ...

Windows Server
Windows Server 2016 RDS Remoteapp Anzeigefehler (11)

Frage von qlnGenius zum Thema Windows Server ...