Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

TELNET SMTP-Mailversand Problem mit AUTH LOGIN

Frage Internet

Mitglied: CLU

CLU (Level 1) - Jetzt verbinden

03.02.2006, aktualisiert 08.02.2006, 31619 Aufrufe, 6 Kommentare

Ich versuche mit TELNET ein Mail zu senden, aber ich scheitere bei AUTH LOGIN!

Hallo,

mir muß mal jemand auf die Sprünge helfen:
Ich versuche mit TELNET ein Mail zu senden, aber ich scheitere bei AUTH LOGIN!

Beispiel:
User: erika.mustermann@web.de
Password: 12345

TELNET SMTP.web.de 25
Verbindungsaufbau klappt!

HELO klappt auch
EHLO klappt auch

AUTH LOGIN klappt nicht! Ich übergebe jeweils einzeln und nach BASE64 verschlüsselt meinen Benutzer und Passwort.
Ich bekomme aber immer nur "incorrect user or password"!

was mache ich falsch?
Mitglied: filippg
03.02.2006 um 19:36 Uhr
Hallo,

vielleicht erwartet ja der Server einfach keine Base64-Encodierung? Die zulässigen Codierungen sollte er idealerweise als Antwort auf EHLO senden.
Ansonsten ist deine Fehlerbeschreibung etwas unspezifisch, sende doch mal ein Sitzungsprotokoll.

Filipp
Bitte warten ..
Mitglied: CLU
08.02.2006 um 12:07 Uhr
Hier das Sitzungsprotokoll:

221 2.0.0 {mp012} GMX Mailservices
220 {mp020} GMX Mailservices ESMTP
EHLO erika.mustermann@gmx.de
250-{mp020} GMX Mailservices
250-8BITMIME
250-ENHANCEDSTATUSCODES
250-AUTH=LOGIN CRAM-MD5 PLAIN
250-AUTH CRAM-MD5 LOGIN PLAIN
250 STARTTLS
AUTH login
334 VXNlcm5hbWU6
***=
334 UGFzc3dvcmQ6
MTIZNDU=
535 5.7.0 {mp020} Incorrect username or password
Bitte warten ..
Mitglied: filippg
08.02.2006 um 13:55 Uhr
Hallo,

also bei mir funktioniert das einwandfrei:

220 {mp030} GMX Mailservices ESMTP
EHLO xxxxxxxx
250-{mp030} GMX Mailservices
250-8BITMIME
250-ENHANCEDSTATUSCODES
250-AUTH=LOGIN CRAM-MD5 PLAIN
250-AUTH CRAM-MD5 LOGIN PLAIN
250 STARTTLS
AUTH LOGIN
334 VXNlcm5hbWU6
xxxxxxxx
334 UGFzc3dvcmQ6
xxxxxxxx
235 2.7.0 {mp030} Go ahead

Ich gehe mal davon aus, dass du Nutzer und Passwort vor dem Posten extra geändert hast, aber vielleicht solltest du das einfach nochmal testen. Ich habe das Tool unter http://www.patshaping.de/projekte/kleinkram/base64.php genommen.
Daneben kann man bei GMX unter E-Mail -> Optionen -> Sicherheit noch Einstellungen zur SMTP-Sicherheit machen, aber auth-login sollte immer funktionieren.

Filipp


Edit: Was mir gerade aufgefallen ist: Originalposting bezog sich auf Web.de, jetzt ist von GMX die Rede, was ist es denn nun? Übrigens: Web.de lässt dich, wenn du kein Club-Mitglied bist nur alle 15min deine eMails abrufen. Das führt auch häufig zu Fehlern, allerdings gibt Web.de afaik wenigstens eine entsprechende Fehlermeldung (und nicht einfach login incorrect).
Bitte warten ..
Mitglied: CLU
08.02.2006 um 14:24 Uhr
Hallo,

bei mir klappt es leider immer noch nicht.
Per Web-Front-End kann ich problemlos Mails verschicken.

Frage zu AUTH LOGIN:
Welche der folgenden "identischen" User muß ich nach BASE64 verschlüsseln und dann bei AUTH LOGIN übergeben:

erika.mustermann@gmx.de ?
erika.mustermann ?
GMX-Kundennummer?

Sorry für die Verwirrung mit GMX.DE und WEB.DE: Ich brauche eine Lösung für GMX.DE! WEB.DE habe ich zum vergleichen genutzt.

Gruss CLU
Bitte warten ..
Mitglied: filippg
08.02.2006 um 14:54 Uhr
Hallo,

ja, das hätte ich noch erwähnen sollen: ich habe die komplette eMail-Adresse genommen (mit @gmx.???), gmx selber schreibt allerdings was von Kundennummer.

Filipp
Bitte warten ..
Mitglied: CLU
08.02.2006 um 15:28 Uhr
Hallo,

also ich habe das Ganze nochmal aus einer DOS-Box gemacht:
Dort klappt AUTH LOGON !
Ich habe das vorher immer mit einem Tool namens SMTP-Explorer gemacht.
Wo da der Unterschied liegt, weiß ich leider nicht.
Vielleicht "klatscht" der bei der Übergabe der verschlüsselten Eingaben noch ein Enter mehr rein oder so. EGAL!

In der guten alten DOS-Box lauft alles!
Und das reicht mir auch!
Dann tippe ich halt auf command-line weiter...

Vielen Dank an Filipp für die freundliche technische Unterstützung und die Hinweise.

Gruss CLU
Bitte warten ..
Ähnliche Inhalte
Linux Netzwerk
Mailversand ohne Auth möglich - dringend Hilfe
gelöst Frage von mexxLinux Netzwerk4 Kommentare

Hallo, ich brauche dringend Hilfe, weil ich seit Wochen nicht weiter komme. Ich habe die DS1813+ mit der aktuellsten ...

Batch & Shell
Automatischer Login per Telnet
Frage von 121851Batch & Shell6 Kommentare

Hallo zusammen, ich habe folgendes Problem. Erstmal bin ich nicht so fit was Programmieren angeht. Gibt es eine möglichkeit ...

iOS
IOS SMTP-Mailversand nicht möglich
gelöst Frage von saschagiOS3 Kommentare

Hallo zusammen, ich habe ein Problem mit dem Mailversand auf einem IPhone 5 (9.2) und iPad gleichermaßen. Die Mailadresse ...

Debian
Zarafa smtp-auth via CRAM-MD5
Frage von zwirniDebian1 Kommentar

Hallo zusammen, nach tagelangen Kopfzerbrechen möchte ich mich nun an die Admin Kollegen wenden. Mein Mailservers läuft auf Debian ...

Neue Wissensbeiträge
Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 2 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit7 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...