Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Terminalserver Last durch einfache Anwendungen

Frage Microsoft Windows Server

Mitglied: Namewarvergeben

Namewarvergeben (Level 1) - Jetzt verbinden

29.10.2013, aktualisiert 07.11.2013, 3527 Aufrufe, 7 Kommentare

Hallo,

System:
Server 2008 Standard 64-Bit
Terminal Services installiert, sonst keine Dienste.

ich habe seit ca. 2 Wochen einen Server 2008 (kein R2) als Testsystem laufen.
Immer wenn ich ein paar User auf diesem System arbeiten lasse gibt es Lastspitzen von Bis zu 30% durch eine einzelne Anwendung eines Benutzers.
Am häufigsten fallen mir Microsoft Office und Mozilla Firefox, sowie der Adobe Reader auf.
Diese Maschine läuft wie die Produktivumgebung auf dem selben Hyper-V Server.
Ich kann keinerlei Einträge in der Ereignisanzeige oder Unauffälligkeiten im Ressourcenmonitor sehen, bis auf die hohe CPU Last.
Auch vom Update stand der beiden Systeme gibt es keine mir auffallenden Unterschiede.

Das deaktivieren von Add-On´s im Outlook oder Firefox brachte auch keine Erfolge.
Das einzig auffallende besteht darin, dass es 32-Bit Anwendungen sind, die diese Last verursachen.

Grüsse
Martin



Mitglied: Mantigul
29.10.2013 um 08:59 Uhr
Hallo,

Bitte gib uns mal grundlegende Daten zu dem Hyper-V Server sowie dem Test-Server. Leistung, RAM, Prozessor,.....
Was ist dem Server zugewiesen? Was läuft sonst noch auf dem Hyper-V? Ist der ausgelastet?
Bitte warten ..
Mitglied: DerWoWusste
29.10.2013 um 09:02 Uhr
Moin.

Beschreibe näher, was Dich beunruhigt und wie diese Lastspitzen aussehen. Gib zudem nötige Randinfos wie Anzahl der CPU-Kerne.
Mit x86/x64 hat das nichts zu tun.
Bitte warten ..
Mitglied: Namewarvergeben
08.11.2013 um 07:49 Uhr
Hallo,

entschuldigt die lange Wartezeit.
Also weitere Daten zum System:

Fuji RX200 S6 Server mit Windows Server 2012 R2 Standard als Hyper-V

- 2x Xeon 8 Threads
- 64GB Arbeitsspeicher
- 4x300GB RAID 5 SAS lokal Storage

virtueller Terminal Testumgebung Windows Server 2008 Standard

- 4 CPUs zugewiesen
- 32GB RAM
- 100GB HDD zugewiesen

Wie sehen die Lastspitzen aus:

Also die Lastspitzen an sich treten auf sobald man mehrere User angemeldet hat die mit Programmen wie Adobe Reader, Outlook und Firefox arbeiten.
Die Auslastung des Prozesses im Taskmanager auf dem Terminal geht dann pro User auf 20-30% warum auch immer.
Des weiteren habe ich nachdem Anmelden der Benutzer häufig 25% CPU-Last auf dem Spooler, auch nach der Benutzerabmeldung. Da bin ich mir auch unsicher wo das Problem herkommt.

Grüsse
Martin
Bitte warten ..
Mitglied: DerWoWusste
08.11.2013 um 09:35 Uhr
Ok, wie die Spitzen aussehen, hast Du beschrieben, nicht aber, was Dich daran beunruhigt, welche (negativen?) Auswirkungen es also auf den Betrieb hat.
Zum Spooler: wenn bei der Anmeldung die Drucker der Clientsitzung mitgenommen werden (ist das der Fall?), dann hat der eine Zeit lang zu tun, das ist normal. Ebenso kann dies auftreten, wenn auf dem Userobjekt eine Policy greift, welche freigegebene Netzwerkdrucker verbindet.
Zum Rest:
Also die Lastspitzen an sich treten auf sobald man mehrere User angemeldet hat die mit Programmen wie Adobe Reader, Outlook und Firefox arbeiten.
Wenn nur ein Nutzer angemeldet ist, kommen diese Spitzen nie?
Bitte warten ..
Mitglied: Namewarvergeben
08.11.2013, aktualisiert um 11:48 Uhr
Direkte Störungen gibt es im Betrieb noch nicht.
Die Last tritt auch auf wenn nur ein User auf dem System arbeitet.

Trotzdem finde ich es ungewöhnlich, dass einzelne Anwendungen "so viel CPU Last" verursachen.
Das Problem mit dem Spooler war schon mal schlimmer, als ich die Drucker von meinem Druckserver jedem User per GPO zugewiesen habe, hatte ich das Problem, dass der Spooler 100% CPU Last verursachte. Dann ging erstmal gar nichts mehr.
Jetzt sind die Drucker lokal Installiert.
Feststellen musste ich, dass es noch vereinzelt Netzwerkdrucker Leichen gibt von Leuten die erst jetzt aus dem Urlaub wiedergekommen sind.
Ich denke, dass sich dieses Problem löst, wenn alle Netzwerkdrucker von dem Script mit con2prt gelöscht wurden sind und nur noch die lokal installierten da sind.

Was ich heute noch feststellen musste ist, dass anscheinend die i/o Performance des Servers nicht ganz stimmt. Ich werde mal ein paar Tests auf dem System durchführen.
Was mich darauf bringt, das bei mehreren Usern auf dem System bis zu 30000 pages/s gelesen/geschrieben werden.

Grüsse
Martin
Bitte warten ..
Mitglied: ymieb1992
26.08.2014 um 11:18 Uhr
Hallo,

wir haben bei uns das gleiche Problem. Auf den beiden TS kommt es immer mal wieder vor, dass einzelne Prozesse von einzelnen Usern (z.B. AdobeReader oder iexplorer) mal eben 25% (ich hatte auch schon mal 80%) der CPU eine TS auslasten. Ich habe dies einige Zeit beobachtet und sofern ich den Prozess nicht beende, bleibt die Auslastung so gut wie konstant (+- 1-2%). Gehe ich dann zu dem Mitarbeiter und Frage was er oder sie denn mache bzw. wie viele PDF Dokumente geöffnet sind, bekomme ich die Rückmeldung 1 Dokument, dann waren es mal 2 Dokumente und diese nur mit 1-2 Seiten, keine großen Grafiken und auch wurden keine Updates etc. gefahren. Beende ich den Prozess und öffne die selben Dokumente oder Internetseiten, bleibt die Auslastung normal und der TS liegt wieder bei maximal 10%. Das Problem was hier dann auftritt, ist, dass dadurch hin und wieder eine Spitze ausgelöst wird und alle Sitzungen, die über den jeweiligen TS laufen hängen.

Habt ihr eine Lösung oder eine Idee woran das liegen könnte?


Danke.

PS: ind täglich so ca. 40 Sitzungen welche auf 2 TS verteilt sind Normalauslastung der Gesamten CPU des einzelnen TS liegt um die 10%.
Bitte warten ..
Mitglied: DerWoWusste
26.08.2014 um 12:15 Uhr
Moin.

Erstelle einen eigenen Thread, ist immer besser, als einen ähnlichen alten aufzuwärmen.
Du must reproduzierbare Vorgänge haben, sonst kann niemand etwas diagnostizieren, das sollte klar sein.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Hardware
gelöst Servergehäusenetzteile zischen, wenn nicht unter Last - normal? (5)

Frage von DerWoWusste zum Thema Hardware ...

Outlook & Mail
Fehlermeldung beim schließen von Outlook 2016 auf Terminalserver (7)

Frage von Tommy1983 zum Thema Outlook & Mail ...

Windows Server
Terminalserver 2008R2 und Exchange 2016 CU2 (3)

Frage von anak1m zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (12)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...