Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

THEMA: Web Folders (HTTPS WebDAV) unter Vista?

Frage Microsoft Windows Vista

Mitglied: Plominski

Plominski (Level 1) - Jetzt verbinden

12.01.2007, aktualisiert 22.10.2007, 26666 Aufrufe, 7 Kommentare

Grüße

es funktioniert das einfügen (web folder) einer Netzwerkressource: SharePoint sowie WebDAV nicht, hat jemand ein Tipp dies unter Vista freizuschalten?

Mit freundlichen Grüßen
Mitglied: Plominski
14.01.2007 um 14:24 Uhr
Unter Windows Vista "Windows Mail" Microsoft Communities MSNEWS Server
--- microsoft.public.windows.vista.general
--- --- WebDav question von Jeremy Dennis

Zitat: I've tried connecting to our WebDAV server as I had in XP through adding a
network place, but after I enter the URL I get an error that states "the
folder you entered is invalid." If I map the drive either on the commandline
or through the GUI it works. Is this how WebDAV is connected now?
Thanks,
Jeremy Dennis

---

Antwort: Ather Haleem (MSFT)

Hi Jeremy,
"Add a Network Place" should work for WebDAV resources as well. Are you
entering the resource using the http:// name or the UNC (prefixed with \\)
name?
Also, are you running a pre-RTM version of Vista? There was an issue with
"add a network place" wizard in RC2 that we fixed in RTM.

thanks
-Ather Haleem
lead sdet | core file systems | microsoft corporation

---

Antwort: Mark

Hi Ather,

Thanks for your response but we continue to have WebDAV problems here at a
major university which uses https secured WebDAV in combination with an
eLearning tool We are using the RTM version of Vista with no success in
accessing the resource.

The WebDAV resource was able to be successfully added as a Web Folder
utilizing machines with Win XP and IE6 all recent patches. No changes to the
testing resource user name or password has occurred. All attempts to add
WebDAV functionality have failedwithin Vista. We have tried the following:

-Method 1: Accessing the WebDAV resource within IE. Result: Unsuccessful.
IE attempts to authenticate and then displays this error message: "Internet
Explorer could not open <https://...> as a web Folder. Would you like to see
its default view instead?". Clicking yes to this question renders a page
that only displays the root folder of the resource as an HTML document.

-Method 2: Add the WebDAV resource from within the "Add Network Location"
wizard. Result: Unsuccessful. No prompt to authenticate and response
displayed was the following error message: The folder you entered does not
appear to be valid. Please choose another"

-Method 3: Add the WebDAV resource using a Privileged Command Prompt and
the "net use" command. Result: Unsuccessful. Attempts to authenticate then
displays this error message: "System Error 5: Access is denied".
Infrequently will respond with the error message: "System Error 67 has
occured: The netowrk name cannot be found".

So far we have had no luck. Can you advise as to how we should proceed?

Thanks!
Mark

---

Antwort: Mark

Hi Ather,

After writing my previous post I read additional posts and now understand
that the root of the problem seems to be the lack of the inclusion of the
WebFolders client within Vista.

The WebDAV redirector client would not be compatible with the design of the
site in question as particular users may not be able to be given access to
the root of the site. Since this is the case, is there a way to install the
WebFolders client in Vista?

Please feel free to clarify if you feel that this summation is inaccurate.

Thanks!
Mark
Bitte warten ..
Mitglied: Plominski
14.01.2007 um 14:47 Uhr
Antwort aus "WEBDAV and Vista" von dak

Zitat: Ather Haleem (MSFT)

the problem in your case is that this site has a weak authentication
mechanism (Basic Auth) which is disabled by default on Windows Vista in order
to make Vista more secure. With Basic Auth, your username and password is
sent in clear text over the wire hence anyone sniffing the network traffic
can find out your password.

If possible, please have your website administrator change the
authentication type to something stronger (e.g. NTLM, Passport or Kerberos)
OR move to a SSL website (i.e. https://). Note that Basic Auth IS turned on
by default for SSL traffic.

If you really don't care about others finding your password AND you don't
have any sensitive data on this website, you can go ahead and enable Basic
Auth for non-ssl via the following registry key:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters "BasicAuthLevel" (REG_DWORD)

the default value of this key is 1. Changing it to 2 and rebooting the
system will make your scenario work.

Note that I HIGHLY discourage you to change this registry key due to
security reasons. Also, if you are not used to playing around with registry
keys, I wouldn't recommend doing this since if you happen to touch some wrong
registry key, you might make your system unstable.

Thanks
-Ather
Bitte warten ..
Mitglied: akk
31.01.2007 um 09:46 Uhr
Hab des ganze bei mir wie hier beschrieben gelöst: schnell und schmerzfrei ohne Registry-Hack...

http://www.schiller.cc/blog/2007/01/29/bug-in-vistas-webdav-implementat ...
Bitte warten ..
Mitglied: chris75
26.02.2007 um 17:20 Uhr
Hallo,
leider funktioniert das auch nicht. Ich habe ebenso alles probiert. Ich verstehe es auch nicht ganz, da Kollegen von mir die gleiche Version (Mehrfachlizenz) nutzen und keine Probleme haben.

Folgende Varianten wurden ausprobiert (leider ohne Erfolg):

1. IE - als webordner öffnen
2. net use * \\ip@ssl\freigabename
3. die "akk"-methode
4. netdrive
5. webdrive
6. ändern der authentifizierung in den richtlinien

Das Problem besteht also nachwievor - vielleicht hat hier jemand noch eine pffifige Idee?

Danke und LG Chris
Bitte warten ..
Mitglied: WebEyE
31.05.2007 um 22:49 Uhr
Hallo,
leider funktioniert das auch nicht. Ich habe
ebenso alles probiert. Ich verstehe es auch
nicht ganz, da Kollegen von mir die gleiche
Version (Mehrfachlizenz) nutzen und keine
Probleme haben.

Folgende Varianten wurden ausprobiert
(leider ohne Erfolg):

1. IE - als webordner öffnen
2. net use * \\ip@ssl\freigabename
3. die "akk"-methode
4. netdrive
5. webdrive
6. ändern der authentifizierung in den
richtlinien

Das Problem besteht also nachwievor -
vielleicht hat hier jemand noch eine pffifige
Idee?

Danke und LG Chris

Habe die exakt gleichen Probleme und ebenfalls noch keine brauchbare Lösung gefunden? Hat hier jemand inzwischen weitere Lösungswege gefunden?
Wäre sehr dankbar. Ohne Webfolder ist Vista für mich unbrauchbar.
Bitte warten ..
Mitglied: chris75
22.10.2007 um 15:30 Uhr
Hi,
anscheinend hilft nur "ein wenig" das strikte Umstellen des Servers auf "Basisauthentifizierung". Ein weiteres Problem scheint die eingebaute Dateigrößen-Beschränkung des IIS zu sein. Selbst ein update auf Windows 2003 R2 und Vista SP1 half nicht wirklich weiter...

So long

Chris
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Verschlüsselung & Zertifikate
HTTPS is not a magic bullet for Web security (3)

Link von ticuta1 zum Thema Verschlüsselung & Zertifikate ...

Windows Vista
gelöst Vista Home Premium nur Basic Key (8)

Frage von Chonta zum Thema Windows Vista ...

Windows Server
Google Chrome Web Store Problem auf Terminal Farm

Frage von dakoerry zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...