Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Thinstation mit Openvpn funktioniert nicht

Frage Linux Linux Netzwerk

Mitglied: bollerbirne

bollerbirne (Level 1) - Jetzt verbinden

08.05.2010 um 21:11 Uhr, 3674 Aufrufe

Zum Einsatz kommt Thinstation-2.2.2d. Gebootet wird von CF-Karte. thinstation.conf.user wird problemlos eingelesen.

Hallo liebe Linuxfreunde,

ich beiße mir schon seit ein paar Tagen die Zähne an Thinstation aus. Mit stehen Windows XP Embedded als auch Thinstation Clients zur Verfügung. Vor ein paar Tagen habe ich auf einem XP-Emb. openvpn eingerichtet und war von den Möglichkeiten sofort begeistert (Aussenstellenanbindung etc.) Voller Freude habe ich im Thinstation Paket auch ein openvpn Client gefunden. Also aktiviert, config angepasst und build eingegeben. Aber Pustekuchen Ich bin den Standartweg gegangen und habe mir aus /conf/openvpn.conf.sample folgendes rauskopiert und in die thinstation.conf.buildtime (oder in thinstation.conf.user) eingetragen:
01.
# Thinstation config: 
02.
OPENVPN_SERVER="123.123.123.123" 
03.
OPENVPN_PORT="1195" 
04.
OPENVPN_PROTO="udp" 
05.
 
06.
# OpenVPN server config: 
07.
dev tap 
08.
server 10.8.0.0 255.255.255.0 
09.
push "route 192.168.17.0 255.255.255.0" 
10.
keepalive 10 60 
11.
# dh /etc/openvpn/dh.pem 
12.
#pkcs12 /etc/openvpn/server.p12 
13.
#persist-tun 
14.
# persist-key 
15.
#keysize 256 
16.
# comp-lzo 
17.
#verb 3
Leider bekomme ich folgende Fehlermeldungen (egal in welcher config ich die Einträge mache):
01.
/etc/rc0.d/S05network: /etc/thinstation.user: 337: dev: not found 
02.
/etc/rc0.d/S05network: /etc/thinstation.user: 338: server: not found 
03.
/etc/rc0.d/S05network: /etc/thinstation.user: 339: push: not found 
04.
/etc/rc0.d/S05network: /etc/thinstation.user: 340: keepalive: not found
ich denke das ich einen Denkfehler habe. Alle Configs sind ja nach dem Motto Variable=Wert aufgebaut. Nur bei dev, server, push ... nicht. Darf ich diese Werte nicht einfach so ausklammern? Muss ich sie evtl. mit in eine andere Zeile schreiben?

Was mich noch stutzig gemacht hat. Die /etc/init.d/openvpn war die einzige Datei die nicht ausführbar war sodass ich beim booten anfangs 'permission denied' Meldungen hatte. Das hatte ich bis ich vor dem 'build' die '/packages/openvpn/etc/init.d/openvpn' ausführbar gemacht habe. Ob das richtig ist weiß ich allerdings auch nicht?

Benutzt hier jemand Thinstation mit openvpn und kann mir einen Denkanstoß geben?

Viele Grüße, der langsam verzweifelnde Henne
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Netzwerk
OpenVPN als Service funktioniert nicht! (6)

Frage von mike7050 zum Thema Windows Netzwerk ...

Netzwerke
gelöst Ping zu Windows Server funktioniert im OpenVPN netz nicht (5)

Frage von ketanest112 zum Thema Netzwerke ...

Netzwerkprotokolle
gelöst OpenVPN selbe config funktioniert an einem Rechner nicht (4)

Frage von PharIT zum Thema Netzwerkprotokolle ...

Router & Routing
Transparenter Proxy funktioniert nicht? (1)

Frage von mrserious73 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...