Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

TLS Versand über 1und1 Smarthost

Frage Microsoft Exchange Server

Mitglied: l4k3k3m4n

l4k3k3m4n (Level 1) - Jetzt verbinden

28.02.2014 um 15:57 Uhr, 7585 Aufrufe, 12 Kommentare

Guten Tag,

unser Exchange 2010 nutzt smtp.1und1.de als Smarthost zum versenden von Emails.
Der Versnad soll jetzt über TLS erfolgen.

Dazu setze ich im Sendeconnector bei der Smarthost-Authentifizierung einen Haken bei "Standardauthentifizierung über TLS".

Ab diesem Zeitpunkt ist Mailversand nicht mehr möglich. Folgende Fehlermeldung in der Warteschlange:

451 4.4.0 Primary target IP adress responded with: "454 4.7.5 Certificate validation failure. "Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

Welches Zertifikat wird hier geprüft und ist fehlerhaft? Eigentlich sollte es sich ja um das von 1und1 handeln?


Habe ich etwas übersehen?

Danke!
Mitglied: Dani
28.02.2014 um 16:31 Uhr
Moin,
siehe hier um deine Einstellungen abzugeleichen.


Grüße,
Dani
Bitte warten ..
Mitglied: Rolf-Hanka.ITD
28.02.2014 um 16:49 Uhr
Hey es reicht nicht einfach auf TLS zu klicken. Du musst manuell via Shell den Port für den Connector ändern.
Bitte warten ..
Mitglied: colinardo
28.02.2014, aktualisiert um 16:53 Uhr
Hallo,
dann hast du vermutlich entweder ein internes selbst-signiertes Zertifikat dem SMTP-Dienst zugeordnet (Serverkonfiguration > Exchange-Zertifikate),
oder euer Server gibt sich bei aktivem Zertifikat auf dem SMTP mit einem Namen (im HELO) beim 1und1 bekannt der nicht mit dem Common-Name auf eurem gültigen Zertifikat übereinstimmt.

4c90e8d6186c2afd1a9e2df8c7ea7900 - Klicke auf das Bild, um es zu vergrößern

Grüße Uwe
Bitte warten ..
Mitglied: colinardo
28.02.2014, aktualisiert um 16:53 Uhr
Zitat von Rolf-Hanka.ITD:

Hey es reicht nicht einfach auf TLS zu klicken. Du musst manuell via Shell den Port für den Connector ändern.
1und1 akzeptiert auch auf Port 25 TLS.
Bitte warten ..
Mitglied: Dani
28.02.2014 um 16:54 Uhr
@colinardo
Da sagt das 1und1 Hilfecenter etwas anderes.


Grüße,
Dani
Bitte warten ..
Mitglied: colinardo
28.02.2014, aktualisiert um 17:05 Uhr
Zitat von Dani:
@colinardo
Da sagt das 1und1 Hilfecenter etwas anderes.
mach mal ein telnet auf Port 25 ...
220 smtp.1und1.de (mreue103) Welcome to Nemesis ESMTP server 
ehlo myhost 
250-smtp.1und1.de 
250-STARTTLS 
250-AUTH LOGIN PLAIN 
250-AUTH=LOGIN PLAIN 
250-SIZE 120000000 
250 HELP
soweit ich von einem Kollegen bei United Internet weiß, wird das auf Port 25 auch nicht abgeschaltet, nur eben die unverschlüsselte Variante via LOGIN PLAIN.

Grüße Uwe
Bitte warten ..
Mitglied: l4k3k3m4n
28.02.2014 um 17:09 Uhr
Erstmal danke für die Tips.

TLS geht bei 1und1 auch auf Port 25.
Der Fehler ist auf Port 587 identisch.

Ich habe kein öffentliches Zertifikat im Exchange installiert, das war bisher nicht nötig.
Das liegt bisher nur auf dem Reverse Proxy für owa,activesync und outlook anywhere.

Ist das das Problem?
Bitte warten ..
Mitglied: colinardo
28.02.2014, aktualisiert um 17:19 Uhr
hier solltest du kein Zertifikat für den SMTP-Dienst drin haben...

cfd694f5d5f478afab8265bfafd248c0 - Klicke auf das Bild, um es zu vergrößern

und auch mal den Zertifikatscache löschen:
http://www.msxforum.de/modules/newbb/viewtopic.php?order=ASC&topic_ ...
Bitte warten ..
Mitglied: l4k3k3m4n
28.02.2014 um 17:27 Uhr
Für den Datenbankserver liegt da ein selbstsigniertes Zertifikat für SMTP drinnen.
Hat Exchange wohl so angelegt. Und das ist falsch?
Bitte warten ..
Mitglied: colinardo
28.02.2014, aktualisiert um 17:51 Uhr
probier erst mal das hier, letzter Kommentar:
http://www.msxforum.de/modules/newbb/viewtopic.php?order=ASC&topic_ ...

oft hilft es auch in diesem Fall den Send-Connector zu löschen und einen neuen anzulegen..
Bitte warten ..
Mitglied: l4k3k3m4n
28.02.2014 um 23:12 Uhr
Ich habe das Problem gelöst.
Am selbst ausgestellten Zertifikat für SMTP lag es auch nicht.


Für die Validierung eines Zertifikats (in diesem Fall das Zertifikat des 1und1 Smarthosts) nutzt der Exchange Server die Verbindung aus den winhttp Einstellungen. Diese waren am Exchange Server nicht richtig gesetzt (da vorher nie erforderlich). Jetzt steht der Proxy drinnen und die Mails gehen auch über TLS raus. Komischer Zusammenhang, da muss man erstmal drauf kommen. Danke für die Anregungen.
Bitte warten ..
Mitglied: colinardo
28.02.2014, aktualisiert um 23:42 Uhr
Alles klar, danke für die Rückmeldung. Stimmt dann kann der Exchange ja keine CRLs der Zertifikate abrufen .... kleine Ursache große Wirkung
Hier noch der Link dazu für alle die hier vorbeischauen und das selbe Problem haben:
http://technet.microsoft.com/de-de/library/bb430772(v=exchg.141).aspx

Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange das Senden über dem Smarthost per TLS, SSL beibringen
Anleitung von minimalwerkExchange Server1 Kommentar

Hallo liebe Community, da ja die Umstellung bei einigen großen Providern vor der Tür steht hier mal eine kleine ...

Exchange Server
Exchange Mail Empfang über MX Record und Versand über SmartHost
gelöst Frage von manuelwExchange Server24 Kommentare

Hallo ich beschäftige mich gerade mit MS Exchange und hätte dazu eine Frage. Ich würde meine E-Mails gerne über ...

E-Mail
SMTP over TLS mit Exchange 2010 und 1und1 realisieren
gelöst Frage von Maexx77E-Mail22 Kommentare

Hallo, ein großer Kunde, nennen wir ihn AUTOBAUER, fordert von uns, dass wir die eMail Kommunikation mit ihm zwischen ...

Exchange Server
Exchange 2010 - 1und1 Smarthost - Sendeconnector per SSL (Port 587)
gelöst Frage von BlueStarDEExchange Server38 Kommentare

Hallo zusammen ab 2014 erlaubt 1&1 wohl nur noch den Versand und Empfang von Mails über SSL. Das heißt, ...

Neue Wissensbeiträge
Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 2 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 3 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Digitiales Fernsehen

Apple TV: Amazon Prime App ist verfügbar

Information von Frank vor 4 TagenDigitiales Fernsehen4 Kommentare

Die Amazon Prime Video App kann ab sofort auf einem Apple TV ab der 3 Generation installiert werden. Einfach ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...